Package Details: gateone-git 1.1_r521.g6ae1d01-2

Git Clone URL: https://aur.archlinux.org/gateone-git.git (read-only)
Package Base: gateone-git
Description: Web-based terminal emulator and SSH client
Upstream URL: https://github.com/liftoff/GateOne
Licenses: AGPL3
Submitter: figue
Maintainer: WorMzy
Last Packager: WorMzy
Votes: 22
Popularity: 0.005609
First Submitted: 2011-10-13 22:26
Last Updated: 2018-08-15 14:05

Dependencies (13)

Required by (0)

Sources (1)

Latest Comments

1 2 3 Next › Last »

WorMzy commented on 2018-08-15 14:19

Seems like a reasonable work-around until gateone gets updated. Update pushed.

neo_ch commented on 2018-08-15 11:43

I was able having GateOne to start again by replacing python2-tornado package with aur/python2-tornado-4.4. The package should be updated to depend on this latter.

WorMzy commented on 2018-08-07 13:01

Looks like it's been reported upstream: https://github.com/liftoff/GateOne/issues/711

That'd be the place to watch, although gateone development hasn't been very active as late, so there's no guarantees that it will be resolved any time soon..

connaisseur commented on 2018-08-07 10:58

With recent (2018-08-07) python2 package updates GateOne refuses to start.

As I'm unluckily only a - former - happy user of GateOne, this is just a heads up. Maybe some python2 literate person could look into the errors an post a fix (github gist / pastebin link / what-so-ever).

Thanks!

WorMzy commented on 2017-06-12 09:55

I'm not sure what you're encountering, but it's unlikely to be caused by GateOne's code directly. All setup.py does is check whether /opt/gateone exists:

if not os.path.exists('/opt/gateone'):

If this is causing problems, then it's either a bug in python itself, your permissions are very broken, or both.

What error are you getting exactly?

ReekyMarko commented on 2017-06-09 10:49

There is a problem with the way the setup.py checks if the old /opt folder exists. I haven't looked into it that much but I temporarily chowned /opt/tomcat to be able to continue the install. Somehow setup.py needed to have a look in there, no idea why though...

Ken commented on 2014-03-07 08:23

Sorry, i missed something, nevermind about the version, and thanks for the update

WorMzy commented on 2014-03-06 22:23

Thanks for the heads up, though I don't know what you mean by the version number not being good. Could you elaborate?

Ken commented on 2014-03-06 20:53

I think i the last version, you need python html5lib in order for it to run, also the version number is not good anymore

WorMzy commented on 2013-11-16 07:56

Note that, if you've run gateone from it's new location as root before, you may get some file conflicts during the latest update, Assuming that these are all .pyc files in /usr/lib/python2.7/site-packages/gateone/, you can safely use --force to install this one package (do not force an entire upgrade). Alternatively, manually remove the conflicting files from your filesystem, then upgrade the package.

If you get conflicts outside of /usr/lib/python2.7/site-packages/gateone/, let me know.