Package Details: gateone-git 1.1_r502.g1d0e803-1

Git Clone URL: https://aur.archlinux.org/gateone-git.git (read-only)
Package Base: gateone-git
Description: Web-based terminal emulator and SSH client
Upstream URL: https://github.com/liftoff/GateOne
Licenses: AGPL3
Submitter: figue
Maintainer: WorMzy
Last Packager: WorMzy
Votes: 20
Popularity: 0.501443
First Submitted: 2011-10-13 22:26
Last Updated: 2016-01-25 12:04

Dependencies (14)

Required by (0)

Sources (1)

Latest Comments

Ken commented on 2014-03-07 08:23

Sorry, i missed something, nevermind about the version, and thanks for the update

WorMzy commented on 2014-03-06 22:23

Thanks for the heads up, though I don't know what you mean by the version number not being good. Could you elaborate?

Ken commented on 2014-03-06 20:53

I think i the last version, you need python html5lib in order for it to run, also the version number is not good anymore

WorMzy commented on 2013-11-16 07:56

Note that, if you've run gateone from it's new location as root before, you may get some file conflicts during the latest update, Assuming that these are all .pyc files in /usr/lib/python2.7/site-packages/gateone/, you can safely use --force to install this one package (do not force an entire upgrade). Alternatively, manually remove the conflicting files from your filesystem, then upgrade the package.

If you get conflicts outside of /usr/lib/python2.7/site-packages/gateone/, let me know.

WorMzy commented on 2013-11-14 21:37

Fingers crossed this will work for everyone for now. Not sure if it's a bug, or if I'm missing a configuration flag, but it's dumping half the package to /usr/gateone for some reason. I've hacked it into the right place in the PKGBUILD, so if it starts failing, please let me know (mark out-of-date or add a comment), that'll mean it's been fixed upstream (hopefully).

I'll investigate some more tomorrow.

WorMzy commented on 2013-11-14 15:58

There's been a biiiig change in way upstream installs things (basically they've stopped dumping everything in /opt). Rest assured that I'm working on an update (or will be once I get home from work). You'll probably need to do some manual moving of files from /opt to the new locations, but hopefully it won't be too painful.

maddien commented on 2013-11-14 15:13

Please add 'python2-setuptools' to (make)depends.

Also, build fails:
/var/abs/local/yaourtbuild/gateone-git/./PKGBUILD: Line 29: cd: /var/abs/local/yaourtbuild/gateone-git/pkg/gateone-git/opt/gateone: Unknown file or directory

hazard commented on 2013-11-07 09:03

Add 'python2-futures' to depends. And 'dtach' to optdepends.

Hopefully the X11 functionality will be released soon.

ankz commented on 2013-03-11 10:51

GateOne is so full of bugs it's scary.

ankz commented on 2013-03-02 02:53

tommis, I believe that error is fixed now; the modules are installed and are able to be imported. Can you confirm?

tommis commented on 2013-02-28 20:17

Some info about the previous import error: https://github.com/liftoff/GateOne/issues/214

tommis commented on 2013-02-28 15:14

I get 'ImportError: No module named onoff' even though the onoff.py is in the right place.

ankz commented on 2013-02-20 05:10

I've updated this package. There is now also a systemd service for GateOne.

figue commented on 2013-02-19 23:50

I disown that package because I don't use it anymore. Sorry for the silence all this time.

Feel free to adopt it.

ankz commented on 2013-02-19 23:26

server.conf is out of date.

ankz commented on 2013-01-25 07:27

Optional dependency on python2-imaging

Anonymous comment on 2012-04-18 16:11

Thanks for this package. I have written an initscript for this in case anyone needed one or for inclusion in the package.

#!/bin/bash

. /etc/rc.conf
. /etc/rc.d/functions

case "$1" in
start)
stat_busy "Starting GateOne daemon"
python2 /opt/gateone/gateone.py &> /dev/null &
{ add_daemon "gateoned"; stat_done; }
;;
stop)
stat_busy "Stopping GateOne daemon"
python2 /opt/gateone/gateone.py --kill &> /dev/null &&
{ rm_daemon "gateoned"; stat_done; } ||
{ stat_fail; exit 1; }
;;
restart)
$0 stop
sleep 1
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
;;
esac
exit 0

oliver_aur commented on 2012-02-18 00:21

thanks for posting, hazard. I was wondering where the server.conf was :-)

hazard commented on 2012-02-17 00:18

Change PKGBUILD dependency python2-kerberos to python2-krbv.
Reason: python2-kerberos fails to build due to compile error.

Tested and this works (:

Run:
# /opt/gateone/gateone.py
(generates /opt/gateone/server.conf)

URL: https://localhost:443

figue commented on 2011-10-13 22:26

Initial release