Package Details: gazebo 10.1.0-4

Git Clone URL: https://aur.archlinux.org/gazebo.git (read-only, click to copy)
Package Base: gazebo
Description: A multi-robot simulator for outdoor environments
Upstream URL: http://gazebosim.org/
Licenses: Apache
Submitter: None
Maintainer: billypilgrim
Last Packager: billypilgrim
Votes: 28
Popularity: 0.50
First Submitted: 2008-10-18 22:59
Last Updated: 2020-01-16 12:11

Dependencies (33)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

billypilgrim commented on 2019-10-04 09:45

This is an issue with the libpgm package (which I can't seem to find on the bugtracker right now).

The way to fix it is to remove the non-existent path from /usr/lib/pkgconfig/openpgm-5.2.pc.

zigas commented on 2019-10-03 20:23

Hi, I'm having problems installing this package, this is the error pamac gives when installing ignition-transport 4: "CMake Error in src/CMakeLists.txt: Imported target "ZeroMQ::ZeroMQ" includes non-existent path "/usr/lib/pgm-5.2/include" in its INTERFACE_INCLUDE_DIRECTORIES."

billypilgrim commented on 2019-09-23 06:18

@acxz thanks for letting me know. Hopefully upstream will fix this at some point.

acxz commented on 2019-09-22 21:57

Posting this github issue here since it relates to this PKGBUILD. https://github.com/ros-melodic-arch/ros-melodic-desktop-full/issues/2

acxz commented on 2019-08-08 16:45

@billypilgrim The source installation page for Gazebo (http://gazebosim.org/tutorials?tut=install_dependencies_from_source&cat=install) states that the following dependencies have to be a specific version:

sdformat=6 ignition-common=1 ignition-fuel-tools=1 ignition-math=4 ignition-transport=4 ignition-msgs=1 ignition-cmake=0

As of right now, only ignition-math/transport and sdformat are specified. If the others can be specified that would prevent users from downloading unnecessary higher versioned ignition packages.

acxz commented on 2019-07-08 18:41

The thing with packages like libtar, libccd, etc. is that there is no package in the official repos or the AUR that offers any version below the specified version. Therefore there is no need to specify versioned dependencies for those packages, it is redundant. Any package of libtar you can get will be versioned >= 1.2.

billypilgrim commented on 2019-07-08 14:50

@acxz is right that you do need specific versions of these dependencies. There's an upstream issue with their build system: https://bitbucket.org/osrf/gazebo/issues/2638/gazebo-source-build-error

I assume that whoever put in the specific versions of libtar and curl that are needed did so because Gazebo won't work with older versions.

acxz commented on 2019-07-06 00:41

@Morganamilo I am 100% sure (you can go ahead and try building it yourself if you do not believe me).

I do agree with you on the second point tho. The version dependencies of libtar>=1.2 and curl>=4 are completely unnecessary and should be removed.

Morganamilo commented on 2019-07-05 17:13

@acxz are you totally sure?

If this package truly requires sdformat=6 and say, not 5 or 7, then that's fair enough.

But arch's general policy is to not over use versioned depends. There's no need to specify stuff like libtar>=1.2 and curl>=4. And your total over use of versioned depends leads me to assume sdformat=6 is also unneeded.

acxz commented on 2019-07-05 16:57

@Morganamilo Versioned depends are needed for this package, since the package does not build with other versions of that dependency. Would there be a better way?