Package Details: gb-studio-bin 1.1.0-1

Git Clone URL: https://aur.archlinux.org/gb-studio-bin.git (read-only)
Package Base: gb-studio-bin
Description: Visual retro game maker
Upstream URL: https://gbstudio.dev
Licenses: MIT
Provides: gb-studio
Replaces: gb-studio
Submitter: noirscape
Maintainer: noirscape
Last Packager: noirscape
Votes: 2
Popularity: 0.492323
First Submitted: 2019-05-23 08:53
Last Updated: 2019-05-23 08:53

Latest Comments

noirscape commented on 2019-05-23 09:26

@muvori - I wasn't entirely sure of all the required dependencies. As a result, I used a program to automatically pull them from the control file, which might have been a bit overzealous.

@sangy - Thanks a ton, this helped reduce the list of dependencies to something much more logical and manageable.

noirscape commented on 2019-05-23 09:12

@polyzen - I have created a new package called gb-studio-bin and filed the merge request. As this is my first time filing one, I hope I did everything properly.

(I also used replaces= which apparently needs to be done when renaming a package?)

polyzen commented on 2019-05-08 18:45

Please also rename this package to gb-studio-bin: https://wiki.archlinux.org/index.php/Arch_User_Repository#Merge

Edit: Packages that use prebuilt deliverables, when the source is available, must use the -bin suffix. The only exception I'm aware of is with Java.

sangy commented on 2019-05-07 00:25

To expand on @muvori's comment, the dependencies listed on the debian control file should be useful for you:

 1 Package: gb-studio
  2 Version: 1.0.0-1
  3 Section: utils
  4 Priority: optional
  5 Architecture: amd64
  6 Depends: libgtk-3-0, libnotify4, libnss3, libxss1, libxtst6, xdg-utils, libuuid1, kde-cli-tools | kde-runtime | trash-cli | libglib2.0-bin | gvfs-bin
  7 Recommends: pulseaudio | libasound2
  8 Suggests: gir1.2-gnomekeyring-1.0, libgnome-keyring0, lsb-release
  9 Installed-Size: 337440
 10 Maintainer: cmaltby
 11 Description: Visual retro game maker
 12  Visual retro game maker

muvori commented on 2019-05-06 15:50

these dependencies are whack