Package Details: gbdfed 1.6-3

Git Clone URL: https://aur.archlinux.org/gbdfed.git (read-only)
Package Base: gbdfed
Description: A GTK2 bitmap font editor
Upstream URL: http://www.math.nmsu.edu/~mleisher/Software/gbdfed/
Licenses: MIT
Submitter: None
Maintainer: pzl
Last Packager: pzl
Votes: 34
Popularity: 0.517951
First Submitted: 2006-06-16 13:20
Last Updated: 2015-08-08 15:41

Latest Comments

speps commented on 2013-05-13 22:10

@oliwer Hi, you should put something like
head -n21 $pkgname.c > "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
in your PKGBUILD to include the required custom MIT license. Cheers

Ypnose commented on 2012-09-11 16:54

The sources are offline. Could you upload them, somewhere?

Anonymous comment on 2012-07-24 18:35

This is amazing. I've been wanting to make bitmap fonts for years, and now I can! Thank you for finding and providing this package!

oliwer commented on 2011-11-23 20:40

Updated! Thanks OK100 (weird nickname).

OK100 commented on 2011-11-19 20:56

Hi, please include this patch. It fixes the problem described here:
https://bbs.archlinux.org/viewtopic.php?id=121113

--- glyphedit.c.orig 2010-04-16 16:39:04.000000000 +0200
+++ glyphedit.c 2011-11-19 21:38:26.467479537 +0100
@@ -104,7 +104,8 @@ enum {
GLYPH_MODIFIED = 0,
POINTER_MOVED,
OPERATION_CHANGE,
- COLOR_CHANGE
+ COLOR_CHANGE,
+ NUM_SIGNALS
};

/**************************************************************************
@@ -114,7 +115,7 @@ enum {
**************************************************************************/

static GtkWidgetClass *parent_class = 0;
-static guint glyphedit_signals[OPERATION_CHANGE + 1];
+static guint glyphedit_signals[NUM_SIGNALS];

/**************************************************************************
*

bbenne10 commented on 2011-03-26 17:32

As of the time of me writing this, it seems that the homepage for gbdfed is down. I've rewritten the source array in the PKGBUILD to include a different download location for both the source tarball and the imge (though the image isn't exactly the same, it's a tango icon that fits relatively well). You can find the updated PKGBUILD here: http://www.ompldr.org/vN3o0dQ

I didn't generate new md5sums, so this'll need to be built with 'makepkg --skipinteg'.

bbenne10 commented on 2011-03-26 16:05

As of the time of me writing this, it seems that the homepage for gbdfed is down. I've rewritten the source array in the PKGBUILD to include a different download location for both the source tarball and the imge (though the image isn't exactly the same, it's a tango icon that fits relatively well). You can find the updated PKGBUILD here: http://www.ompldr.org/vN3o0dQ

I didn't generate new md5sums, so this'll need to be built with 'makepkg --skipinteg'.

oliwer commented on 2010-11-26 19:57

Done! Thanks for the alert.

keenerd commented on 2010-11-23 20:26

From their homepage: "To compile gbdfed with GTK+ 2.22, please remove the *_DEPRECATED flags from the CFLAGS line in the Makefile."

Please apply this.