Package Details: gcc44-multilib 4.4.7-4

Git Clone URL: https://aur.archlinux.org/gcc44-multilib.git (read-only)
Package Base: gcc44-multilib
Description: The GNU Compiler Collection, version 4.4.7 - multilib version
Upstream URL: http://gcc.gnu.org
Licenses: GPL, custom, LGPL
Conflicts: gcc44
Provides: gcc44
Submitter: utak3r
Maintainer: ItachiSan
Last Packager: ItachiSan
Votes: 4
Popularity: 0.018438
First Submitted: 2012-10-03 12:42
Last Updated: 2015-06-23 10:18

Dependencies (7)

Required by (3)

Sources (8)

Latest Comments

sl1pkn07 commented on 2015-07-03 18:39

oh, i saw this in other gccxx{,-multilib} packages

# Move potentially conflicting stuff to version specific subdirectory
$(ls "$pkgdir"/usr/lib/gcc/$CHOST/lib* &> /dev/null) && mv "$pkgdir"/usr/lib/gcc/$CHOST/lib* "$pkgdir/usr/lib/gcc/$CHOST/$pkgver/"

this is correct?

sl1pkn07 commented on 2015-07-03 18:28

tested gcc46-mltilib. i have same behavior with same files :S

note:

add this to disable doc build (no need texinfo_5 patch)

mkdir -p makeinfo-path
ln -s /usr/bin/false "${srcdir}/makeinfo-path/makeinfo"
export PATH="${srcdir}/makeinfo-path:$PATH"

sl1pkn07 commented on 2015-06-30 23:08

Hi @itachisan

this is my gcc49-multilib pkgbuild

http://sl1pkn07.wtf/paste/view/637decd3

is like your gcc44-multilib but with some changes to build gcc4.9.3. i'm not sure if i missing something.

not use a gcc49-multilib from [aur] because is a replace of gcc-multilib for [multilib] repositories. i dont know if has been changed since my last try

greetings

ItachiSan commented on 2015-06-30 10:28

@sl1pkn07 I tried installing both gcc44-multilib and gcc46-multilib and they works fine.
Looking at gcc49-multilib PKGBUILD, it seems to conflict with other packages, so I think it needs some rework in order to make it install properly.

ItachiSan commented on 2015-06-29 10:29

@sl1pkn07 sincerly I don't know, I never tried do install 2 different gcc-multilib; I can test as soon as possible, but I can't promise you anything.

sl1pkn07 commented on 2015-06-28 13:16

i have a little trouble. the package build and install OK. but when try to build another gcc-multilib (for example, your pkgbuild with changes for GCC 4.9.3). this build OK, but when install make conflicts with 2 files:

/usr/lib/gcc/x86_64-unknown-linux-gnu/lib/libgcc_s.so.1 (and symlink)
/usr/lib/gcc/x86_64-unknown-linux-gnu/lib32/libgcc_s.so.1 (and symlink)

this is spected? I can't install both gccs in same time?

greetings

ItachiSan commented on 2014-06-01 09:31

Aaaaaand it's updated. ;)

utak3r commented on 2014-05-31 20:45

It's disowned now, so you can adopt it :)

ItachiSan commented on 2014-05-31 14:08

Here you have:
https://aur.archlinux.org/packages/gcc44-multilib-android/

ItachiSan commented on 2014-05-31 07:22

I need it for Android compiling, so I will update it.
I've akready a working PKGBUILD, so let me know if you're going to disown the package or if I've to send you my source package.

All comments