Package Details: gcc44 4.4.7-6

Git Clone URL: https://aur.archlinux.org/gcc44.git (read-only, click to copy)
Package Base: gcc44
Description: The GNU Compiler Collection (4.4.x)
Upstream URL: http://gcc.gnu.org/
Licenses: GPL, custom, LGPL
Conflicts: gcc44-multilib
Submitter: None
Maintainer: severach
Last Packager: severach
Votes: 69
Popularity: 0.000000
First Submitted: 2010-05-28 14:46
Last Updated: 2017-09-13 15:17

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

xyproto commented on 2013-03-15 10:57

Thank you, vladmihaisima. Updated the package.

Anonymous comment on 2013-03-14 22:46

With texinfo 5.0-1 it fails with the following error:

if [ xinfo = xinfo ]; then \
makeinfo --split-size=5000000 --split-size=5000000 --split-size=5000000 --no-split -I . -I ../../gcc/doc \
-I ../../gcc/doc/include -o doc/cpp.info ../../gcc/doc/cpp.texi; \
fi
../../gcc/doc/cppopts.texi:761: @itemx must follow @item
make[3]: *** [doc/cpp.info] Error 1

Workaround (will not generate some docs):
- add the following line in the PKGBUILD before configure (currently line 43)
sed -i 's/BUILD_INFO=info/BUILD_INFO=/' ../gcc/configure
- comment or remove the for loop in package() (currently lines 70-73)

xyproto commented on 2012-11-14 01:39

Updated to 4.4.7.

xyproto commented on 2012-02-26 14:43

TamCore, works fine here. Have you installed base-devel first? https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started Are all packages up to date?

TamCore commented on 2012-02-26 11:38

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libstdc++.so when searching for -lstdc++
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libstdc++.a when searching for -lstdc++
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libstdc++.so when searching for -lstdc++
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libstdc++.a when searching for -lstdc++
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libgcc.a when searching for -lgcc
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.6/libgcc.a when searching for -lgcc
/usr/bin/ld: cannot find -lgcc

When compiling an 32bit project. Any suggestions?

xyproto commented on 2012-02-12 16:42

Updated to gcc 4.4.6.

xyproto commented on 2011-12-02 15:54

Since this package has been an orphan for three weeks now, I'll adopt it.

GordonGR commented on 2011-11-21 14:21

Cloog or no cloog, it doesn't compile for me either. After a lot of building I get
ar: libbackend.a: No space left on device
and it stops :(

xyproto commented on 2011-11-10 12:57

This package has been flagged out of date from 22 Feb 2011 to 10 Nov 2011. Fixed the PKGBUILD and orphaned the package. Sincerely yours, a random TU.

xyproto commented on 2011-11-10 12:28

Please depend on cloog instead of cloog-ppl>=0.15.8