Package Details: gcc49-multilib 4.9.4-2

Git Clone URL: https://aur.archlinux.org/gcc49-multilib.git (read-only)
Package Base: gcc49-multilib
Description: The GNU Compiler Collection for multilib (4.9.x)
Upstream URL: http://gcc.gnu.org
Licenses: GPL, custom, LGPL, FDL
Conflicts: gcc49
Provides: gcc49
Submitter: yurikoles
Maintainer: severach
Last Packager: severach
Votes: 5
Popularity: 0.000039
First Submitted: 2015-06-28 10:59
Last Updated: 2018-08-30 02:56

Dependencies (8)

Required by (9)

Sources (7)

Latest Comments

« First ‹ Previous 1 2

neTpK commented on 2016-08-08 19:36

Thanks for clarifying. I will try out both of your tips.

severach commented on 2016-08-08 11:58

% gcc --version
gcc (GCC) 6.1.1 20160802
I'm building with the current gcc just fine. The line to build with an older version of gcc is already in the PKGBUILD. Just enable it.

The bug is due to the C++ ABI change. On some systems link picks the right library. On others it is necessary to enable LD_PRELOAD to force the right one. I'm hoping someone has an explanation of why library selection is so erratic.

r08 commented on 2016-08-08 11:30

@petterk That's your problem. You're compiling with a compiler not tested enough and prone to bugs like this. Downgrade to arch's GCC 5.3 and you'll be able to build GCC 4.9.4
Also note that if you want GCC 4.9.4 for compiler reliability, I suggest you update to GCC 5.4 after downgrading to GCC 5.3. It's just as reliable as GCC 4.9.4 but newer.

neTpK commented on 2016-08-08 11:22

To clarify:

$ gcc --version
gcc (GCC) 6.1.1 20160802

neTpK commented on 2016-08-08 11:19

make[6]: *** [Makefile:553: libstdc++.la] Error 139
make[5]: *** [Makefile:583: all-recursive] Error 1
make[4]: *** [Makefile:485: all-recursive] Error 1
make[3]: *** [Makefile:391: all] Error 2
make[2]: *** [Makefile:13606: all-stage1-target-libstdc++-v3] Error 2
make[1]: *** [Makefile:21618: stage1-bubble] Error 2
make: *** [Makefile:894: all] Error 2
/usr/bin/makepkg: line 729: logpipe: unbound variable

severach commented on 2016-08-07 21:41

libstdc++.so.6: version `GLIBCXX_3.4.21' not found

No compile errors on Arch Linux or Manjaro. Compile error on Antergos. To compile, enable the 2 LD_PRELOAD lines.

neTpK commented on 2016-08-07 12:08

make[6]: *** [Makefile:553: libstdc++.la] Error 139
make[5]: *** [Makefile:583: all-recursive] Error 1
make[4]: *** [Makefile:485: all-recursive] Error 1
make[3]: *** [Makefile:391: all] Error 2
make[2]: *** [Makefile:13606: all-stage1-target-libstdc++-v3] Error 2
make[1]: *** [Makefile:21618: stage1-bubble] Error 2
make: *** [Makefile:894: all] Error 2
/usr/bin/makepkg: line 729: logpipe: unbound variable

LeonardK commented on 2016-02-22 19:36

With LLVM & GCC5 installed build might fail due to this:

/tmp/gcc49-multilib/src/gcc-build/x86_64-unknown-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/bin/../bin/../lib/bfd-plugins/LLVMgold.so)

This was also the issue with gcc48, but this commit fixed it via environment-variables:
https://aur.archlinux.org/cgit/aur.git/commit/?h=gcc48&id=d6c1e9ab18bccca006a5107a6db2b1d25c8a613a

Also see the comments for more info:
https://aur.archlinux.org/packages/gcc48/?comments=all


Maybe this should be included here too?

mareex commented on 2015-11-14 15:03

I am just building this package. The tests are very time consuming and probably have no valuable effect. Can these not be disabled by default?

gavinhungry commented on 2015-07-01 06:48

I tried to build with GCC 5.1.0 and GCC 4.9.2 (from Rollback machine), both failed. What version are you using to (successfully) build?