Package Details: gcc5 5.5.0-4

Git Clone URL: https://aur.archlinux.org/gcc5.git (read-only)
Package Base: gcc5
Description: The GNU Compiler Collection (5.x.x)
Upstream URL: http://gcc.gnu.org
Licenses: GPL, custom, LGPL, FDL
Submitter: yan12125
Maintainer: yan12125
Last Packager: yan12125
Votes: 15
Popularity: 2.111538
First Submitted: 2017-10-23 06:02
Last Updated: 2018-02-10 20:27

Pinned Comments

yan12125 commented on 2017-11-21 17:42

Building this package requires several gigas of disk space and may require several hours of time if you're using an older hardware. If you can't afford that, you can download 3rd party prebuilt packages from the following locations:

https://mirrors.tuna.tsinghua.edu.cn/arch4edu/x86_64/ https://cdn.repo.archlinuxcn.org/x86_64/

Beware that those gcc packages are not built the maintainer on AUR (yan12125). Use it with care.

yan12125 commented on 2017-11-11 16:31

The recommended way to build this package is using clean chroots [1]. If you use plain makepkg or AUR helpers (yaourt, pacaur, ...), you'll need to take care by yourself.

If building does not succeed with clean chroots, please open an issue at https://github.com/yan12125/aur with a title starting with "gcc5: ". I've disabled notifications here as there are too many non-constructive comments.

[1] https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_Clean_Chroot

Latest Comments

alfredo.ardito commented on 2018-03-09 23:16

@Ergo, thx. I'll check it out.

Ergo commented on 2018-03-09 22:02

@alfredo.ardito I got the same error building and for me it was fixed preloading my actual libstdc++. I got the solution from the gcc53-alternative-multilib package and the explication is simple but long. Is is just.

export LD_PRELOAD=/usr/lib/libstdc++.so.6

Hope this could help and maybe this package's maintainer could consider add this line in the PKGBUILD. In order to avoid chroots and so on.

klore commented on 2018-02-27 15:56

can't compile

tmp/yaourt-tmp-user/aur-gcc5/src/gcc-5.5.0/libiberty/fibheap.c:368:3: warning: incompatible implicit declaration of built-in function ‘memset’ /tmp/yaourt-tmp-user/aur-gcc5/src/gcc-5.5.0/libiberty/fibheap.c:368:3: note: include ‘<string.h>’ or provide a declaration of ‘memset’ make[3]: [Makefile:752: fibheap.o] Error 1 make[3]: Leaving directory '/tmp/yaourt-tmp-user/aur-gcc5/src/gcc-build/libiberty' make[2]: [Makefile:10252: all-stage1-libiberty] Error 2 make[2]: Leaving directory '/tmp/yaourt-tmp-user/aur-gcc5/src/gcc-build' make[1]: [Makefile:22897: stage1-bubble] Error 2 make[1]: Leaving directory '/tmp/yaourt-tmp-user/aur-gcc5/src/gcc-build' make: [Makefile:905: all] Error 2</string.h>

ewtoombs commented on 2018-02-16 03:08

I got the same error as everybody else. Why does this package need to be built in a chroot? Are some other packages on my system interfering with the build process? Maybe llvm? I'd appreciate not having to use a chroot. They're a real PITA.

FrederickZh commented on 2018-02-11 14:06

@yan12125 Thanks, I successfully built it in a clean chroot and it should be fine now :)

@kingcreole You may use the scripts from https://www.archlinux.org/packages/extra/any/devtools/

kingcreole commented on 2018-02-11 14:02

i can't use '''# arch-nspawn $CHROOT/root pacman -Syu''' to update my chroot, as it automatically resets the mirrorlist to some mirrorlist with only one sever that gives back a 404, every chroot interaction does this, anyone else got this problem? how do you get around it?

update: i found out i can use '''# arch-nspawn -S /etc/pacman-mirrors.conf $CHROOT/root pacman -Syu''' but it's not perfect as makechrootpkg will propably still reset the mirrorlist if i'm right...

yan12125 commented on 2018-02-11 10:28

@FrederickZh, @alfredo.ardito: most likely you need to build this in clean chroots.

alfredo.ardito commented on 2018-02-11 10:16

Got this error when building:

version `GLIBCXX_3.4.22' not found (required by /usr/lib/libLLVM-5.0.so)

FrederickZh commented on 2018-02-10 23:35

Got /pacaur/gcc5/src/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/src/.libs/libstdc++.so.6: version `GLIBCXX_3.4.22' not found (required by /usr/lib/libLLVM-5.0.so)

Having glibc 2.26-11 installed.

GPereira commented on 2018-02-08 16:35

I am getting this error: ==> ERROR: Unknown download protocol: file Aborting...

All comments