Package Details: gcstar 1.8.0-3

Git Clone URL: https://aur.archlinux.org/gcstar.git (read-only, click to copy)
Package Base: gcstar
Description: Collection manager written in Perl and based on GTK
Upstream URL: https://gitlab.com/GCstar/GCstar
Licenses: GPL-2.0-or-later
Submitter: Barthalion
Maintainer: carsme
Last Packager: carsme
Votes: 10
Popularity: 0.69
First Submitted: 2018-01-06 19:16 (UTC)
Last Updated: 2024-01-28 22:34 (UTC)

Latest Comments

1 2 3 Next › Last »

kerenoc commented on 2023-06-27 10:23 (UTC)

Thanks for packaging 1.8.0.

I tried to install GCstar on a fresh Manjaro 23.0.0 / Plasma distribution and had an error as one of the GCstar's dependencies perl-ogg-vorbis-header-pureperl required "make" to be built. This dependency can be made optional for GCstar (only used to analyse some audio files) or make could be added to this library's dependencies or make could be added to GCstar dependencies.

haawda commented on 2023-01-21 20:52 (UTC)

I do not see 1.8.0 anywhere.

ignace1972 commented on 2023-01-21 14:25 (UTC)

Hello, version 1.8.0 was released 9 months ago.

kerenoc commented on 2022-06-29 14:28 (UTC)

Hello,

In order to apply for the Gitlab Open Source program, I changed the namespace of GCstar from Kerenoc (my account) to GCstar (a Gitlab group).

The updates of the 1.7.3 version are now in the main branch of the git+https://gitlab.com/GCstar/GCstar.git

As the gcstar-git package name is still available in AUR, it could be used to directly build the latest versions from git.

kerenoc commented on 2022-03-18 23:14 (UTC) (edited on 2022-06-29 14:28 (UTC) by kerenoc)

I'm only testing Manjaro as a user was experiencing a bug on that system. I just used a LiveCD version that may be too old. I'll check the latest version to see if GCstar can be run out of the box using this package.

The gcstar-gitlab package is based on Gtk2 instead of Gtk3. It may be useful to keep the 2 versions

haawda commented on 2022-03-18 22:26 (UTC)

perl-params-validationcompiler is pulled by perl-datetime, which is pulled by perl-datetime-format-strptime, so it is not necessary to add it explicitely under Arch. On the other hand it does not harm to add it.

About the glibc packages: Why do you have outdated packages for these central packages installed? Is this a Manjaro thingy? If so, I do not use Manjaro and cannot support it reliantly.

Pulling directly from git is possible, but it is not usual to do this in packages without a -git suffix in name. This could be done in a gcstar-git package in AUR. And itis done by the (wrongly named an badly written) gcstar-gitlab package in AUR.

kerenoc commented on 2022-03-17 22:46 (UTC)

Hello,

I'm the GCstar maintainer, thank you for packaging this app for ArchLinux and its derivatives. I'm testing the installation process on Manjaro. The installation fails when using the pamac-manager and enabling AUR.

I had to manually install the package perl-params-validationcompiler and update the lib32-glibc and glibc packages. Is there a way to automate these steps?

The Gtk3 version of GCstar seems stable now and I plan to merge it as the main branch on Gitlab. Can AUR directly fetch this upstream via git instead of using an archive?

warp4ever commented on 2022-02-11 22:44 (UTC)

Fixed:

Discogs: sudo cpan JSON / Musicbrainz: sudo cpan Locale::Country

warp4ever commented on 2022-02-11 21:53 (UTC) (edited on 2022-02-11 22:43 (UTC) by warp4ever)

Runs nice, although in GCMusic only Douban search is available. (sorry no code block)

Plugins : loading error with plugin GCDiscogs : Can't locate JSON.pm in @INC (you may need to install the JSON module)

Plugins : loading error with plugin GCMusicBrainz : Can't locate JSON.pm in @INC (you may need to install the JSON module)

jmvazquezes commented on 2021-12-06 08:41 (UTC)

Sorry, brab is right. Install first "perl-gtk3" and "perl-gtk3-simplelist"