Package Details: gdbuspp-git 1-2

Git Clone URL: https://aur.archlinux.org/gdbuspp-git.git (read-only, click to copy)
Package Base: gdbuspp-git
Description: glib2 D-Bus C++ interface
Upstream URL: https://codeberg.org/OpenVPN/gdbuspp
Keywords: c++ d-bus glib2 openvpn
Licenses: AGPL-3.0-only
Conflicts: gdbuspp
Provides: gdbuspp
Submitter: rzvncj
Maintainer: rzvncj
Last Packager: rzvncj
Votes: 0
Popularity: 0.000000
First Submitted: 2024-05-28 10:30 (UTC)
Last Updated: 2024-07-02 12:25 (UTC)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

rzvncj commented on 2024-07-02 12:27 (UTC)

Done, thanks for pointing that out!

dreieck commented on 2024-07-02 11:47 (UTC)

You need to change the license identifier to be SPDX compliant:

gdbuspp-git E: AGPLv3 is not a valid SPDX license identifier. See https://spdx.org/licenses/ for valid identifiers, or prefix the identifier with 'LicenseRef-', if it is custom.

Regards!

dreieck commented on 2024-07-02 11:46 (UTC)

You changed the provides and conflicts entey to their correct values, but you missed to increment $pkgrel on ubload.

Please increment $pkgrel and re-generate .SRCINFO and upload again to the AUR, so that the updated provides and conflicts entries are updated in the AUR database so that automatic dependency resolution with tools like yay works.

Regards and thanks for maintaining!

bhyoo commented on 2024-06-21 00:37 (UTC)

Please change provides and conflicts to gdbuspp

rzvncj commented on 2024-06-16 07:46 (UTC) (edited on 2024-06-16 07:47 (UTC) by rzvncj)

Since there's nothing we can do to prevent the packager (or the user) from running the tests in a D-Bus session different from the one belonging to the originally logged-in user, I've just disabled the tests.

This should make the package install with pikaur as well.

It's not ideal, but it works and it is what it is.

rzvncj commented on 2024-06-15 19:43 (UTC) (edited on 2024-06-15 19:44 (UTC) by rzvncj)

Sorry for the late reply, I've been travelling and without access to my Arch Linux machine.

The problem in both reports is that the tests require a D-Bus session bus (these exist one per user session, and sudo will create a new user session).

pikaur in particular uses:

sudo --user=#<UID> -- makepkg --force

to build the package, which effectively creates a new user session without its own D-Bus session bus. This leads to an attempt to automatically create a session bus, but for whatever reason Arch Linux tries to run it basically assuming an active X connection, and that fails. This is how it fails on my Wayland machine:

Error spawning command line “dbus-launch --autolaunch=e28f49469a3c43e590d80385bbb5e85d --binary-syntax --close-stderr”: Child process exited with code 1
Autolaunch requested, but X11 support not compiled in.
Cannot continue.

Long story short, if we want the tests to run before installing, pikaur is simply unusable. I bet the same fundamental problem occurs for @RockhopperP - makepkg simply ends up not being run in the same session as the currently logged in user.

So we either live with the restriction of installing this with yay in a user session that has the D-Bus session bus properly set up (and don't use pikaur), or I can just disable the automatic tests.

RockhopperP commented on 2024-06-10 10:19 (UTC)

@rzvncj

Running as currently logged-in user (in sudo-ers group). Yay works fine as an installer to any other package.

rzvncj commented on 2024-06-09 14:15 (UTC)

Are you running yay as the regular, currently-logged in user?

RockhopperP commented on 2024-06-09 09:07 (UTC)

Unfortunately yay spits out similar errors

==================================== 3/10 ====================================
test:         gdbuspp / test-data-types-dbus
start time:   08:58:38
duration:     2.01s
result:       exit status 1
command:      MALLOC_PERTURB_=88 MSAN_OPTIONS=halt_on_error=1:abort_on_error=1:print_summary=1:print_stacktrace=1 ASAN_OPTIONS=halt_on_error=1:abort_on_error=1:print_summary=1 UBSAN_OPTIONS=halt_on_error=1:abort_on_error=1:print_summary=1:print_stacktrace=1 /tmp/aurbuilder/.cache/yay/gdbuspp-git/src/gdbuspp-git/tests/scripts/run-simple-server-test /tmp/aurbuilder/.cache/yay/gdbuspp-git/src/gdbuspp-git/build/test_data-types --simple-service
----------------------------------- stdout -----------------------------------
Starting simple-server: ./test_simple-service
EXCEPTION (DBus): [DBus::Connection] Could not connect to the D-Bus: Error spawning command line “dbus-launch --autolaunch=4068b95c6d70496c95af01ffdb87e186 --binary-syntax --close-stderr”: Child process exited with code 1
Simple Service PID: 108610
-----------------------------------------------------------

I already manually installed python-xmltodict, but it did not solve this. I need gdbuspp-git as prerequisite for openvpn3.

rzvncj commented on 2024-05-30 07:04 (UTC) (edited on 2024-06-01 11:07 (UTC) by rzvncj)

I'm not sure what causes the pikaur issue. I just use yay these days. Could you debug a bit deeper to get a better idea of what's causing this?