Package Details: gdevelop-git 20161025-1

Git Clone URL: https://aur.archlinux.org/gdevelop-git.git (read-only)
Package Base: gdevelop-git
Description: A full featured, open source game development software, allowing to create HTML5 and native games without knowing a programming language. All the game logic is made thanks to an intuitive and powerful event based system.
Upstream URL: http://www.compilgames.net
Keywords: game gdevelop
Licenses: GPL, MIT, zlib/png
Provides: gdevelop
Submitter: JoseluCross
Maintainer: JoseluCross (kprkpr)
Last Packager: JoseluCross
Votes: 4
Popularity: 0.000176
First Submitted: 2016-05-28 15:40
Last Updated: 2016-10-25 05:56

Latest Comments

lgzy commented on 2017-11-24 06:22

Guys, some help would be much appreciated, if you can.
Recently started using linux, I`m with Manjaro now. I tried to yaourt the `gdevelop` package and it displayed the crash pattern you guys describe here: version 0.0.0.0, clean program break on new project. As my hardware is really weak, installing the package took many hours and I don`t want to install it wrong again, so I ask: can I just use yaourt gdevelop-git or is it going to crash the same way? Do I have to `add the repository to the pacman.conf`? (I think this is quite above my limited skills with linux) Can someone please help me with the steps to install this in a way it won`t crash this way? Should I try to download the 5.0 version from the website?
Real thanks in advance!!

kprkpr commented on 2017-06-27 22:00

+nanners, yea, maybe the solution is in the Gdevelop 5 more than this
I will create a gdevelop meanwhile without "-git", because aur as I think, say that git is for "master" developer branch
If you have any idea about retrieving master but doesnt have this bug, maybe changing with a command the version number or something like this, help me if you can :)
Hopefully it solves the problem until GD 5

EDIT: I created the gdevelop package (Its here in AUR), the version 4.0.94 works right, 4.0.95 not because it says that is version 0.0.0.0 and halts same way as -git

nanners commented on 2017-06-27 09:46

@kprkpr I'm very new to package maintanence and PKGBUILD tweaking, but I've managed to repair a couple broken, abandoned AUR builds and can use Git and Google. So if you need a hand with something, just ask. I was confused on just how changing the build name would affect this, if at all. The devs are about to roll out Gdevelop 5 as well and are hoping to have a true universal app and IDE, so there are some big changes coming as well (according to the devs anyway).

kprkpr commented on 2017-06-27 08:42

+nanners, I will try to see it, but, as this is the git master pull, is somewhat weird to no pull git master.. But we can make a non git one with the branch you say. I have little time to do it

nanners commented on 2017-06-25 22:51

Just a heads-up, but this will crash until the build is renamed to follow the dev's naming convention. I opened an issue on GitHub, here's the dev's reply explaining it:

"The crash when creating/opening a new project is due to the branch being named new-ide-beta1-16-g9fbc4613a, which is not following "major.minor.revision.patch" scheme and making the code discovering the version number crash.
Could you try again with version tagged 4.0.94? I've also created a tag 4.0.95 to avoid having users relying on new-ide-beta1 tag."

(https://github.com/4ian/GD/issues/356)

I ended up adding the repo to pacman.conf and downloading that way, per the website. Works fine.