Package Details: gdm-plymouth 3.22.1-2

Git Clone URL: https://aur.archlinux.org/gdm-plymouth.git (read-only)
Package Base: gdm-plymouth
Description: Gnome Display Manager with Plymouth support.
Upstream URL: http://www.gnome.org
Licenses: GPL
Groups: gnome
Conflicts: gdm
Provides: gdm
Submitter: damian01w
Maintainer: nullptr_t
Last Packager: nullptr_t
Votes: 45
Popularity: 3.062002
First Submitted: 2015-03-18 02:35
Last Updated: 2016-11-27 10:08

Latest Comments

nullptr_t commented on 2016-11-27 09:51

Did you try using 'pacman -Rs gdm-plymouth'? That removes all remaining unnessecary dependencies for a package.

electricprism commented on 2016-11-26 22:57

For some reason installing gdm and removing gdm-plymouth libgdm-plymouth remains. This can cause issues since it's easy to assume libgdm was installed aswell instead of just gdm.

ralt commented on 2016-11-02 11:20

Recently, I'm unable to update my arch with this error:

error: failed to prepare transaction (could not satisfy dependencies)
:: gdm-plymouth: installing gnome-shell (3.22.1+2+g5a08886-1) breaks dependency 'gnome-shell<3.21.0'

Can this package be updated to work with gnome-shell 3.22?

groundhack commented on 2016-10-31 02:57

There is something wrong with the source. Getting stuck at fetching origin

nullptr_t commented on 2016-10-26 07:28

Update 3.22.1 is online. I first updated like in the main repositories

Nexxuz commented on 2016-10-25 20:02

is the update coming soon?

justin8 commented on 2016-10-18 09:45

I'm getting the following when trying to build this in a clean chroot:

19:41:54 checking for XLIB... yes
19:41:54 checking for GTK... no
19:41:54 configure: error: Package requirements (gtk+-3.0 >= 2.91.1
19:41:54 ) were not met:
19:41:54
19:41:54 Package 'gdk-3.0' requires 'gio-unix-2.0 >= 2.49.4' but version of gio-unix-2.0 is 2.48.2
19:41:54

frosticecold commented on 2016-10-12 10:53

Was failing to upgrade to gnome 3.22

Currently reinstalled and edited the pkg build,
Replaced this string 'gnome-shell<3.21.0'
TO 'gnome-shell'

Upgrading atm, will post if everything works fine.

EDIT:

Everything works fine.
Edited the pkg build with previous line and everything 100%

Vistaus commented on 2016-09-25 08:08

Please update to 3.22, I miss this so much on 3.22 :-(

lazydays79 commented on 2016-04-18 14:00

@nullptr_t Thanks!

mcComBat commented on 2016-04-17 20:57

@nullptr_t Thanks!

nullptr_t commented on 2016-04-17 14:58

Sorry for the inconvenience. I updated the dependency to work for a full release version like 3.20.*

lazydays79 commented on 2016-04-17 08:42

@shihjay2, worked great, thanks!

shihjay2 commented on 2016-04-16 18:08

In the meantime while we wait for the maintainer to fix the package, reinstall gdm-plymouth and edit PKGBUILD at the line
depends=('plymouth' 'gnome-shell=3.20.0' 'gnome-session' 'upower' 'xorg-xrdb' 'xorg-server' 'xorg-server-xwayland' 'xorg-xhost')
and change to
depends=('plymouth' 'gnome-shell>=3.20.0' 'gnome-session' 'upower' 'xorg-xrdb' 'xorg-server' 'xorg-server-xwayland' 'xorg-xhost')

Once it is reinstalled, then you can update gnome-shell.

lazydays79 commented on 2016-04-16 17:31

So anything new about the dependency to gnome-shell?

I can't do an update since a couple of days:

:: Synchronizing package databases...
core 121.0 KiB 1247K/s 00:00 [##############################] 100%
extra 1749.6 KiB 6.65M/s 00:00 [##############################] 100%
community 3.4 MiB 9.39M/s 00:00 [##############################] 100%
multilib 161.7 KiB 11.3M/s 00:00 [##############################] 100%
archlinuxfr 11.3 KiB 1891K/s 00:00 [##############################] 100%
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gdm-plymouth: installing gnome-shell (3.20.1-1) breaks dependency 'gnome-shell=3.20.0'

justin8 commented on 2016-04-15 23:58

Probably add a <= as well so that it will block gnome shell 3.22 updates until it's ready; but get rid of the exact version match on 3.20.0

mcComBat commented on 2016-04-15 19:34

@shihjay2 +1
Getting dependency issue when trying to update gnome-shell

shihjay2 commented on 2016-04-13 23:10

Recommend changing dependency to gnome-shell to use >= instead of = as another recent update to gnome-shell recently caused upgrading to stop due to a dependency error.

nullptr_t commented on 2016-04-11 07:37

Updated and added versioned dependency to gnome-shell. I hope I'll be fast enough when gnome gets updated.

nathan1015 commented on 2016-04-10 21:17

@edrose: +1
I had to build a local package for 3.20 today...

edrose commented on 2016-04-10 11:46

Would it be possible to make the current version of gnome-shell a dependency to prevent the problems I just had when gnome-shell upgraded without this package?

nullptr_t commented on 2016-03-09 11:00

I wonder why...this package is the same as the one in the main repos except for `--without-plymouth` left out from configure parameters.

Did you enable gdm-plymouth.service from the plymouth package?

seglberg commented on 2016-03-08 16:00

For what it's worth, I had to revert to the standard gdm package because my external monitors would not wake up after blanking when using gdm-plymouth.

nullptr_t commented on 2016-01-08 20:50

I've got the repo up and running again, but the URL changed:
https://wiki.archlinux.org/index.php/Unofficial_user_repositories#nullptr_t

nullptr_t commented on 2015-12-12 17:57

NOTE: If you are using my mirror, the repo name changed to nullptr_t to reflect username change

nullptr_t commented on 2015-12-10 21:02

You can now get this package prebuild, signed and secured from my repo here by adding the following to /etc/pacman.conf

[nullptr_t]
SigLevel = Optional TrustedOnly
Server = https://www.slau.me/archlinux/mirrors/$repo/$arch

The key-id is 1607AC45
armv6h might follow when I have more time.

mrapp commented on 2015-12-03 14:06

@somepaulo: I faced the same issue. Removing libgdm-plymouth with pacman -Rdd and afterwards reinstalling it together with gdm-plymouth also solved it for me. Thank you.

somepaulo commented on 2015-12-02 17:35

An error occurs on upgrading/installing this package (libgdm-plymouth), like so:

install: cannot stat ‘/tmp/yaourt-tmp-username/aur-libgdm-plymouth/src/org.gnome.login-screen.gschema.xml’: No such file or directory
==> ERROR: A failure occurred in package_libgdm-plymouth().
Aborting...
==> ERROR: Makepkg was unable to build gdm-plymouth.

Tried removing and reinstalling to no avail.
Ended up uninstalling libgdm-plymouth with pacman -Rdd, and built both packages successfully from gdm-plymouth.

nullptr_t commented on 2015-08-10 21:12

Thats a good question. Probably because I didn't know that the gnome developers also tag unstable versions and only versions in an own branch are considered stable.

I changed the sources back to 3.16.2 and will take care that I'm not using dev releases again.

Mayzie commented on 2015-08-10 11:46

Why is this using experimental GDM sources, and not that of stable (at the time of writing, 3.16)?

ework commented on 2015-05-01 23:50

This package shows up as orphaned by yaourt because it has no maintainer. Is there a reason for that?

DoctorJellyface commented on 2015-04-19 12:15

OK, installed, because my laptop wouldn't boot after the plymouth update without this. The screen no longer blanks out between plymouth and GDM, but now the plymouth screen just freezes and waits for GDM.

DoctorJellyface commented on 2015-04-19 10:06

Thanks for the update! Before I install, what does this package actually do? Smooth transition from Plymouth to GDM?

damian01w commented on 2015-04-18 17:57

Sorry for the delay. I'm working on it now. I will update it as soon as possible.

damian01w commented on 2015-04-18 17:55

Sorry for the delay. I'm working on with now.

Frnco commented on 2015-04-17 05:55

Needs an update for 3.16, any plans on that?

oxalin commented on 2015-03-19 05:27

It seems to be in conflict with libgdm (without plymouth support).

You should probably add something like the following to the PKGBUILD:
conflicts=('libgdm')

I don't know if it is compatible with libgdm, but if so, you could also add:
replaces=('libgdm')
provides=("libgdm=$pkgver libgdm-plymouth=$pkgver")