Package Details: geant4 10.4.2-1

Git Clone URL: https://aur.archlinux.org/geant4.git (read-only)
Package Base: geant4
Description: A simulation toolkit for particle physics interactions.
Upstream URL: http://geant4.cern.ch/
Licenses: custom: http://geant4.cern.ch/license/
Conflicts: geant4_devel
Submitter: Eothred
Maintainer: donpicoro
Last Packager: donpicoro
Votes: 11
Popularity: 0.002720
First Submitted: 2010-04-08 08:54
Last Updated: 2018-05-28 11:25

Dependencies (18)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

donpicoro commented on 2018-04-13 12:46

new site, new location... Source array fixed. Thanks.

georgieff commented on 2018-04-13 01:47

tar.gz location is changed from this: http://geant4.cern.ch/support/source/geant4.10.04.p01.tar.gz to this: http://cern.ch/geant4-data/releases/geant4.10.04.p01.tar.gz

donpicoro commented on 2017-12-29 13:13

Sorry, not a clue =( I enabled it by default to be inclusive but I myself use the QT driver...

If you know the source and how to compile it I am willing to upload it and maintain it.

Cheers,

/Pico

eisterman commented on 2017-12-28 12:33

How can i install OpenInventory with this Geant4 package? I haven't find a package on the AUR for this

donpicoro commented on 2017-12-11 08:06

Updated to 10.4 (Dec 2017)!

donpicoro commented on 2015-01-22 13:54

I do not want to roll it to everybody just yet. Mine with Qt4 work just fine. I tried with Qt5 and it seems to work as well and you help me trying it out

In order to make it work with Qt5 please when compiling comment out the following line:
#patch -Np1 Geant4InterfaceOptions.cmake < ${srcdir}/Geant4InterfaceOptions.patch

and simply change QT_SELECT=4 by QT_SELECT=5. I would appreciate the feedback if people let me know it works for them as well.

donpicoro commented on 2015-01-22 13:53

I tried and it seems like it is working but I do not want to roll it to everybody just yet. Mine with Qt4 work just fine. I tried with Qt5 and its to work as well.

In order to make it work with Qt5 please when compiling comment out the following line:
#patch -Np1 Geant4InterfaceOptions.cmake < ${srcdir}/Geant4InterfaceOptions.patch

and simply change QT_SELECT=4 by QT_SELECT=5 and try it. I would appreciate the feedback if people let me know it works for them as well.

Stevenwalton commented on 2015-01-22 07:40

Since the new package has come out are you going to add the fix for qt5?

Hell-G commented on 2014-12-16 19:21

Anybody having issues with the new Geant4 version?
I can't run my code and the official examples I have tested. I always get an error concerning the G4EMLOW data files. I have version 6.41 installed, as it comes with this package. This is also the version reported on the Geant4 homepage for version 10.01. According to the error message, it looks like that Geant4 is looking for the data file from version 6.35 of G4EMLOW but that is of course not installed anymore. Here is a sample error message:

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : em0003
issued by : G4SeltzerBergerModel::ReadData()
Bremsstrahlung data file </usr/share/geant4-ledata/G4EMLOW6.35/brem_SB/br1> is not opened!G4LEDATA version should be G4EMLOW6.23 or later.

*** Fatal Exception *** core dump ***
-------- EEEE -------- G4Exception-END --------- EEEE -------


*** G4Exception: Aborting execution ***

Thanks for your feedback!

donpicoro commented on 2014-10-27 09:53

The only reason to have the "internal" clhep as opposed the "external" one was to save the user from compiling something extra. Most of my applications work perfectly with the internal one but I guess in order to be more inclusive we can have it as a dependency until the point something breaks.

And as for the Qt, I do not justify a new release bump for it. As I said let's wait and see the actual support for Qt in the next release.