Package Details: geany-plugins-git 1.36.0.r19.g0bfe89d1-2

Git Clone URL: https://aur.archlinux.org/geany-plugins-git.git (read-only, click to copy)
Package Base: geany-plugins-git
Description: Various plugins for Geany
Upstream URL: https://plugins.geany.org/
Licenses: GPL
Conflicts: geany-plugin-markdown, geany-plugins, geany-plugins-svn
Provides: geany-plugins
Submitter: xyproto
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 38
Popularity: 0.000000
First Submitted: 2011-12-17 12:35
Last Updated: 2019-12-08 14:56

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

martinoff commented on 2014-01-06 21:10

dose not build in clean chroot
==> Updated version: geany-plugins-git 1.23.0.196.g601b1cf-1
==> Starting build()...
Waf: The wscript in '/build/geany-plugins-git/src/geany-plugins' is unreadable
Traceback (most recent call last):
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Scripting.py", line 87, in waf_entry_point
set_main_module(Context.run_dir+os.sep+Context.WSCRIPT_FILE)
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Scripting.py", line 110, in set_main_module
Context.g_module=Context.load_module(file_path)
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/extras/compat15.py", line 88, in load_module
ret=rev(path)
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Context.py", line 261, in load_module
code=Utils.readf(path,m='rU')
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Utils.py", line 85, in readf
txt=f.read()
File "/usr/lib/python3.3/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 96: ordinal not in range(128)
==> ERROR: A failure occurred in build().
Aborting...

xyproto commented on 2013-10-19 20:11

Just tried building the package, it builds fine here. Have you read https://wiki.archlinux.org/index.php/AUR#Prerequisites ?

xyproto commented on 2013-10-19 20:07

@liquibyte I don't think you understand how AUR and git works. Report upstream problems upstream to the geany-plugins developers. Only flag a package if it is out of date (if ie. version 3.0 is flagged, but 3.1 has been released). Unflagging.

liquibyte commented on 2013-10-18 02:49

Doesn't build for me at all. Even tried with autogen and make. The waf thing is a fiasco. Flagging.

SysGhost commented on 2013-08-15 05:34

This package is not valid anymore.
Quote from the README.md file:

## MultiTerm source has moved!

The [MultiTerm][mt] plugin is now part of the [Geany-Plugins][gp]
project and the latest source is hosted there. You can find the
latest `master` branch of this old repository by checking out the
[`old-master`][om] branch.

Feel free to still use the [Issue tracker][it] here to report issues
with the main plugin in the [Geany-Plugins][gp] project, it doesn't
have the [Github Issue tracker][GP] activated at the time of writing.

xyproto commented on 2013-07-09 11:15

Updated the PKGBUILD to use pkgver() etc.

Anonymous comment on 2013-04-07 18:54

This script should be updated for pacman 4.1 so that it more efficiently downloads the git repo.

xyproto commented on 2012-07-19 10:43

thanks mloskot, updated the package.

Anonymous comment on 2012-07-18 22:18

It seems geanylua plugin has some problems with building [1], so the package doesn't build too.
Temporarily, simple fix is to patch PKGBUILD to skip it:

- ./waf configure --prefix=/usr --libexecdir=/usr/lib
+ ./waf configure --prefix=/usr --libexecdir=/usr/lib --skip-plugins=geanylua

[1] http://lists.uvena.de/geany-devel/2012-July/006965.html

xyproto commented on 2011-12-31 17:47

Updated the PKGBUILD, sorry for the delay.