Package Details: geany-plugins-git 1.27.0.17.g6122e13-1

Git Clone URL: https://aur.archlinux.org/geany-plugins-git.git (read-only)
Package Base: geany-plugins-git
Description: Various plugins for Geany
Upstream URL: http://plugins.geany.org/
Licenses: GPL
Conflicts: geany-plugins, geany-plugins-svn
Provides: geany-plugins
Submitter: xyproto
Maintainer: youngunix
Last Packager: youngunix
Votes: 33
Popularity: 0.953357
First Submitted: 2011-12-17 12:35
Last Updated: 2016-05-17 18:41

Dependencies (16)

Required by (0)

Sources (1)

Latest Comments

youngunix commented on 2016-05-17 22:29

Humm! It didn't for me. Is this [makepkg --printsrcinfo > .SRCINFO] what you use?

trizen commented on 2016-05-17 18:49

pkgver was automatically updated by makepkg.

youngunix commented on 2016-05-17 18:34

Confirmed! Will update it shortly. Q: Where did you get the {pkgver=1.27.0.17.g6122e13} from?

trizen commented on 2016-05-17 11:42

The "waf" configuration system has been replaced with "autoconf/make".
A working PKGBUILD can be found at: http://pastebin.com/LYQ7cFhj

trizen commented on 2015-09-23 08:01

Also, please add "--prefix=/usr" to "./waf configure".

trizen commented on 2015-08-03 21:10

The "_skip" variable is no longer needed. All plugins build successfully.

xyproto commented on 2015-02-12 14:16

I'll also look into using python2 instead of python3, to see if it works out.

xyproto commented on 2015-02-12 14:15

Updated the package to depend on geany-git.

xyproto commented on 2015-02-12 09:28

@zegoti, thanks for the information.

Depending on old versions of lua and python, in addition to the current ones sounds like a bad idea to me, for this package.

Perhaps someone would like to create a new package for geany-plugins-git for supporting old versions of lua and python, perhaps named python2-geany-plugins-git?

Depending on the git version of geany is a good idea, I'll make that change.

zegoti commented on 2015-02-12 01:00

Hi xyproto,

someone on #geany (b4n and elextr) told me that plugin depends on python2, not 3.x
they also told me that geanylua is only supposed to work with lua 5.1, and I experienced build failures with 5.2, so it'd be great to depend on lua51.

and BTW, they also believe that if some plugins "don't build" is probably because they depend on the Git version of Geany, so that geany-plugins-git should probably depend on geany-git

xyproto commented on 2015-02-10 21:12

Updated the package. As usual for the development version of geany-plugins-git, some plugins stopped working and some plugins started working again.

geanylua now builds again, and is included.
geanygendoc, geanyprj and projectorganizer didn't build and are now excluded.

I also added a "_skip" variable at the top, if the package should fail again in the future and someone wants a really quick solution (apart from installing the official geany-plugins package).

JohnRobson commented on 2015-02-09 17:11

Hi xyproto, please, could you update this package? Thank you ;)

xyproto commented on 2014-09-29 10:29

Updated the PKGBUILD to use waf instead. The geanylua plugin currently fails to build, so it is temporarily disabled. Builds and installs here.

xyproto commented on 2014-09-29 09:03

The configure script is so close, but gets it wrong. /usr/lib/python3.4 exists but not /usr/lib/python3.4/config:

checking for Python library path... -L/usr/lib/python3.4/config -lpython3.4

Will try to find the cause of this and/or a workaround.

hansi commented on 2014-09-23 17:19

Same problem here, won't build anymore...

checking consistency of all components of python development environment... no
configure: error: in `/tmp/yaourt-tmp-jean/aur-geany-plugins-git/src/geany-plugins':
configure: error:
Could not link test program to Python. Maybe the main Python library has been
installed in some non-standard library path. If so, pass it to configure,
via the LDFLAGS environment variable.
Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
============================================================================
ERROR!
You probably have to install the development version of the Python package
for your distribution. The exact name of this package varies among them.
============================================================================

Nothing4You commented on 2014-09-06 18:49

this package is failing to build for quite some time already for me...
any ideas?

checking for Python include path... -I/usr/include/python3.4m
checking for Python library path... -L/usr/lib/python3.4/config -lpython3.4
checking for Python site-packages path... /usr/lib/python3.4/site-packages
checking python extra libraries... -lpthread -ldl -lutil
checking python extra linking flags... -Xlinker -export-dynamic
checking consistency of all components of python development environment... no
configure: error: in `/home/rschwab/build/geany-plugins-git/src/geany-plugins':
configure: error:
Could not link test program to Python. Maybe the main Python library has been
installed in some non-standard library path. If so, pass it to configure,
via the LDFLAGS environment variable.
Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
============================================================================
ERROR!
You probably have to install the development version of the Python package
for your distribution. The exact name of this package varies among them.
============================================================================

See `config.log' for more details

in config.log i found the following:

configure:17434: checking consistency of all components of python development environment
configure:17460: gcc -o conftest -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -I/usr/include/python3.4m -Wl,-O1,--sort-common,--as-needed,-z,relro conftest.c -L/usr/lib/python3.4/config -lpython3.4 -Xlinker -export-dynamic -lpthread -ldl -lutil >&5
/usr/bin/ld: cannot find -lpython3.4
collect2: error: ld returned 1 exit status
configure:17460: $? = 1


However, python3.4 is installed on my system (system is up to date) and I also have installed geany-git

Name : python
Version : 3.4.1-1

xyproto commented on 2014-08-06 11:56

Sorry about the slow update of this package, the comments flew under my radar for a while. Updated the package to build in the same way as the geany-plugins package in [community]. Works now.

xyproto commented on 2014-01-23 14:39

GordinGR, IMO, geany-gtk3-git should rather add provides=('geany-git'), since geany and this package has not played well in the past.

GordonGR commented on 2014-01-17 14:45

Could you change depends=('geany-git') to depends=('geany'), please? Otherwise it doesn't acknoweledge geany-gtk3-git.

martinoff commented on 2014-01-07 15:53

yes it build ok with makepkg
change the ./waf with ./configure make and it work in clean chroot

xyproto commented on 2014-01-07 11:56

Ok. Does it work when building with makepkg? It builds fine here.

https://wiki.archlinux.org/index.php/Arch_User_Repository#Q:_What_is_the_difference_between_the_Arch_User_Repository_and_community.3F

martinoff commented on 2014-01-06 21:10

dose not build in clean chroot
==> Updated version: geany-plugins-git 1.23.0.196.g601b1cf-1
==> Starting build()...
Waf: The wscript in '/build/geany-plugins-git/src/geany-plugins' is unreadable
Traceback (most recent call last):
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Scripting.py", line 87, in waf_entry_point
set_main_module(Context.run_dir+os.sep+Context.WSCRIPT_FILE)
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Scripting.py", line 110, in set_main_module
Context.g_module=Context.load_module(file_path)
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/extras/compat15.py", line 88, in load_module
ret=rev(path)
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Context.py", line 261, in load_module
code=Utils.readf(path,m='rU')
File "/build/geany-plugins-git/src/geany-plugins/.waf3-1.6.11-30618c54883417962c38f5d395f83584/waflib/Utils.py", line 85, in readf
txt=f.read()
File "/usr/lib/python3.3/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 96: ordinal not in range(128)
==> ERROR: A failure occurred in build().
Aborting...

xyproto commented on 2013-10-19 20:11

Just tried building the package, it builds fine here. Have you read https://wiki.archlinux.org/index.php/AUR#Prerequisites ?

xyproto commented on 2013-10-19 20:07

@liquibyte I don't think you understand how AUR and git works. Report upstream problems upstream to the geany-plugins developers. Only flag a package if it is out of date (if ie. version 3.0 is flagged, but 3.1 has been released). Unflagging.

liquibyte commented on 2013-10-18 02:49

Doesn't build for me at all. Even tried with autogen and make. The waf thing is a fiasco. Flagging.

SysGhost commented on 2013-08-15 05:34

This package is not valid anymore.
Quote from the README.md file:

## MultiTerm source has moved!

The [MultiTerm][mt] plugin is now part of the [Geany-Plugins][gp]
project and the latest source is hosted there. You can find the
latest `master` branch of this old repository by checking out the
[`old-master`][om] branch.

Feel free to still use the [Issue tracker][it] here to report issues
with the main plugin in the [Geany-Plugins][gp] project, it doesn't
have the [Github Issue tracker][GP] activated at the time of writing.

xyproto commented on 2013-07-09 11:15

Updated the PKGBUILD to use pkgver() etc.

Undeterminant commented on 2013-04-07 18:54

This script should be updated for pacman 4.1 so that it more efficiently downloads the git repo.

xyproto commented on 2012-07-19 10:43

thanks mloskot, updated the package.

mloskot commented on 2012-07-18 22:18

It seems geanylua plugin has some problems with building [1], so the package doesn't build too.
Temporarily, simple fix is to patch PKGBUILD to skip it:

- ./waf configure --prefix=/usr --libexecdir=/usr/lib
+ ./waf configure --prefix=/usr --libexecdir=/usr/lib --skip-plugins=geanylua

[1] http://lists.uvena.de/geany-devel/2012-July/006965.html

xyproto commented on 2011-12-31 17:47

Updated the PKGBUILD, sorry for the delay.

xyproto commented on 2011-12-30 21:20

RetroX, will upload the updated PKGBUILD shortly.

Anonymous comment on 2011-12-30 16:44

Why is this named geany-plugins-git if it still uses the SVN repository?

xyproto commented on 2011-12-17 12:41

gour, thanks, created geany-plugins-git, merged the votes and comments from geany-plugins-svn and updated the PKGBUILD.

Anonymous comment on 2011-12-17 07:07

geany-plugins project is now at https://github.com/geany/geany-plugins

eht16 commented on 2011-10-20 20:41

Weird. I don't see what's wrong.
Could you try to remove my name in the top of the wscript? Byte 0xc3 is the start of a "ö" in UTF-8 and position 96 is exactly that position in the file of the "ö" in my name. However, this is totally weird. The wscript file has the Python coding header specifying utf-8 as encoding and the file itself is UTF-8 encoded. So it should work.
Very confusing.

xyproto commented on 2011-10-20 18:49

eht16, the error only occurs with yaourt, not with makepkg or packer. My conclusion is that it's the combination of waf and yaourt that is the problem.

xyproto commented on 2011-10-18 23:05

Weird, now I get that error for both cases. Will examine the issue a bit more before concluding with anything.

xyproto commented on 2011-10-18 23:03

eht16, there, the error happened again (strangely only when updating the package, not when using makepkg). http://pastebin.com/70PbCs7M
Added make dependency on "waf" and changed the PKGBUILD to use the system wide waf, for now.

eht16 commented on 2011-10-18 22:37

Great. If it will break again, please tell us upstream. Thanks.

xyproto commented on 2011-10-18 22:32

eht16, I can't remember the exact reason, unfortunately, as I've delt with several other packages since then. I think it just didn't compile.
However, "./waf" works again now, so I'm updating the package to use that instead of depending on the "waf" package.

eht16 commented on 2011-10-18 17:19

trontonic, just for my curiosity, what problems exactly did you experience?

xyproto commented on 2011-10-12 09:14

Updated the package to use waf from the system instead of ./waf, which caused problems.

xyproto commented on 2011-10-12 08:40

eht16, you're right; thanks for noticing. Updating the package. namcap displays no errors.

eht16 commented on 2011-10-11 21:05

Trontronic, thanks.
Correct me if I'm wrong but shouldn't their a dependency on Geany?
And optdepends is defined twice.

xyproto commented on 2011-10-09 16:51

Adopted and updated the package. namcap displays no errors.

eht16 commented on 2011-09-12 13:30

I just adopted and updated the package as well. Now it properly depends on Geany 0.21 SVN again and I added a few more dependencies.

eht16 commented on 2011-09-12 13:09

This was a bug in the code, a check used a Python2-only syntax. Fixed now in SVN and should build again.

Anonymous comment on 2011-09-10 15:10

waf complains about not finding devhelp.

As a workaround i added --skip-plugins=devhelp to the waf configure command.

eht16 commented on 2010-11-09 17:56

The Waf-based build system and Waf itself have been updated, so now it should work with Python 3 as well.

KaoDome commented on 2010-11-05 16:14

Needs to be updated to reflect the use of Python 3.x as the default Python interpreter, right now it doesn't build.

eht16 commented on 2010-08-06 18:25

I found a bit more:
- could you add 'ctpl' as makedep to also build the geanygendoc plugin (and maybe adjust geany-plugins-svn.install)
- could you add 'lua' as makedep to also build the geanylua plugin (and maybe adjust geany-plugins-svn.install)
- the geany-plugins 0.19 do depend on Geany 0.19, not 0.18

Thanks.

eht16 commented on 2010-08-06 17:22

I just noticed in the PKGBUILD there is still the old website address mentioned.
When you update it the next time, it'd be nice if you could change it to www.geany.org.
Thanks.

Anonymous comment on 2010-07-28 14:44

Thanks for the hint.
fixed & updated

Anonymous comment on 2010-06-13 17:04

Made slight correction to build script in the pastebin
http://aur.pastebin.com/w6WbPr5Y

Anonymous comment on 2010-05-03 00:39

fixed PKGBUILD
http://aur.pastebin.com/w6WbPr5Y

Anonymous comment on 2010-04-12 10:38

==> Missing Dependencies:
-> versionpkg
==> ERROR: Could not resolve all dependencies.

I can't find this package even in AUR.