Package Details: geary-git r5442.c4d0b714-1

Git Clone URL: https://aur.archlinux.org/geary-git.git (read-only, click to copy)
Package Base: geary-git
Description: An email application built around conversations, for the GNOME 3 desktop.
Upstream URL: https://gitlab.gnome.org/GNOME/geary
Keywords: client email GNOME
Licenses: GPL3
Conflicts: geary
Provides: geary
Submitter: emersion
Maintainer: letorbi
Last Packager: letorbi
Votes: 12
Popularity: 0.000002
First Submitted: 2015-08-31 14:59
Last Updated: 2020-01-31 21:41

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

letorbi commented on 2019-01-23 11:30

The enchant2 patch is not required anymore and has been removed.

letorbi commented on 2019-01-11 15:47

The enchant2 patch has been updated. The package should work with the latest master of the upstream repo now.

vivaeltopo commented on 2018-09-15 08:53

seems to work fine

letorbi commented on 2018-09-14 11:02

@vivaeltopo I've removed the vapi path completely from the patch, so building should work with 0.40 and 0.42 now.

vivaeltopo commented on 2018-09-09 08:31

Does no longer build with vala 0.42. the enchant patch needs to be edited with this line:

  • dirs: '/usr/share/vala-0.40/vapi/',

to

  • dirs: '/usr/share/vala-0.42/vapi/',

letorbi commented on 2018-05-29 21:42

@vivaeltopo Thx for the hint. I've added itstool to the build-deps and reviewed the dependencies in general.

vivaeltopo commented on 2018-05-29 19:49

there seems to be a new dependency: "itstool" not sure if its just a build-dep

Redi commented on 2018-05-29 15:44

@letorbi Looks good to me.

letorbi commented on 2018-05-29 11:14

This package is now using Meson instead of CMake.

@Redi Can you please verify that the package can be built now?

letorbi commented on 2018-05-29 08:48

@Redi It seems that the old CMake config is missing some build instructions for newer files.

Using Meson to build Geary works, but I have to verify that the problem with the enchant-library (see below) is actually fixed, before I can update the package.