Package Details: gedit-latex 3.20.0-1

Git Clone URL: https://aur.archlinux.org/gedit-latex.git (read-only)
Package Base: gedit-latex
Description: Gedit plugin that provides features to ease the edition of LaTeX documents
Upstream URL: https://wiki.gnome.org/Apps/Gedit/LaTeXPlugin
Licenses: GPL
Conflicts: gedit-latex-plugin
Replaces: gedit-latex-plugin
Submitter: markzz
Maintainer: markzz
Last Packager: markzz
Votes: 3
Popularity: 0.028165
First Submitted: 2015-08-16 15:27
Last Updated: 2016-05-17 03:18

Latest Comments

markzz commented on 2016-05-16 12:53

You only need to mark the package out-of-date and an additional comment is unnecessary.

Mymaud commented on 2016-05-14 22:14

New version : http://ftp.gnome.org/pub/GNOME/sources/gedit-latex/3.20/

markzz commented on 2015-12-09 03:14

I just checked (again) and it builds fine here with 'makepkg -s'. I do test all my PKGBUILDs in a clean chroot before submitting.

dzuykhanh commented on 2015-12-09 03:04

I have already installed python-latex package but when I run "makepkg -s" to install gedit-latex, it still gives me the error

error: target not found: python-latex
==> ERROR: 'pacman' failed to install missing dependencies.

Please fix it.

Thanks.

markzz commented on 2015-12-04 01:40

That last line is all I needed. I'm making a python-latex package now to see if it fixes it. You can use pip to install the latex python package in the meantime to fix it.

qifei9 commented on 2015-12-04 01:36

(gedit:16897): libpeas-WARNING **: Error importing plugin 'latex':
Traceback (most recent call last):
File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 986, in _gcd_import
File "<frozen importlib._bootstrap>", line 969, in _find_and_load
File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 662, in exec_module
File "<frozen importlib._bootstrap>", line 222, in _call_with_frames_removed
File "/usr/lib/gedit/plugins/latex/__init__.py", line 39, in <module>
from .windowactivatable import LaTeXWindowActivatable
File "/usr/lib/gedit/plugins/latex/windowactivatable.py", line 36, in <module>
from .config import EDITOR_VIEWS, ACTIONS
File "/usr/lib/gedit/plugins/latex/config.py", line 26, in <module>
from .latex.actions import LaTeXMenuAction, LaTeXNewAction, LaTeXChooseMasterAction, \
File "/usr/lib/gedit/plugins/latex/latex/actions.py", line 33, in <module>
from .editor import LaTeXEditor
File "/usr/lib/gedit/plugins/latex/latex/editor.py", line 37, in <module>
from .expander import LaTeXReferenceExpander
File "/usr/lib/gedit/plugins/latex/latex/expander.py", line 28, in <module>
from .cache import LaTeXDocumentCache
File "/usr/lib/gedit/plugins/latex/latex/cache.py", line 111
print self.__file.path
^
SyntaxError: Missing parentheses in call to 'print'

(gedit:16897): libpeas-WARNING **: Error loading plugin 'latex'