Package Details: gedit2 2.30.4-9

Git Clone URL: https://aur.archlinux.org/gedit2.git (read-only)
Package Base: gedit2
Description: A text editor for GNOME
Upstream URL: http://www.gnome.org
Licenses: GPL
Groups: gnome-extra
Conflicts: gedit
Provides: gedit
Submitter: WhyNotHugo
Maintainer: bidulock
Last Packager: bidulock
Votes: 14
Popularity: 0.000003
First Submitted: 2011-05-23 23:39
Last Updated: 2018-03-19 00:45

Required by (24)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

xvoprsalek commented on 2012-04-07 11:27

Thanks svg1234, your workaround about this libICE error was very helpful to me.

svg1234 commented on 2012-03-19 10:49

If you get the dreaded DSO libICE error, just create a ~/.makepkg.conf file and append "-lICE" to your DFLAGS. I use LDFLAGS="-lICE -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu". There are other ways to accomplish the same thing, but this'll do. Rename the .conf to disable it when not required.

mephistopheles commented on 2012-03-10 13:07

all versions after 2.30.4 base on gtk3. please, don't mark this package as "out-of-date"

TuxLyn commented on 2012-03-10 12:52

There is version 2.31.6 > http://ftp.gnome.org/pub/gnome/sources/gedit/2.31/
Please update it =)

mephistopheles commented on 2012-03-07 00:49

This bug fixed in gtk3 newer version. This is last version with gtk2. Excuse me.

Anonymous comment on 2012-03-06 19:06

doesn't work for this time:

/usr/bin/ld: ./.libs/libgedit.a(eggsmclient-xsmp.o): undefined reference to symbol 'IceConnectionNumber'
/usr/bin/ld: note: 'IceConnectionNumber' is defined in DSO /usr/lib/libICE.so.6 so try adding it to the linker command line
/usr/lib/libICE.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

WhyNotHugo commented on 2012-02-29 03:20

I haven't used this package for ages. I'm disowning it, in case someone wants to pick this is. This *will* die eventually, since it's unsupported, but feel free to use it while it works (which will probably be a looong while).

tea commented on 2011-08-23 11:56

This could make use of MATE to fix the GTK3 dependency.

WhyNotHugo commented on 2011-08-02 12:07

Well... a gconf-2 aur package would be needed, and make this package depend on that instead of gconf, plus, make sure they can both co-exist. If you're up for it, I'll change the depends. I'm not sure there's any way around this either. I didn't notice this since I've already gotten gtk3 pushed down my throat by several other apps upgrading to it.

carlwgeorge commented on 2011-08-02 11:41

This depends on gconf, which depends on gtk3 now. Something needs to be tweaked.