Package Details: geeknote-git r205.192a0c5-1

Git Clone URL: https://aur.archlinux.org/geeknote-git.git (read-only)
Package Base: geeknote-git
Description: Work with Evernote from command line
Upstream URL: http://www.geeknote.me
Licenses: GPL
Provides: geeknote
Submitter: jecxjo
Maintainer: jamesan
Last Packager: jamesan
Votes: 31
Popularity: 0.238717
First Submitted: 2012-10-17 17:57
Last Updated: 2015-11-17 19:07

Latest Comments

d4rkeagle6591 commented on 2015-09-19 21:00

I needed to use python2-markdown2 and python2-thrift as dependencies, instead of what was listed. There is an evernote-sdk-python-git on git, not on the aur. However there is also a evernote-sdk-python package on the AUR, which targets the git package.

Can the maintainer update these dependencies?

GutenYe commented on 2015-05-27 10:48

~ ❯ geeknote
Traceback (most recent call last):
File "/usr/bin/geeknote", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3074, in <module>
@_call_aside
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3060, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3087, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 645, in _build_master
ws.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 946, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 833, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'markdown2' distribution was not found and is required by geeknote

I know I can edit the PKGBUILD, but why just nobody fix a simple problem?

ngoonee commented on 2015-02-03 23:57

You do know that you can just edit the PKGBUILD yourself after downloading it?

JohnBlood commented on 2015-02-03 03:31

Could you guys fix this problem. It keeps telling me that "error: target not found: thrift-python2", just like fabiofalci said. I'd really like to use this, but I need you guys to fix it. Thanks.

nizar commented on 2015-01-09 10:37

Had to use the following dependencies:
python2-thrift: instead of python-thrift2
python2-markdown2-git: instead of python-markdown2 since the latter is now based on python3

ngoonee commented on 2014-11-13 02:38

I think it just got renamed to python2-thrift (which would be correct).

fabiofalci commented on 2014-11-11 12:26

==> Building and installing package
==> Install or build missing dependencies for geeknote-improved-git:
error: target not found: thrift-python2

ngoonee commented on 2014-11-05 17:08

python-markdown2 is now based on python3, so you'd need to change deps

jamesan commented on 2014-06-19 02:37

Confirmed and fixed. Thanks for catching that. =)

ngoonee commented on 2014-06-10 03:22

python2-pip isn't a dependency actually =) works fine without. Needed if you want to install this package from pip, but in the AUR? Nah =)

All comments