Package Details: gegl-git

Git Clone URL: (read-only)
Package Base: gegl-git
Description: Graph based image processing framework
Upstream URL:
Licenses: GPL3, LGPL3
Conflicts: gegl
Provides: gegl=
Submitter: None
Maintainer: FFY00
Last Packager: FFY00
Votes: 106
Popularity: 0.899681
First Submitted: 2009-05-27 08:12
Last Updated: 2018-05-25 14:04

Dependencies (24)

Required by (4)

Sources (1)

Latest Comments

Salamandar commented on 2018-05-25 09:44

The new repository is at

haawda commented on 2018-04-29 11:45

qdii, read the comments. it is quite clear what to do then. Rebuild and install babl-git.

qdii commented on 2018-04-20 00:25

Compilation is broken for me. I get "Requested 'babl >= 0.1.46' but version of babl is 0.1.45". How can I fix that?

bartus commented on 2018-04-11 15:39

@mytbk: deps should be babl>=0.1.46 as extra has babl=0.1.44 which is goint to be pulled instead of aur:babl-git=0.1.46, preventing successful build of gelg-git in clean chroot.

mk-fg commented on 2018-04-07 07:29

Using gegl-git without installing its makedepends will give following warnings:

GEGL-Message: 12:16:02.433: Module '/usr/lib/gegl-0.3/' load error: cannot open shared object file: No such file or directory

These seem to be non-fatal, but probably indicate that "suitesparse" should be in depends=() instead of makedepends=(), as libumfpack is provided by that one at runtime.

Salamandar commented on 2018-03-06 15:23

Just as Babl, Gegl was ported to Meson :)

cafehaine commented on 2018-03-05 09:51

The correct URL for the git repository is now git://

JonnyRobbie commented on 2017-10-22 08:24

Build error.
"Requested 'babl >= 0.1.34' but version of babl is 0.1.33"

Both babl and babl-git are versioned at 0.1.30. The build passes with `babl-git`.

The makedepends should have the git version, the vanilla version fails.

haawda commented on 2017-09-13 22:23

It turns out that the gegl-git package is fine. The culprit was the lensfun-git package from AUR I use, delivering a broken .pc-File for pkg-config.

haawda commented on 2017-09-10 06:32

BTW., I opened a bug report for this:

haawda commented on 2017-09-09 14:34

I need a small patch to compile this.

prepare() {
cd "$srcdir/$_gitname"
patch -p1 < "$srcdir"/correct_lensfun.patch

diff --git a/operations/workshop/external/lens-correct.c b/operations/workshop/external/lens-correct.c
index ac8070a3..141ee304 100644
--- a/operations/workshop/external/lens-correct.c
+++ b/operations/workshop/external/lens-correct.c
@@ -19,7 +19,7 @@

#include "config.h"
-#include <lensfun.h>
+#include <lensfun/lensfun.h>
#include <glib/gi18n-lib.h>

grayich commented on 2017-02-13 14:17

no babl>=0.1.24
there extra/babl 0.1.18 and aur/babl-git

-- depends=('babl>=0.1.24' 'libspiro' 'json-glib')
++ depends=('babl-git' 'libspiro' 'json-glib')

LordReg commented on 2016-10-10 11:45

When building this package with clang, need to make sure the 'openmp' package is installed. Maybe a condition statement for makedepends could be added to the PKGBUILD?

justinzane commented on 2016-03-11 18:39

Sorry for the last. See that it has been done.

justinzane commented on 2016-03-11 18:39

Please edit the PKGBUILD so that it has "provides = gegl\nconflicts=gegl". Gimp-git now cannot build because lib-mypaint depends on gegl; and gegl and gegl-git want to overwrite each others files. With a proper provides/conflicts pair, I'm hoping that this will be working again. Thanks!

Perry3D commented on 2016-01-13 23:36

Do we really need babl-git? Version 0.1.14 is also in the repository.

electricprism commented on 2015-11-02 12:01

Maybe I misunderstand, but gimp-gtk3-git fails to load because gegl-git doesn't include maze which should have been added in this patch

Does anyone know why?

mytbk commented on 2015-09-12 00:45

conflicts and provides updated
Now extra/gegl is in version 0.3.0, however, it lacks gegl:maze which is used by gimp-git, so gimp-git still depends on gegl-git.

electricprism commented on 2015-09-11 18:21

Upon upgrading my system gnome-photos and gegel refused to upgrade due to file conflicts

Please resolve this package conflict so this issue doesn't come up again, thank you.

ratcheer commented on 2015-09-11 14:18

The main repository now contains an upgraded gegl package. It cannot be installed if gegl-git is installed. Apparently, the gegl-git package should contain a conflict with the gegl package.

Also, I can no longer run gimp-git, because it has a hard dependency on gegl-git. With the new gegl package installed, I cannot reinstall gimp-git.

Nordlicht commented on 2014-03-02 10:32

I've updated gegl-git. After this, gimp-gtk3-git doesn't start any more:

"GEGL operation missing!

GIMP requires the GEGL operation "gegl:seamless-clone".
This operation cannot be found. Check your
GEGL install and ensure it has been compiled
with any dependencies required for GIMP."

Nordlicht commented on 2013-08-28 15:19

Please add 'git' to "makedepends".

diverse_izzue commented on 2013-06-25 09:13

I adopted this and updated the package. Let me know if things break.

Anonymous comment on 2012-04-26 17:24

Same problem here, solved by installing manually intltool. It should be added as a dependency.

Anonymous comment on 2012-04-25 10:01

I think intltool is missing as dependency?

Anonymous comment on 2012-01-09 18:54

Alternatively, disable vala in gegl by adding --without-vala to the line "./ --prefix=/usr --disable-docs" in the PKGBUILD

milkmiruku commented on 2011-12-12 19:21

Same for me, removing Vala worked.

felixonmars commented on 2011-12-09 04:45

Finally I got it to work - simply removed vala and the build succeeded, that's crazy!
Thank you 0ion9 :)

felixonmars commented on 2011-12-05 04:24

Same as you, using the latest core version.

0ion9 commented on 2011-12-05 04:04

Then what about GLib? I have 2.30.2

felixonmars commented on 2011-12-05 03:53

Yes, every time I failed just right after I have built babl-git.

0ion9 commented on 2011-12-05 03:06

Have you checked that your BABL is up to date?
Building the latest babl-git then gegl-git works fine for me.

felixonmars commented on 2011-12-05 00:48

I cannot build this for months, output is:

GICOMP Gegl-0.1.gir
/usr/bin/vapigen --library=gegl-0.1 Gegl-0.1.gir
babl-0.1.vapi:7.16-7.16: error: syntax error, expected statement
public class {
Generation failed: 1 error(s), 0 warning(s)
make[3]: *** [gegl-0.1.vapi] Error 1
make[3]: Leaving directory `/tmp/yaourt-tmp-felix/aur-gegl-git/src/gegl-build/ge
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/yaourt-tmp-felix/aur-gegl-git/src/gegl-build/ge
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-felix/aur-gegl-git/src/gegl-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().

yvonney commented on 2010-11-22 22:59

perhaps I am mistaken, is there now a problem with package: [thank you!]

In file included from <stdin>:6:0:
/var/cache/pacman/pkg/babl-git/src/babl-build/babl/babl-version.h:23:2: error: #error "babl-version.h must not be included directly, include babl.h instead."
Error while processing the source.
make[3]: *** [Babl-0.1.gir] Error 1
make[3]: Leaving directory `/var/cache/pacman/pkg/babl-git/src/babl-build/babl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/cache/pacman/pkg/babl-git/src/babl-build/babl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/cache/pacman/pkg/babl-git/src/babl-build'
make: *** [all] Error 2

mtorromeo commented on 2010-07-07 09:25

Cleaned up PKGBUILD

Anonymous comment on 2010-07-04 06:29

needs to handle first time builds better
'rm -rf "$srcdir/$_gitname-build"' to '[ ! -d "$srcdir/$_gitname-build" ] || rm -rf "$srcdir/$_gitname-build"'
that way first time builders don't get an error for trying to remove a directory that isn't there.

Anonymous comment on 2010-06-30 22:43

under make rm -r ... should be rm -rf to avoid makepkg from bailing out first time package is built