Package Details: geis 2.2.17-1

Git Clone URL: (read-only)
Package Base: geis
Description: Implementation of the GEIS (Gesture Engine Interface and Support) interface.
Upstream URL:
Licenses: GPL, LGPL
Conflicts: utouch-geis
Provides: utouch-geis
Replaces: utouch-geis
Submitter: niQo
Maintainer: niQo
Last Packager: niQo
Votes: 48
Popularity: 1.249054
First Submitted: 2012-08-15 12:49
Last Updated: 2016-05-09 19:30

Latest Comments

evilguc commented on 2015-07-12 19:45

Comment by bulletmark on old AUR:

Here's an updated PKGBUILD for this package that downloads the 2.2.16 source, applies a patch for this bug from the geis Ubuntu launchpad project, and then builds the Arch package. Get it from

It solves the problem with compilation described bellow:

geis_logging.h:56:39: error: ISO C does not support '__FUNCTION__' predefined identifier [-Werror=pedantic]

evilguc commented on 2015-07-12 19:38

I had a problem with compiling due to lack of 'oif/frame_x11.h'. I already had 'xorg-xinput' installed. But... simple re-installation of grail and frame helped out. Unfortunately, I couldn't catch cause of a problem

nos1609 commented on 2015-06-19 18:59

Successfully compiled v2.2.17. Simply replace
"source= ...blablabla... .tar.gz" to "source= ...blablabla... .tar.xz"
and the
"md5sums=('550c78b5185b835b80dba14537c2c83d'" to "md5sums=('2ff9d76a3ea5794516bb02c9d1924faf'".
Everything woks like a charm.

rekoil commented on 2015-06-03 22:35

I can't get it to compile even with these proposed changes. Still pretty much the same error as ZetaHunter had initially.

trengrj commented on 2015-05-19 03:35

I got it compiling from the original package however I had already installed xorg-xinput. Maybe this is no longer an optional requirement?

SunBey commented on 2015-05-16 20:57

Thanks ZetaHunter it would be very helpfull if you could paste the complete changes you've made as source line here. I have the same problems as you during compile.

ZetaHunter commented on 2015-05-01 13:48

Changing source to bzr+ and changing cd to $srcdir/trunk/ aswell as replacing ./configure with ./ seem to have fixed it.

I am new to aur and makepkg in general, so I don't know how to commit my changes to public.

ZetaHunter commented on 2015-04-27 14:10

Won't compile.

In file included from geis_bag.c:25:0:
geis_bag.c: In function '_bag_store_allocate':
geis_logging.h:56:39: error: ISO C does not support '__FUNCTION__' predefined identifier [-Werror=pedantic]
__FUNCTION__, __LINE__, \
geis_bag.c:39:5: note: in expansion of macro 'geis_error'
geis_error("failed to allocate bag store");
geis_bag.c: In function 'geis_bag_new':
geis_logging.h:56:39: error: ISO C does not support '__FUNCTION__' predefined identifier [-Werror=pedantic]
__FUNCTION__, __LINE__, \
geis_bag.c:53:5: note: in expansion of macro 'geis_error'
geis_error("failed to allocate bag");
cc1: all warnings being treated as errors
Makefile:379: recipe for target 'libgeis_util_la-geis_bag.lo' failed
make[3]: *** [libgeis_util_la-geis_bag.lo] Error 1
Makefile:351: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
Makefile:461: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
Makefile:369: recipe for target 'all' failed
make: *** [all] Error 2

debugrr commented on 2013-10-14 19:55

compiled this time, after reinstalling xorg-xinput, then recompiling frame.... so I'm blaming me.

debugrr commented on 2013-10-14 19:36

@ebrodeur I'm guessing you mean xorg-xinput? If so I'm getting that as not avail, and it was already installed. If you do mean xorg-input, where can I get it?

niQo commented on 2013-04-15 21:02

@Duologic fixed thanks for reporting ( seems to be FS#34658 )

Duologic commented on 2013-04-11 07:07

New revision won't compile here:

Making all in python
CC _geis_bindings_la-_geis_bindings.lo
In file included from /usr/include/python3.3m/Python.h:112:0,
from _geis_bindings/_geis_bindings.c:1:
/usr/include/python3.3m/modsupport.h:29:1: error: 'PyArg_ParseTuple' is an unrecognized format function type [-Werror=format=]
PyAPI_FUNC(int) PyArg_ParseTuple(PyObject *, const char *, ...) Py_FORMAT_PARSETUPLE(PyArg_ParseTuple, 2, 3);

(Sorry, no time to check)

Anonymous comment on 2013-03-26 17:16

For anybody who gets the frame_x11 not available, install xorg-input before you install frame/geis and it will build correctly.

Not real sure who's bug this is, x11 is an optional dep on libframe, but geis requires it to compile.

I would argue that geis does have an xorg-input dep even if libframe does not (since geis fails to compile if xorg-input isn't installed before frame).

niQo commented on 2013-03-16 13:47

@test0: package updated, thx for reporting

test0 commented on 2013-03-13 18:48

geisview requires python-gobject which is missing from dependencies.

mutterschiff commented on 2012-12-16 14:46

I installed xorg-server-devel and got to the next error:

City-busz commented on 2012-12-03 11:58

xorg-xinput is not required, please remove it from depends

ilpianista commented on 2012-11-28 23:18

xorg-server-devel is a makedepends

niQo commented on 2012-08-15 12:49

Initial release, this package replaces obsolete utouch-geis package.