Package Details: gelemental 1.2.0-8

Git Clone URL: https://aur.archlinux.org/gelemental.git (read-only)
Package Base: gelemental
Description: gElemental is a periodic table viewer that provides detailed information on the chemical elements
Upstream URL: http://www.kdau.com/projects/gelemental/
Licenses: GPL
Submitter: Phrodo_00
Maintainer: chelqo
Last Packager: chelqo
Votes: 26
Popularity: 2.024337
First Submitted: 2007-04-23 02:48
Last Updated: 2016-01-24 13:05

Dependencies (8)

Required by (0)

Sources (6)

Latest Comments

cth451 commented on 2016-01-02 14:28

Archlinux has updated to c++14 standard now which caused compilation to fail. just add CXXFLAGS="--std=c++11" at the end of `./configure` line in PKGBUILD. @chelqo @gojun077

chelqo commented on 2015-12-17 14:31

Hi @gojun077, I just checked and unfortunately get the same compilation error that you indicate.
Give me some time, I will try to find a solution, this is an application that I quite like.
But as you can see, the problem is that it is discontinued for 8 years, once I tried unsuccessfully to contact the authors, hopefully I'll have better luck now.
If you find some way to patch this please alerts us.
(sorry my bad english)

gojun077 commented on 2015-12-16 06:14

Getting a 'make' error in glibmm:
...
make[3]: Entering directory '/home/archjun/Downloads/AUR/gelemental/src/gelemental-1.2.0/libelemental/misc'
/usr/include/glibmm-2.4/glibmm/ustring.h:267:12: error: expected ';' at end of member declaration
~ustring() noexcept;
^
/usr/include/glibmm-2.4/glibmm/ustring.h:267:14: error: 'noexcept' does not name a type
~ustring() noexcept;
...
Makefile:334: recipe for target 'ucompose.lo' failed

The 'Makefile' referred to above is in $HOME/Downloads/AUR/src/gelemental-1.2.0/libelemental/misc/Makefile

Look at line 334 in this Makefile shows the following (lines 333, 334):

.cc.lo:
$(LTCXXCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<

Perhaps this problem is due to library version mismatch?

Tallix commented on 2015-04-01 21:32

Build failed until I installed perl-xml-parser and intltool. Please add them as dependencies.

vgf89 commented on 2015-02-17 21:56

There's a dependency missing in the PKGBUILD: perl-xml-parser

dixDel commented on 2013-10-13 14:44

False alert, I tried again after a full system upgrade and the installation was successful. Sorry for the trouble ;)

chelqo commented on 2013-10-12 04:56

dixDel:
I do not know what will be the problem.
For me it works well:
https://dl.dropboxusercontent.com/s/r4xbj0f6h6fxt01/gelemental.log?token_hash=AAH8cwz5p8y0ioEf-wojFbGZ4QdLGAaqXJKmw4YP6u4X2w&dl

dixDel commented on 2013-10-10 15:15

Hello, it doesn't work with yaourt: http://pastebin.com/nPM5A2gn

chelqo commented on 2012-11-29 20:12

let me know if now it works with yaourt
thanks!

Maxwel commented on 2012-11-28 18:54

This PKGBUILD (1.2.0-4) doesn't work while using yaourt. Please update PKGBUILD to fix it. Here is a patch

http://pastebin.com/1LCZZiaY

PS. I forgot to increase package release so, do it yourself please. Thank you for attention.

All comments