Package Details: gem2arch 0.11-1

Git Clone URL: https://aur.archlinux.org/gem2arch.git (read-only)
Package Base: gem2arch
Description: Create PKGBUILD from Ruby Gem Package
Upstream URL: https://github.com/anatol/gem2arch
Licenses: GPL3
Submitter: anatolik
Maintainer: anatolik
Last Packager: anatolik
Votes: 56
Popularity: 0.135991
First Submitted: 2013-12-06 14:03
Last Updated: 2015-08-10 18:34

Dependencies (5)

Required by (1)

  • pkgtools (requires gem2arch) (optional)

Sources (1)

Latest Comments

jose1711 commented on 2015-10-09 09:40

gem2arch breaks on localized pacman:
/usr/bin/gem2arch:250:in `find_arch_version': undefined method `[]' for nil:NilClass (NoMethodError)
from /usr/bin/gem2arch:427:in `block in check_gem_dependencies'
from /usr/bin/gem2arch:424:in `each'
from /usr/bin/gem2arch:424:in `check_gem_dependencies'
from /usr/bin/gem2arch:459:in `gen_pkgbuild'
from /usr/bin/gem2arch:517:in `create_packages'
from /usr/bin/gem2arch:544:in `<main>'

as a workaround run LC_ALL=C gem2arch ..

Anonymous comment on 2015-09-20 12:36

optional dependency burp does not exist in AUR.

sigmundv commented on 2015-08-10 18:05

Please update the checksum in the PKGBUILD.

anatolik commented on 2014-04-28 06:48

update pkgtools

blackhole commented on 2014-04-28 06:47

error: failed to commit transaction (conflicting files)
gem2arch: /usr/bin/gem2arch exists in filesystem

pacman -Qo /usr/bin/gem2arch
/usr/bin/gem2arch is owned by pkgtools 24-5

jstjohn commented on 2014-02-17 23:16

The pkgtools package on the AUR has not yet been updated for pkgtools version 25. You may want to leave the pkgtools conflict in place for versions <25. For example, conflicts=('pkgtools<25')

bchretien commented on 2014-02-17 22:25

pkgtools conflict can be removed with the latest pkgtools version.

jstjohn commented on 2014-02-08 02:53

'burp' should be added as an optional dependency for 'gem2arch --aur'

anatolik commented on 2014-02-05 04:58

ok, filed an upstream ticket https://github.com/Daenyth/pkgtools/issues/50

jstjohn commented on 2014-02-05 04:21

Please add "pkgtools" as a conflicting package.

Alternatively, you may want to work with the upstream maintainer of pkgtools to remove gem2arch from the pkgtools Git repository and PKGBUILD and to have pkgtools depend on gem2arch.

All comments