Package Details: geogram 1.7.1-1

Git Clone URL: https://aur.archlinux.org/geogram.git (read-only)
Package Base: geogram
Description: Library of geometric algorithms. It includes a simple yet efficient Mesh data structure.
Upstream URL: http://alice.loria.fr/index.php/software.html
Licenses: BSD
Submitter: bartus
Maintainer: bartus
Last Packager: bartus
Votes: 0
Popularity: 0.000000
First Submitted: 2019-08-29 22:35
Last Updated: 2019-08-29 22:35

Dependencies (5)

Required by (1)

Sources (1)

Latest Comments

bartus commented on 2019-09-21 12:56

Thanks for clarifying ( in hindsight I could explicitly stated that one should execute export LANG=en_EN beforehand to switch current console to English ;)

It looks like you have /usr/include/geogram1/geogram/NL/nl.h in your system.

Can you test which, if any, package own this file.

export LANG=en_EN
pacman -Qo /usr/include/geogram1/geogram/NL/nl.h

If no package own it, you can safely remove whole path.

sudo rm -rf /usr/include/geogram1

And continue geogram installation.

heros21 commented on 2019-09-21 08:58

Here is the error message:

==> Nettoyage de l’installation…
  -> Suppression des fichiers libtool…
  -> Suppression des fichiers indésirables…
  -> Suppression des fichiers de bibliothèques statiques…
  -> Nettoyage des symboles inutiles dans les fichiers binaires et les bibliothèques…
  -> Compression des pages de man/info…
==> Recherche des erreurs d’empaquetage…
==> ATTENTION : Le paquet contient une référence à $srcdir
usr/lib/libgeogram_gfx.so.1.7.1
usr/lib/libgeogram.so.1.7.1
==> Création du paquet « geogram »…
  -> Génération du fichier .PKGINFO…
  -> Génération du fichier .BUILDINFO…
  -> Génération du fichier .MTREE…
  -> Compression du paquet… 
==> Quitte l’environnement fakeroot.
==> Création terminée : geogram 1.7.1-1 (sam. 21 sept. 2019 10:43:37 CEST)
==> Nettoyage…
Résolution des dépendances...
Recherche des conflits entre paquets...
Vérification du trousseau...
Vérification de l’intégrité des paquets...
Chargement des fichiers des paquets...
Analyse des conflits entre fichiers...La validation de la transaction a échoué
conflit de fichiers:
geogram : /usr/include/geogram1/geogram/NL/nl.h est déjà présent dans le système de fichiers
etc....

bartus commented on 2019-09-20 23:48

@heros21 can't reproduce the errors based upona such unenlightened description, you have to be more scrupulous. Please provide the error message and command invocation leading to it.

heros21 commented on 2019-09-20 19:57

Hello I have a problem with geogram that tells me it is already built and I can't install the alice-vision update for meshmixer. Thank you for enlightening me.