Package Details: geographiclib 1.46-2

Git Clone URL: https://aur.archlinux.org/geographiclib.git (read-only)
Package Base: geographiclib
Description: Set of C++ classes for conversions between geographic, UTM, UPS, MGRS, geocentric, and local cartesian coordinates, for gravity, geoid height, and geomagnetic field calculations and for solving geodesic problems. Geotrans replacement.
Upstream URL: http://geographiclib.sourceforge.net/
Licenses: custom
Submitter: petRUShka
Maintainer: rossetti
Last Packager: rossetti
Votes: 8
Popularity: 0.813876
First Submitted: 2012-01-21 22:14
Last Updated: 2016-11-23 20:08

Latest Comments

kikislater commented on 2016-11-23 20:18

Thank you rosseti ;-)

rossetti commented on 2016-11-23 20:17

Post-install info about the data files has been added.

rossetti commented on 2016-11-23 16:16

Both gravity and magnetic models are the additional data for the GeographicLib, and the user have to decide which of them wants to use (if any). PKGBUILD is not the right place for it, I think.

kikislater commented on 2016-11-23 15:51

Ok but why not puting it in PKGBUILD ?

rossetti commented on 2016-11-23 15:48

@kikislater: Please see http://geographiclib.sourceforge.net/html/geoid.html#geoidinst

"For Linux and Unix systems, GeographicLib provides a shell script geographiclib-get-geoids (typically installed in /usr/local/sbin) which automates the process of downloading and installing the geoid data."

kikislater commented on 2016-11-23 13:20

Geoids are missing !

echo 45 1 47 | GeoidEval --msltohae
Error reading egm96-5: File not readable /usr/local/share/GeographicLib/geoids/egm96-5.pgm

petRUShka commented on 2012-02-17 18:42

Done

syne commented on 2012-02-17 18:39

Please remove the apostrophes from the depends array, it should be depends=() if there are none.