Package Details: gerbera 1.2.0-1

Git Clone URL: https://aur.archlinux.org/gerbera.git (read-only)
Package Base: gerbera
Description: UPnP Media Server
Upstream URL: https://github.com/v00d00/gerbera
Licenses: GPL2
Submitter: sergej
Maintainer: sergej
Last Packager: sergej
Votes: 10
Popularity: 0.605203
First Submitted: 2017-05-30 09:39
Last Updated: 2018-05-10 11:57

Latest Comments

1 2 3 Next › Last »

Buddlespit commented on 2018-06-24 02:41

My server didn't have any version of libupnp installed on it. This package pulled 1.8.3 and built it, but this package kept failing to build just as Sergey_Aka was saying it failed. After spending an ungodly amount of time reaching around my ass to scratch my ear, I went and also installed libupnp-1.6. Built just fine afterwards.

By the way, thank you for hosting this. I was a HUGE fan of MediaTomb back in the day.

blue commented on 2018-06-02 09:45

Please consider adding "DLNA" to the package description (or as a keyword) to make this package more visible in search results.

the_jk commented on 2018-05-22 06:04

gerbera depends on libc++ to be able to build

maderios commented on 2018-05-18 09:59

Following official documentation, Gerbera works better for me this way http://docs.gerbera.io/en/latest/compile.html cmake -DCMAKE_INSTALL_PREFIX=/usr . -DWITH_MAGIC=1 -DWITH_MYSQL=1 -DWITH_CURL=1 -DWITH_JS=1 \ -DWITH_TAGLIB=1 -DWITH_AVCODEC=1 -DWITH_FFMPEGTHUMBNAILER=1 -DWITH_EXIF=1 -DWITH_LASTFM=1

maderios commented on 2018-05-16 19:39

Compiled successfully with libupnp18. Thanks!

Sergey_Aka commented on 2018-05-12 23:21

Hi! Trying compile gerbera I've got this error mesage:

Could NOT find UPnP (missing: UPNP_UPNP_LIBRARY UPNP_INCLUDE_DIR) CMake Error at CMakeLists.txt:349 (message): gerbera requires libupnp 1.8.3 or above.

Why gerbera looks up upnp directory in defaulte way /usr/include/upnp/ but not in /usr/include/libupnp-1.8/upnp/ ???

sergej commented on 2018-05-10 11:57

fixed, thank you

GAZDOWN commented on 2018-05-08 11:02

Hi, I just created libupnp18 package which can co-exist with arch default libupnp (currently 1.6). I wanted to use gerbera, but any attempt to update libupnp is breaking too many other packages, so thats why. If you wanna use it, just replace pupnp with libupnp18. Enjoy your gerbera.

le_fuzzy commented on 2018-02-10 11:07

@CommodoreCrunch: mrjimenez is the standard libupnp. It's just a clone of the repository on github. Since gerbera 1.1.0 doesn't compile on libupnp 1.8.3+ your solution is basically what is needed until there's a new version released.

CommodoreCrunch commented on 2018-01-25 00:10

This is a total kludge but I managed to get this compiled. I built libupnp 1.8.2 with a PKGBUILD like so: https://ptpb.pw/ZGqX

Then I edited the gerbera PKGBUILD to change the pupnp dependency to libupnp. It's been working so far, anyway. Hopefully this issue will be fixed upstream with gerbera 1.2. I also legitimately don't know the difference between the standard libupnp and mrjimenez's pupnp so I have no idea whether this workaround breaks something.