Package Details: getfem++ 5.0-2

Git Clone URL: (read-only)
Package Base: getfem++
Description: Generic C++ finite element library.
Upstream URL:
Licenses: LGPL3
Conflicts: gmm
Provides: getfem++, gmm
Submitter: kkimdev
Maintainer: eolianoe
Last Packager: eolianoe
Votes: 2
Popularity: 0.000000
First Submitted: 2011-08-06 16:40
Last Updated: 2016-01-26 16:52

Latest Comments

nivata commented on 2016-01-26 09:43


The qd package only provides a, whereas the configure script of getfem++ explicitly looks for a libqd.a file in the system. So you need to add the following line to the PKGBUILD (in the prepare() function):

sed 's/libqd.a/' configure

I don't know if this could cause other problems during utilization.

kkimdev commented on 2011-08-23 09:59

it's now working

kkimdev commented on 2011-08-06 16:43

you need to change python to python2 first, e.g. (ln -s /usr/bin/python2 /usr/local/bin/python)

and help needed, all the python test code fails


python src/getfem-4.1.1/interface/tests/python/
Traceback (most recent call last):
File "", line 30, in <module>
from getfem import *
File "/usr/lib/python2.7/site-packages/getfem/", line 26, in <module>
from getfem import *
File "/usr/lib/python2.7/site-packages/getfem/", line 40, in <module>
from _getfem import *
ImportError: /usr/lib/python2.7/site-packages/getfem/ undefined symbol: qh_qh