Package Details: ghost 0.9.0-1

Git Clone URL: https://aur.archlinux.org/ghost.git (read-only)
Package Base: ghost
Description: Free, open, simple blogging platform
Upstream URL: http://ghost.org
Keywords: nodejs
Licenses: MIT
Submitter: cyang
Maintainer: Horo
Last Packager: Horo
Votes: 20
Popularity: 0.125852
First Submitted: 2013-10-15 06:07
Last Updated: 2016-08-08 23:37

Latest Comments

niklaszantner commented on 2016-08-21 21:27

Interestingly I get this on install:

npm ERR! Linux 4.7.0.201608131240-1-grsec
npm ERR! argv "/usr/bin/node" "/home/admin/.npm-global/bin/npm" "install" "--production"
npm ERR! node v6.4.0
npm ERR! npm v3.10.6
npm ERR! path /tmp/yaourt-tmp-admin/aur-ghost/pkg/ghost/srv/ghost/node_modules/.staging/core-js-36a99c7e/fn/reflect/prevent-extensions.js
npm ERR! code ENOSPC
npm ERR! errno -28
npm ERR! syscall open

npm ERR! nospc ENOSPC: no space left on device, open '/tmp/yaourt-tmp-admin/aur-ghost/pkg/ghost/srv/ghost/node_modules/.staging/core-js-36a99c7e/fn/reflect/prevent-extensions.js'
npm ERR! nospc This is most likely not a problem with npm itself
npm ERR! nospc and is related to insufficient space on your system.

npm ERR! Please include the following file with any support request:
npm ERR! /tmp/yaourt-tmp-admin/aur-ghost/pkg/ghost/srv/ghost/npm-debug.log


I already increased the amount of allowed watchers and checked the tmp dir for size - both fine. Has someone an idea?

nash commented on 2016-07-30 06:31

With the following simple patch, 0.9.0 seems to work well.

--- PKGBUILD 2016-07-30 14:46:01.240103642 +0900
+++ PKGBUILD.txt 2016-07-30 15:27:52.319174651 +0900
@@ -4,28 +4,25 @@
# Colaborator: Jonhoo

pkgname=ghost
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Free, open, simple blogging platform"
arch=('any')
url="http://ghost.org"
license=('MIT')
makedepends=('unzip')
-depends=('nodejs>=0.12' 'npm' 'python')
+depends=('nodejs>=4.0' 'npm' 'python')
backup=('srv/ghost/config.js')
install=ghost.install
source=(https://ghost.org/zip/$pkgname-$pkgver.zip
ghost.service
ghost.install
- package.json.patch
- npm-shrinkwrap.json.patch
)
noextract=($pkgname-$pkgver.zip)
-sha512sums=('b707c411a014d6aeb9de6bd297ba446e4c16fbd8077f6fd1cb03baf357f0d7a24449a66d75b956978bbb966ea7027664488761b2de82ff07686b3e29d2c686df'
+sha512sums=('f7d1b05f71ad4f03ed65b83c4e0845c4997f299013af90f3a16b74aab61d703c154fce42ab9a814ae200e25709d59436e0c521fcd74e3b6b6a2b69293128fb6a'
'9028de4621c38bf83a22c1cbfa0529d6538516838d641730226fcc24487d654a7d8dcb0b45e455a0a697bd0a9dd80dfdbce6ca8ec1d2e895683ab35846dac10c'
'c4cbd918bf050dbf4b77d5ff016836947351fb1f575359b19e0d6c0343275a253f0922e3be952a9e672c3d2659e67327f92c19573ff5e5fde7f68826afec6d8f'
- '17e9c5572f4976af6e129ca20e66b8ef9aeb626b037d1d4b3de19a1dfa9d8feb7854d84dbfeba0e2056ed18cd05215fab5b7a0e05e4c1d67c17e4b58c4fe0483'
- 'be732d99fd2326d103f67cc502eb4ea0ae3bc4b2b2b4d2a713eb1dac7ee5357e01cc05ec9f73762b687a44b39370cb0f05d362d560a5b06e2f6e1b65c3ccaf4e')
+)

# Note: You may need to log into ghost.org and download the zip file manually
# and place it inside the same directory as the PKGBUILD
@@ -35,8 +32,6 @@
cd "$pkgdir/srv/ghost"
unzip "$srcdir/$pkgname-$pkgver.zip"
echo "Fixing sqlite3 to 3.1.4 ......"
- patch npm-shrinkwrap.json < $srcdir/npm-shrinkwrap.json.patch
- patch package.json < $srcdir/package.json.patch
echo "Ingoring Ghost's Nodejs version check ......"
export GHOST_NODE_VERSION_CHECK=false
cp config.example.js config.js

Horo commented on 2016-05-31 01:34

I use some patch to make ghost use node-sqlite3@3.1.4 ,and it worked."
(These patch may be removed if Ghost support nodejs 6.x offically)

letroll commented on 2016-05-18 07:54

@springmeyer : "node-sqlite3@3.1.4 has been released, which is the first one to support node v6."

Horo commented on 2016-05-09 13:31

sqlite3 module could not support nodejs 6.0 yet :https://github.com/mapbox/node-sqlite3/issues/638

PreparationH67 commented on 2016-05-02 18:46

Confirmed that I was able to install the package with nodejs-lts installed instead of the latest nodejs from the official repos and did NOT need to mess with any of the python symlinks, I'm guessing NPM has been using python2 correctly and changing the links just happened to not break anything. I'm not sure what's the best way to handle this in the package config besides more strict dependencies on the nodejs version that match the ghost officially supported node versions page or some more complicated setup around it to have ghost use a different node version in a manner that allows multiple installed versions.

PreparationH67 commented on 2016-05-02 17:00

I finally got around to confirming that sqlite3 can be build via NPM on my system in a clean directory, but errors out when trying to install/build in the ghost directory so it is something specific to Ghosts javascript packages and config. Currently installing nodejs-lts from the AUR to see if that helps when I get a change to try this again, but it does seem like node-gyp/npm are using the correct python binary without mucking with the symlinks. I'm on a 64-bit x86 system, so it still seems weird to me that it is trying to build this at all since my understanding was that compiling sqlite3 from source was an ARM problem.

hestia commented on 2016-04-30 02:55

I just have tested with official ghost installation guide (sorry but not AUR packagebuild) below environment and finally achieved success.

> Raspberry Pi 3 B+
> Arch Linux ARM ARMv7
> node v4.4.3
> npm v2.15.1
> used NVM for change node version from 6.0.1 to 4.4.3
> python2, created symlink as @lrizzo comment. But this will not be good idea for production servers. My server is just for test environment and nothing's using python3. First compile with python3 showed error and there is some command option to using python2, but I can't cuz I'm newbie. ;)

Didn't aware nodejs and npm has quite strict dependency with each versions.

--
Hestia @minibrary
https://minibrary.com

PreparationH67 commented on 2016-04-29 19:25

Currently having an issue building sqlite3 that is preventing me from updating the package, there are some references to it using node v6 that seems to be the cause, but I am unsure of how to fix the issue.

@Irizzo advice is dangerous and incorrect, do not manipulate the python symlink on your system as most packages are working on the, correct, assumption that /usr/bin/python on Arch Linux is python3 and it is up to package maintainers to patch any packages that still assume /usr/bin/python is symlinked to python2. Manual manipulations like this should only be done as a temporary work around and undone right away or other programs will break on your system.

Horo commented on 2016-03-11 03:43

I have used python (not python2) to test and I haven't found problem now......

All comments