Package Details: ghost 0.11.0-1

Git Clone URL: https://aur.archlinux.org/ghost.git (read-only)
Package Base: ghost
Description: Free, open, simple blogging platform
Upstream URL: http://ghost.org
Keywords: nodejs
Licenses: MIT
Submitter: cyang
Maintainer: Horo
Last Packager: Horo
Votes: 22
Popularity: 1.757496
First Submitted: 2013-10-15 06:07
Last Updated: 2016-09-23 09:33

Latest Comments

MattScherbatsky commented on 2016-09-22 09:33

Ghost 0.11.0 is out..

niklaszantner commented on 2016-08-21 21:27

Interestingly I get this on install:

npm ERR! Linux 4.7.0.201608131240-1-grsec
npm ERR! argv "/usr/bin/node" "/home/admin/.npm-global/bin/npm" "install" "--production"
npm ERR! node v6.4.0
npm ERR! npm v3.10.6
npm ERR! path /tmp/yaourt-tmp-admin/aur-ghost/pkg/ghost/srv/ghost/node_modules/.staging/core-js-36a99c7e/fn/reflect/prevent-extensions.js
npm ERR! code ENOSPC
npm ERR! errno -28
npm ERR! syscall open

npm ERR! nospc ENOSPC: no space left on device, open '/tmp/yaourt-tmp-admin/aur-ghost/pkg/ghost/srv/ghost/node_modules/.staging/core-js-36a99c7e/fn/reflect/prevent-extensions.js'
npm ERR! nospc This is most likely not a problem with npm itself
npm ERR! nospc and is related to insufficient space on your system.

npm ERR! Please include the following file with any support request:
npm ERR! /tmp/yaourt-tmp-admin/aur-ghost/pkg/ghost/srv/ghost/npm-debug.log


I already increased the amount of allowed watchers and checked the tmp dir for size - both fine. Has someone an idea?

nash commented on 2016-07-30 06:31

With the following simple patch, 0.9.0 seems to work well.

--- PKGBUILD 2016-07-30 14:46:01.240103642 +0900
+++ PKGBUILD.txt 2016-07-30 15:27:52.319174651 +0900
@@ -4,28 +4,25 @@
# Colaborator: Jonhoo

pkgname=ghost
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Free, open, simple blogging platform"
arch=('any')
url="http://ghost.org"
license=('MIT')
makedepends=('unzip')
-depends=('nodejs>=0.12' 'npm' 'python')
+depends=('nodejs>=4.0' 'npm' 'python')
backup=('srv/ghost/config.js')
install=ghost.install
source=(https://ghost.org/zip/$pkgname-$pkgver.zip
ghost.service
ghost.install
- package.json.patch
- npm-shrinkwrap.json.patch
)
noextract=($pkgname-$pkgver.zip)
-sha512sums=('b707c411a014d6aeb9de6bd297ba446e4c16fbd8077f6fd1cb03baf357f0d7a24449a66d75b956978bbb966ea7027664488761b2de82ff07686b3e29d2c686df'
+sha512sums=('f7d1b05f71ad4f03ed65b83c4e0845c4997f299013af90f3a16b74aab61d703c154fce42ab9a814ae200e25709d59436e0c521fcd74e3b6b6a2b69293128fb6a'
'9028de4621c38bf83a22c1cbfa0529d6538516838d641730226fcc24487d654a7d8dcb0b45e455a0a697bd0a9dd80dfdbce6ca8ec1d2e895683ab35846dac10c'
'c4cbd918bf050dbf4b77d5ff016836947351fb1f575359b19e0d6c0343275a253f0922e3be952a9e672c3d2659e67327f92c19573ff5e5fde7f68826afec6d8f'
- '17e9c5572f4976af6e129ca20e66b8ef9aeb626b037d1d4b3de19a1dfa9d8feb7854d84dbfeba0e2056ed18cd05215fab5b7a0e05e4c1d67c17e4b58c4fe0483'
- 'be732d99fd2326d103f67cc502eb4ea0ae3bc4b2b2b4d2a713eb1dac7ee5357e01cc05ec9f73762b687a44b39370cb0f05d362d560a5b06e2f6e1b65c3ccaf4e')
+)

# Note: You may need to log into ghost.org and download the zip file manually
# and place it inside the same directory as the PKGBUILD
@@ -35,8 +32,6 @@
cd "$pkgdir/srv/ghost"
unzip "$srcdir/$pkgname-$pkgver.zip"
echo "Fixing sqlite3 to 3.1.4 ......"
- patch npm-shrinkwrap.json < $srcdir/npm-shrinkwrap.json.patch
- patch package.json < $srcdir/package.json.patch
echo "Ingoring Ghost's Nodejs version check ......"
export GHOST_NODE_VERSION_CHECK=false
cp config.example.js config.js

Horo commented on 2016-05-31 01:34

I use some patch to make ghost use node-sqlite3@3.1.4 ,and it worked."
(These patch may be removed if Ghost support nodejs 6.x offically)

letroll commented on 2016-05-18 07:54

@springmeyer : "node-sqlite3@3.1.4 has been released, which is the first one to support node v6."

Horo commented on 2016-05-09 13:31

sqlite3 module could not support nodejs 6.0 yet :https://github.com/mapbox/node-sqlite3/issues/638

PreparationH67 commented on 2016-05-02 18:46

Confirmed that I was able to install the package with nodejs-lts installed instead of the latest nodejs from the official repos and did NOT need to mess with any of the python symlinks, I'm guessing NPM has been using python2 correctly and changing the links just happened to not break anything. I'm not sure what's the best way to handle this in the package config besides more strict dependencies on the nodejs version that match the ghost officially supported node versions page or some more complicated setup around it to have ghost use a different node version in a manner that allows multiple installed versions.

PreparationH67 commented on 2016-05-02 17:00

I finally got around to confirming that sqlite3 can be build via NPM on my system in a clean directory, but errors out when trying to install/build in the ghost directory so it is something specific to Ghosts javascript packages and config. Currently installing nodejs-lts from the AUR to see if that helps when I get a change to try this again, but it does seem like node-gyp/npm are using the correct python binary without mucking with the symlinks. I'm on a 64-bit x86 system, so it still seems weird to me that it is trying to build this at all since my understanding was that compiling sqlite3 from source was an ARM problem.

hestia commented on 2016-04-30 02:55

I just have tested with official ghost installation guide (sorry but not AUR packagebuild) below environment and finally achieved success.

> Raspberry Pi 3 B+
> Arch Linux ARM ARMv7
> node v4.4.3
> npm v2.15.1
> used NVM for change node version from 6.0.1 to 4.4.3
> python2, created symlink as @lrizzo comment. But this will not be good idea for production servers. My server is just for test environment and nothing's using python3. First compile with python3 showed error and there is some command option to using python2, but I can't cuz I'm newbie. ;)

Didn't aware nodejs and npm has quite strict dependency with each versions.

--
Hestia @minibrary
https://minibrary.com

PreparationH67 commented on 2016-04-29 19:25

Currently having an issue building sqlite3 that is preventing me from updating the package, there are some references to it using node v6 that seems to be the cause, but I am unsure of how to fix the issue.

@Irizzo advice is dangerous and incorrect, do not manipulate the python symlink on your system as most packages are working on the, correct, assumption that /usr/bin/python on Arch Linux is python3 and it is up to package maintainers to patch any packages that still assume /usr/bin/python is symlinked to python2. Manual manipulations like this should only be done as a temporary work around and undone right away or other programs will break on your system.

Horo commented on 2016-03-11 03:43

I have used python (not python2) to test and I haven't found problem now......

lrizzo commented on 2016-03-08 01:37

All those having an issue with build failing for sqlite (e.g. below in comments); you are missing python2.

Run 'pacman -S python2' and re-rerun the makepkg -s

Note: python2 is installed as /usr/bin/python2 so one needs to symlink that to python. By default installing python2 will *NOT* create /usr/bin/python. For example:

ln -s /usr/bin/python2 /usr/bin/python

Also make sure you uninstall python 3 (the default python when you install via pacman -S python) by running pacman -R python

If you follow the above steps, you should have no problem in compiling the ghost package)

--
Lucius Rizzo
https://mail.edu.ky

ursidal commented on 2016-02-28 14:59

Trying to compile on a Raspberry Pi B+, I got stuck on the sqlite3 part.
I found somewhere that it is because of the lack of RAM/swap.
I have created a swapfile (see Archwiki) of 1024M (maybe less is enough) and it compiled.

PreparationH67 commented on 2016-02-19 16:09

Thanks for the quick update!

nash commented on 2016-02-15 13:05

Wow, updated! Thanks!

helmi77 commented on 2016-01-07 12:48

As a temporary workaround you could replace the "node" version string in package.json with the version you're using.

lordmetroid commented on 2016-01-05 22:34

Using ghost-0.7.1-3 on an updated Archlinux as of Jan 2016-01-05:

Jan 05 22:25:30 gorilla npm[16766]: ERROR: Unsupported version of Node
Jan 05 22:25:30 gorilla npm[16766]: Ghost needs Node version ~5.0 you are using version 5.3.0

Jonhoo commented on 2015-11-06 01:00

Updated new-node.patch that works with v5: http://pastebin.com/kBeMdbyx

jascha commented on 2015-10-13 07:27

After the latest npm Update, the ghost servcice doesn't start anymore :(

Okt 13 09:08:09 systemd[1]: Started Ghost Blogging Platform.
Okt 13 09:08:10 npm[680]: > ghost@0.7.1 start /srv/ghost
Okt 13 09:08:10 npm[680]: > node index "/srv/ghost"
Okt 13 09:08:10 npm[680]: ERROR: Unsupported version of Node
Okt 13 09:08:10 npm[680]: Ghost needs Node version ~4.1.0 you are using version 4.2.0
Okt 13 09:08:10 npm[680]: Please go to http://nodejs.org to get a supported version

€dit: Just manually edit package.json and change "node": "~4.1.0",
This will solve the issue.

sflor commented on 2015-10-10 18:00

Build fails for me:

patching file /tmp/pacaurtmp-sf/ghost/pkg/ghost/srv/ghost/package.json
npm WARN engine html-to-text@1.3.0: wanted: {"node":">= 0.8.0 <=0.12 || <=1.4.0"} (current: {"node":"4.1.2","npm":"3.3.6"})
npm WARN prefer global js-beautify@1.5.4 should be installed with -g

> sqlite3@3.1.0 install /tmp/pacaurtmp-sf/ghost/pkg/ghost/srv/ghost/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

pedrogabriel commented on 2015-10-01 23:51

I will removed it, but Namcap acuse java-environment as a dep. If you think this is a bug, please contact the namcap upstream.

draringi commented on 2015-09-30 15:55

Removed java-environment from deps list and still builds and installs perfectly (on a machine without java-environment). Seems to be no reason for it.

Jonhoo commented on 2015-09-29 03:11

Why did you add java-environment as a makedepends? I can't see anything that would indicate this is needed from the changelog?

orbifx commented on 2015-09-24 08:54

Thanks Jonhoo, that did the trick. All up and working now.

Jonhoo commented on 2015-09-23 15:12

Ah, yes, AUR messes with whitespace. Try http://pastebin.com/PMsqfKE3

orbifx commented on 2015-09-23 13:15

Jonhoo: I get an error with the patch:

patch: **** malformed oatch at line 4: "test": "grunt validate --verbose"

Is the patch out of date?

Jonhoo commented on 2015-09-23 04:42

FWIW, a working installation can be produced by:

1) Create a new file, new-node.patch, alongside the PKGBUILD:
--- package.json 2015-09-23 00:28:53.733674984 -0400
+++ package.json 2015-09-23 00:30:08.830456732 -0400
@@ -22,7 +22,7 @@
"test": "grunt validate --verbose"
},
"engines": {
- "node": "~0.10.0 || ~0.12.0",
+ "node": "~4.1.0",
"iojs": "~1.2.0"
},
"dependencies": {
@@ -60,7 +60,7 @@
"rss": "1.1.1",
"semver": "4.3.6",
"showdown-ghost": "0.3.6",
- "sqlite3": "3.0.8",
+ "sqlite3": "3.1.0",
"unidecode": "0.1.3",
"validator": "3.40.0",
"xml": "1.0.0"
2) Add new-node.patch to PKGBUILD source array (and run updpkgsums to add checksum)
3) Before "npm install --production" in package(), add:
patch "$pkgdir/srv/ghost/package.json" < "$srcdir/new-node.patch"
rm "$pkgdir/srv/ghost/npm-shrinkwrap.json"

This will update the dependency list of ghost to use an *unsupported* configuration though, so be careful. Discussion on the Ghost issue tracker here: https://github.com/TryGhost/Ghost/issues/5821

Jonhoo commented on 2015-09-23 04:25

Currently fails to build (because of sqlite3), but old version also fails to run:
Sep 23 06:24:02 npm[413]: ERROR: Unsupported version of Node
Sep 23 06:24:02 npm[413]: Ghost needs Node version ~0.10.0 || ~0.12.0 you are using version 4.1.0

lordmetroid commented on 2015-09-21 18:21

Tried to restart ghost but it complains about not finding ghost/node_modules/sqlite3/lib/binding/node-v46-linux-x64
There is however a node-v14-linux-x64

pedrogabriel commented on 2015-09-18 03:48

It's currently not building, because there's no sqlite3 build for npm 4.1.0.

blackleg commented on 2015-09-16 23:37

Ghost is a java script program
Not dependent of the processor architecture

Can change the package arch to any?

arch=('any')

blackleg commented on 2015-09-04 14:23

@barsanuphe Build fails if npm is not installed, it should be added in the dependencies.

Add npm in the PKGBUILD
makedepends=('unzip' 'npm')

vreyes commented on 2015-05-28 19:33

Ghost 0.6.4 is out.

barsanuphe commented on 2015-05-05 20:26

Build fails if npm is not installed, it should be added in the dependencies.

vreyes commented on 2015-04-01 00:02

From https://github.com/TryGhost/Ghost

# Node v0.10.x - full support
# Node v0.12.x and io.js v1.2 - partial support
#
# Choose wisely

and PKGBUILD
depends=('nodejs>=0.12')

jdarnold commented on 2015-03-26 12:40

I'm getting the following when trying to update ghost after updating nodejs to 0.12:

npm WARN engine html-to-text@1.2.0: wanted: {"node":">= 0.8.0 <0.12"} (current: {"node":"0.12.0","npm":"2.7.1"})
/tmp/packerbuild-1000/ghost/ghost/PKGBUILD: line 22: 9085 Killed npm install --production
==> ERROR: A failure occurred in package().
Aborting...
The build failed.

HLFH commented on 2015-03-10 12:49

http://dev.ghost.org/ghost-0-5-10/ released with Node v0.12 (and the ugly io.js) support.

voxel commented on 2015-02-27 07:33

Thank you, I totally missed that. If it's a recommendation coming from Ghost itself then we should respect it.

cyang commented on 2015-02-25 19:12

Not sure, I haven't had a chance to test, but the docs say that 0.11.x are not supported. http://support.ghost.org/installation/

voxel commented on 2015-02-25 11:18

Do we really need the nodejs<0.11.0 dependency? Just asking out of interest since my Pacman won't run now without adding nodejs into IgnorePkg list.

leafonsword commented on 2014-12-18 07:04

Upgrading to ghost 0.5.7-1 occurs foolowing err:
-----------------------------------------------------------
npm ERR! Linux 3.16.5-x86_64-linode46
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "--production"
npm ERR! node v0.10.34
npm ERR! npm v2.1.14
npm ERR! code ELIFECYCLE

npm ERR! sqlite3@3.0.2 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sqlite3@3.0.2 install script 'node-pre-gyp install --fallback-to-build'.
npm ERR! This is most likely a problem with the sqlite3 package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get their info via:
npm ERR! npm owner ls sqlite3
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /tmpdir/yaourt-tmp-gf/aur-ghost/pkg/ghost/srv/ghost/npm-debug.log
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build ghost.
==> Restart building ghost ? [y/N]

NOTtheMessiah commented on 2014-12-18 05:01

Make sure you have the environment variable PYTHON=python2 before building, otherwise, gyp will complain.

voxel commented on 2014-12-05 13:39

Ghost 0.5.6 is out.

voxel commented on 2014-11-18 15:16

Ghost 0.5.4 released.

cyang commented on 2014-09-15 16:27

Thanks, updated.

sflor commented on 2014-09-15 06:28

What about 0.5.1? https://github.com/TryGhost/Ghost/releases

cyang commented on 2014-09-15 01:50

Someone flagged this out of date, 0.5.0 is currently the newest announced version I have found.

cyang commented on 2014-08-11 19:51

Package has been updated to 0.5.0 and is no longer running as root. Please backup the content directory before updating.

voxel commented on 2014-08-05 13:06

Please update.

linkmauve commented on 2014-06-01 13:43

Hi, could you make it run from a dedicated user instead, create it in an install file, remove it at uninstall time, and make the service script use it, while chowning the files required to be writable by it.

It is very uncomfortable to run it as root all the time.

qote commented on 2014-05-26 21:47

Last week of May and still not updated. Any chances to see the new version soon?

cyang commented on 2014-04-01 01:47

0.4.2 is out, but I won't have a chance to update the package until May. Someone can take a look in the meantime.

ilpianista commented on 2014-02-10 16:28

Oh wait, python2 is needed only on ARM, where sqlite3 is built from sources.
Forgot it then!

ilpianista commented on 2014-02-10 16:22

stack Error: Can't find Python executable "python2", you can set the PYTHON env variable.

Please add python2 to makedepends

cyang commented on 2014-01-23 20:28

I have updated the package to 0.4 with all your suggestions, please let me know if you find any bugs.

Backup the content directory before updating to be safe.

leafonsword commented on 2014-01-13 14:52

ghost 0.4 has released,please upgrade!

ilpianista commented on 2013-12-14 09:18

you don't need unzip to extract a ZIP archive, bsdtar can do that.

leafonsword commented on 2013-12-07 13:07

since differences of development mode and production mode will grow and become more apparent,and most users will be more suitable to production mode,it may be better to settle:
npm start --production
in ghost.service

cyang commented on 2013-12-06 16:04

Thanks guys, I've updated the PKGBUILD with the corrections.

Seems like the hash difference was due to the line terminators changing on all the files.

leafonsword commented on 2013-12-05 14:03

I also calculated with "5a323ac459ac16d84c92171c25e1c820a6ccd962812ed260bde7666f7cbe9922"
Please update PKGBUILD~

leafonsword commented on 2013-12-05 13:59

==> Validating source files with sha256sums...
ghost-0.3.3.zip ... FAILED
ghost.service ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build ghost.

starfry commented on 2013-11-20 14:28

I found the checksum for ghost-0.3.3.zip to be incorrect in the PKGBUILD. I calculated this to be '5a323ac459ac16d84c92171c25e1c820a6ccd962812ed260bde7666f7cbe9922'.

Also, I think you should add a makedepends=('unzip') to the PKGBUILD.

elirei72 commented on 2013-10-29 03:00

Awesome package man. However it would be helpful for people installing to add "After starting ghost, type http://<domain_name>:2368/ghost in your browser" to the echo in the package build.