Package Details: gimagereader 3.1.91-2

Git Clone URL: https://aur.archlinux.org/gimagereader.git (read-only)
Package Base: gimagereader
Description: A graphical frontend to tesseract-ocr
Upstream URL: http://sourceforge.net/projects/gimagereader/
Licenses: GPL3
Submitter: FredBezies
Maintainer: Tristelune
Last Packager: Tristelune
Votes: 88
Popularity: 0.664945
First Submitted: 2010-09-03 18:19
Last Updated: 2016-07-14 18:05

Latest Comments

Tristelune commented on 2016-07-14 18:06

Done, thank you for the hint!

eta-carinae commented on 2016-07-12 13:46

Hi, cmake should be included in the makedepends array. Also, if the build fails (for example, you don't have cmake installed :) ), then subsequent attempts will fail on the line "mkdir build", as that directory now exists.

Thanks for updating.

Tristelune commented on 2016-07-11 13:32

Sorry for the long time I had a lot of to do until now. Because of the problem of the build and there is not a lot of changes at the moment I have updated to version 3.1.91.

slav commented on 2016-05-31 22:37

so we're waiting for v3.2 to fixing build?

slav commented on 2016-05-07 22:45

the same here...
error: ‘M_PI’ was not declared in this scope
avgDeskew = qRound(((avgDeskew/nDeskew)/M_PI * 180.) * 10.) / 10.;

Boohbah commented on 2016-05-06 18:00

Fails to build with gcc 6.1.1

src/gimagereader-3.1.2/qt/src/Displayer.cc:480:42: error: ‘M_PI’ was not declared in this scope

Tristelune commented on 2016-05-01 09:48

I won't update gimagereader to the latest version, because 3.1.2 is a stable release and the last one is a beta. But I can create another package until gimagereader 3.2 is released. Is somebody interested ?

hutou commented on 2016-01-28 22:02

Sorry, my bad ! I just missed the down arrow icon to change from osd to fr_FR !
Works fine, now.
Thanks

Tristelune commented on 2016-01-28 12:01

Hi, could you send me your document at my email address ? I'll have a look at it.

hutou commented on 2016-01-27 16:26

Hi,
just installed packages tesseract, tesseract-data-fra and gimagereader and got very bad OCR from gimagereader (but very good from tesseract command line).
So I check the logs :
janv. 27 16:47:07 m1530al gimagereader-qt4.desktop[2597]: Error opening data file /usr/share/tessdata/eng.traineddata
janv. 27 16:47:07 m1530al gimagereader-qt4.desktop[2597]: Please make sure the TESSDATA_PREFIX environment variable is set to the parent directory of your "tessdata" directory.
janv. 27 16:47:07 m1530al gimagereader-qt4.desktop[2597]: Failed loading language 'eng'
janv. 27 16:47:07 m1530al gimagereader-qt4.desktop[2597]: Tesseract couldn't load any languages!
Do I need to install the git version of tesseract ?

GordonGR commented on 2015-06-30 12:08

Thanks.

Tristelune commented on 2015-06-29 19:22

Sorry, it is fixed now.

GordonGR commented on 2015-06-27 10:51

==> Validating source files with sha256sums...
gimagereader-3.1.1.tar.xz ... FAILED
==> ERROR: One or more files did not pass the validity check!

Tristelune commented on 2015-06-26 15:22

Updated to version 3.1.1.

Tristelune commented on 2015-05-02 18:08

Version 3.1 is out.

Tristelune commented on 2015-01-06 14:54

The package has been updated. The qt interface is built and all gtk dependance have been removed. Thank you for your comment!

Alister.Hood commented on 2015-01-05 11:43

Should the gtk dependencies be removed? Or is there something else that needs to be added? It only built the qt version for me...
Also note that there is a new release.

Tristelune commented on 2014-12-20 15:41

Sorry, I created yesterday the package qtspell and I have forgotten to add it in the dependencies. The package is updated.

jeffcasavant commented on 2014-12-19 19:57

New dependency: poppler-qt4

-- checking for module 'poppler-qt4'
-- package 'poppler-qt4' not found

jeffcasavant commented on 2014-12-19 19:55

New dependency: poppler-qt4

-- checking for module 'poppler-qt4'
-- package 'poppler-qt4' not found

aur/qtspell provides QtSpell-qt4 (previous comment).

BOHverkill commented on 2014-12-19 19:24

New Dependency qtspell

-- checking for module 'QtSpell-qt4'
-- package 'QtSpell-qt4' not found

Tristelune commented on 2014-12-19 15:41

The package has been updated.

Tristelune commented on 2014-12-15 17:54

The package will be updated. The build system has changed. As soon as I know how to build the software with the new system, I will update the package on AUR.

Tristelune commented on 2014-11-14 12:56

I don't know if you still have the problem. I have updated the package gtkspellmm. Perhaps it can solve the issue.

Tristelune commented on 2014-11-07 17:23

Are the other packages up to date ?
When you install gimagereader is gtkspell3 installed ?

3ED_0 commented on 2014-11-01 19:27

[..]
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for GIMAGEREADER... no
configure: error: Package requirements (gtkmm-3.0 >= 3.6 gtkspellmm-3.0 >= 3.0.2
cairomm-1.0 poppler-glib) were not met:

Package 'gtkspell3-3.0', required by 'gtkspellmm-3.0', not found
[..]

Tristelune commented on 2014-10-17 13:50

Done, thank you!

natrio commented on 2014-10-15 08:50

The "make" dependencies may be NOT excluded from "running" dependencies list.

Please, add to PKGBUILD the real dependencies of this package:
gtkspellmm tesseract sane

biloucat commented on 2014-09-30 06:57

When i run gimagereader in lxterminal i get:
WARNING **: iso_639.xml: L'ouverture du fichier « /usr/share/xml/iso-codes/iso_639.xml » a échoué : échec de open() : Aucun fichier ou dossier de ce type
WARNING **: iso_3166.xml: L'ouverture du fichier « /usr/share/xml/iso-codes/iso_3166.xml » a échoué : échec de open() : Aucun fichier ou dossier de ce type

"yaourt -S iso-codes" does the job but I do not know if it's really useful

Tristelune commented on 2014-09-02 14:02

@biloucat: I have removed the dependency on appdata-tools.This package was required to validate appdata files (here: gimagereader.appdata.xml). But in Archlinux we don't use those files, so it's not necessary to install this package.

zebulon commented on 2014-08-27 08:51

@Tristelune: Thank you very much, compiled and installed like a charm!

Tristelune commented on 2014-08-26 20:52

@zebulon: thank you for your comment. I have made the change. Now it should build wihtout a problem.

@biloucat: no idea, I have just taken it from the documentation. I will contact soon the developper for some comments, I'll ask him.

biloucat commented on 2014-08-25 09:45

@Tristelune: I tested your version successfully but removing the dependency on appdata-tools.
Could you tell me the usefulness of this dependence ?

zebulon commented on 2014-08-25 08:04

@Tristelune: I think I have found the issue: poppler-glib is a makedepends of cairo, not a depends. (https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/cairo)

So it may be uninstalled after cairo has been built, and it is not installed when cairo is installed from binary package. You should make poppler-glib as a makedependency if you need it to build gimagereader.

zebulon commented on 2014-08-25 07:45

@Tristelune: I may have discovered a yaourt issue there then. When trying to reinstall cairo, poppler-glib is not installed along. I will contact the yaourt developers.

zebulon commented on 2014-08-25 07:41

Hi, yes, I use yaourt and it lists dependencies at the start:
gimagereader 2.93-2 (ven. sept. 3 19:19:01 BST 2010)
==> Dépendances de gimagereader :
- hicolor-icon-theme (déjà installé)
- appdata-tools (déjà installé)
- gtkmm3 (déjà installé)
- gtkspellmm (déjà installé)
- desktop-file-utils (déjà installé)
- intltool (déjà installé)
- sane (déjà installé)
- tesseract (déjà installé)

gtkmm3 is listed, so this is weird. I never had any issues with dependency solving with yaourt, but I cannot exclude that it has issues to resolve this one.

Tristelune commented on 2014-08-22 12:31

Did you try with gimagereader-2.93-2 ? I have updated the package. poppler-glib should be a denpendency of gtkmm3 (gtkmm3 -> pangomm -> cairomm -> cairo -> poppler-glib).

zebulon commented on 2014-08-21 13:26

Hi, I had a config fail due to poppler-glib missing. I suppose it should be a build dependency, maybe a dependency.

Tristelune commented on 2014-08-18 16:39

Thank you for your contribution bilouat! I have uploaded an update of the software. Please test it and tell me if there is a problem.

Tristelune commented on 2014-08-06 13:08

@cookies: I still would like to know when you will update the package or if you are waiting for a 3.0 version. Thanks.

biloucat commented on 2014-07-14 19:51

I make 2 packages to test the new version:
see the PKGBUILDs @ pastebin:
http://pastebin.com/9dRAjyeL
http://pastebin.com/Dx1pGv0g
Beware to uninstall "official imagereader" before install the new version:
i missed conflicts,replaces and provides in the PKGBUILD of gimagereader
@cookies:
feel free to test, correct, improve and, perhaps, adopt this new version

Tristelune commented on 2014-07-02 21:29

Hello,

I would like to test the new version. Could you update the package or do you want to wait for a stable release ?

Lemmiwinks commented on 2014-06-16 13:14

An update to the new (beta) versions of gImageReader would be nice, or a new extra package!

cookies commented on 2013-07-24 09:37

Update to v0.9.1

cookies commented on 2013-03-23 21:11

Update to v0.9-3, fixed dependencies and added a package() function.

natrio commented on 2013-02-26 10:18

Please, fix the dependencies:
pycairo > python2-cairo
python-imaging > python2-imaging

Anonymous comment on 2012-05-28 13:00

Adopted and bumped release.

FredBezies commented on 2011-10-18 21:11

@uwinkelvos : for the time being, you can try xsane2tess which I adopted. It works great, and it is not really hard to use.

See https://aur.archlinux.org/packages.php?ID=24702

FredBezies commented on 2011-10-18 19:19

Reported bug upstream. We depend here on coder to get this bug fixed. Sorry !

https://sourceforge.net/tracker/?func=detail&aid=3425391&group_id=291112&atid=1231316

uwinkelvos commented on 2011-10-18 19:08

"Could not load GTK modules: /usr/lib/python2.7/site-packages/poppler.so: undefined symbol: poppler_page_render_to_pixbuf_for_printing"
when starting the app, ill have a look into this.

FredBezies commented on 2011-03-25 16:12

25 march 2011 : Upgraded to 0.9 version.

FredBezies commented on 2011-02-22 14:57

0.8.1-5 : python-imaging instead of pil-sane.

konlaasz commented on 2011-02-22 14:05

In depends=(), 'pil-sane' should be replaced with 'python-imaging' (see comment @ http://aur.archlinux.org/packages.php?ID=15054).

FredBezies commented on 2011-01-31 16:18

0.8.1-4 : python2-gtkspell dependency added. Thanks for the tip.

FredBezies commented on 2011-01-31 09:04

Thanks for the tip. I will modify PKGBUILD asap today.

Anonymous comment on 2011-01-31 08:42

python-gtkspell needs to be replaced with python2-gtkspell.

FredBezies commented on 2011-01-28 21:45

0.8.1-3 : replacing python-poppler by python2-poppler

FredBezies commented on 2011-01-07 06:35

@ouyoyo : added pil-sane. Scanning will be enabled and working.

Only missing point for now : "Could not load dbus, find PackageKit on dbus or find apt-file: dictionary autoinstallation will not work."

Any idea ?!

Anonymous comment on 2011-01-07 04:29

why ?:

Could not load sane or twain, scanning will not work.
Failed to load gImageReader modules, check your installation: No module named Image

FredBezies commented on 2011-01-01 21:07

Added python-poppler to makedepends.

Updated to 0.8.1 version. Hope it works ;)

FredBezies commented on 2010-12-23 14:22

@le_fuzzy : done. Thanks a lot.

le_fuzzy commented on 2010-12-23 14:09

A dependency needs to be changed from python-pyenchant to python2-pyenchant

FredBezies commented on 2010-10-22 05:55

Updated. Thanks.