Package Details: gimp-devel-noconflict 2.99.18-4

Git Clone URL: https://aur.archlinux.org/gimp-devel-noconflict.git (read-only, click to copy)
Package Base: gimp-devel-noconflict
Description: GNU Image Manipulation Program (Development version, doesn't conflict with gimp 2.0)
Upstream URL: https://www.gimp.org/
Licenses: GPL, LGPL
Provides: gimp
Submitter: su226
Maintainer: su226
Last Packager: su226
Votes: 3
Popularity: 0.000264
First Submitted: 2022-08-09 06:34 (UTC)
Last Updated: 2024-04-07 03:20 (UTC)

Required by (101)

Sources (3)

Latest Comments

Freso commented on 2024-04-07 00:09 (UTC) (edited on 2024-04-07 00:21 (UTC) by Freso)

I don’t know whether this is an upstream or packaging issue, but it seems like /usr/include/gimp-3.0/libgimpbase/gimpchoice.h doesn’t get installed. This in turn leads plugins etc. building against GIMP to fail as libgimpbase/gimpbase.h has #include <libgimpbase/gimpchoice.h>.

Edit: Seems like it was an upstream issue: https://gitlab.gnome.org/GNOME/gimp/-/issues/10900 – patching this in the PKGBUILD would be appreciated. :)

alex-y commented on 2023-04-07 17:05 (UTC)

It works for me today ...

alex-y commented on 2023-03-27 13:17 (UTC)

babl-0.1-name-change-meson.patch ... ÉCHEC

C_Schmidpeter commented on 2023-02-28 05:26 (UTC)

Build fails despite babl being installed (also fails with babl-git):

Found CMake: /usr/bin/cmake (3.25.2) Run-time dependency babl found: NO (tried pkgconfig and cmake)

gimp-2.99.14/meson.build:343:0: ERROR: Dependency "babl" not found, tried pkgconfig and cmake

alex-y commented on 2022-08-18 15:15 (UTC)

Thank you, su226 !