Package Details: gimp-devel 2.99.18-6

Git Clone URL: https://aur.archlinux.org/gimp-devel.git (read-only, click to copy)
Package Base: gimp-devel
Description: GNU Image Manipulation Program (Development version)
Upstream URL: https://www.gimp.org/
Licenses: GPL-3.0-or-later
Conflicts: gimp
Provides: gimp
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 40
Popularity: 0.045940
First Submitted: 2017-02-02 23:39 (UTC)
Last Updated: 2024-06-26 14:41 (UTC)

Required by (101)

Sources (4)

Latest Comments

1 2 3 4 5 6 .. 8 Next › Last »

duffydack commented on 2024-06-27 14:48 (UTC)

Ofc, I'm a dumbass today...

Auerhuhn commented on 2024-06-27 14:42 (UTC)

@duffydack I’m not the maintainer, just trying to be helpful.

I think the depends entries are fine as they are.
You need to build libilbm-git and add the package to a local repo that your chroot can access. Then the gimp-devel build will work in your chroot.

duffydack commented on 2024-06-27 14:34 (UTC)

Can you add to deps please, I build all my stuff in chroots

Auerhuhn commented on 2024-06-27 14:27 (UTC)

@duffydack libilbm is provided by libilbm-git.

duffydack commented on 2024-06-27 06:11 (UTC)

Missing deps while building in chroot.

error: target not found: libilbm

arti commented on 2024-06-17 09:15 (UTC)

Now also needs glib2-devel in makedepends for building

HurricanePootis commented on 2024-05-21 22:46 (UTC) (edited on 2024-05-22 16:06 (UTC) by HurricanePootis)

Here is the patch to fix compiling due to gi-docgen errors, makes license spdx compliant, and adds a propert bug report url.

diff --git a/PKGBUILD b/PKGBUILD
index 330b46b..4a90449 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,11 @@ pkgrel=2
 pkgdesc="GNU Image Manipulation Program (Development version)"
 arch=('i686' 'x86_64' 'armv7h' 'aarch64')
 url="https://www.gimp.org/"
-license=('GPL' 'LGPL')
+license=('GPL-3.0-or-later' 'LGPL-3.0-or-later')
 depends=('gtk3' 'lcms2' 'libwmf' 'icu' 'enchant' 'libgexiv2' 'librsvg' 'desktop-file-utils'
          'libexif' 'libgudev' 'openjpeg2' 'poppler-glib' 'poppler-data' 'openexr' 'mypaint-brushes1'
-         'babl>=0.1.98' 'gegl>=0.4.48' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz')
+         'babl>=0.1.98' 'gegl>=0.4.48' 'cairo' 'python-gobject' 'appstream-glib' 'libxmu' 'graphviz'
+    'libbacktrace-git')
 makedepends=('appstream' 'intltool' 'libxslt' 'glib-networking'
              'alsa-lib' 'curl' 'ghostscript' 'libxpm'
              'libheif' 'libwebp' 'libmng' 'iso-codes' 'aalib' 'zlib' 'libjxl'
@@ -45,6 +46,8 @@ sha256sums=('8c1bb7a94ac0d4d0cde4d701d8b356387c2ecd87abbd35bbf7d222d40f6ddb6e'
 build() {
   local meson_options=(
     -Dilbm=disabled
+    -Dbug-report-url="https://aur.archlinux.org/packages/gimp-devel"
+    -Dgi-docgen=disabled
   )

   arch-meson "${_pkgname}-${pkgver}" build "${meson_options[@]}"

su226 commented on 2024-04-22 04:43 (UTC) (edited on 2024-04-22 04:44 (UTC) by su226)

@HurricanePootis GIMP is GPL-3.0-or-later, not GPL-3.0-only, see FAQ.

libgimp is only mentioned as LGPL in LICENSE, without version, I assume maybe it's LGPL-3.0-or-later?