Package Details: git-annex-standalone 10.20220121-1

Git Clone URL: https://aur.archlinux.org/git-annex-standalone.git (read-only, click to copy)
Package Base: git-annex-standalone
Description: Manage files with git, without checking their contents into git. Standalone version, with no Haskell dependency.
Upstream URL: https://git-annex.branchable.com/
Licenses: GPL
Conflicts: git-annex
Provides: git-annex
Submitter: Schnouki
Maintainer: Schnouki
Last Packager: Schnouki
Votes: 4
Popularity: 0.27
First Submitted: 2019-11-24 21:22 (UTC)
Last Updated: 2022-02-20 10:25 (UTC)

Latest Comments

Schnouki commented on 2021-11-25 14:38 (UTC)

@msauter @ozziem Right, I probably had an older version of the tarball with libffi.so.7 ... Bumped to the latest git-annex version using core/libffi. Thanks for your feedback!

ozziem commented on 2021-11-08 20:38 (UTC)

8.20210904-1 has re-introduced the libffi issue here also (was fixed in previous release). Suggestion from @msauter rectifies the issue. Thanks!

msauter commented on 2021-11-05 12:09 (UTC)

@Schnouki For me the PKGBUILD has still the same defect as in my first comment. I had a look into the current standalone release git-annex-standalone-amd64-8.20210904.tar.gz. The following lists only a single file (libffi.so.8 and no libffi.so.7).

tar tf git-annex-standalone-amd64-8.20210904.tar.gz | grep -i ffi
git-annex.linux/lib/x86_64-linux-gnu/libffi.so.8

Since libffi.so.8 comes with core/libffi, my suggestion to remove the three offending lines still stands.

ozziem commented on 2021-09-23 21:47 (UTC)

Thx! All good here, now.

Schnouki commented on 2021-09-23 13:33 (UTC)

Sorry folks, I probably had something weird in my environment. Updated the package to the latest version. Right now libffi from arch matches the one used in git-annex-standalone, so I'm using the one from the system instead of bundling it.

f0rdprefect commented on 2021-03-15 05:47 (UTC)

same here...

ozziem commented on 2020-12-13 20:44 (UTC)

I have the same error as @kragol and @msauter. Clean build of 8.20201008.

kragol commented on 2020-11-17 22:36 (UTC)

Hi @Schnouki. I have the same problem as @msauter which is due there being no libffi.* files in the usr/lib/x86_64-linux-gnu/ directory.

You can easily check for yourself that there are no such files in git-annex-standalone-amd64-8.20201008.tar.gz

I am not sure why you can make it work on your machine. Perhaps you are using an older cache which contains the libffi files? Have you tried rebuilding the package from scratch? (i.e. using makepkg in a directory containing nothing but the PKGBUILD)

Schnouki commented on 2020-11-13 15:34 (UTC)

@msauter, which version of git-annex-standalone are you building? It works for me with 8.20201008...

msauter commented on 2020-10-12 22:16 (UTC)

For me makepkg fails with the following message:

install: cannot stat 'usr/lib/x86_64-linux-gnu/libffi.so.7': No such file or directory

After removing the three offending lines from PKGBUILD the package builds fine and git annex works properly as far as I can tell.