Package Details: git-cola 2.6-1

Git Clone URL: https://aur.archlinux.org/git-cola.git (read-only)
Package Base: git-cola
Description: A powerful GUI for Git
Upstream URL: http://git-cola.github.com/
Licenses: GPL
Submitter: tdy
Maintainer: nobody44
Last Packager: nobody44
Votes: 173
Popularity: 2.234877
First Submitted: 2008-12-05 14:38
Last Updated: 2016-06-03 19:59

Dependencies (10)

Required by (0)

Sources (1)

Latest Comments

nobody44 commented on 2016-08-20 10:28

I know that, I tried to get it working a week ago, but there was an error in the new dependencies, that come along.

eliluminado commented on 2016-08-19 02:31

The latest stable git-cola release is v2.7 (2016-07-29)

nobody44 commented on 2016-04-25 09:14

That shouldn't happen. There is only one file, that may cause this:

/usr/share/applications/git-cola-folder-handler.desktop

Could you move it somewhere else and try again?

BuZZ-dEE commented on 2016-02-16 08:54

Hi, could you please don't set it as default application for opening folders etc. After installing this package my system wants to open things with Git-Cola instead of Nautilus. E.g. if I click on the Owncloud client tray icon to open my cloud folder, it tries to do that with Git-Cola, which makes no sense.

nobody44 commented on 2016-02-13 11:21

@neng, done. Sorry for the delay.

neng commented on 2016-01-31 04:11

@nobody44 please upgrade to 2.5. Thanks.

alexandre-mbm commented on 2015-08-06 04:53

Se this please: https://github.com/git-cola/git-cola/issues/483#issuecomment-128238944

nobody44 commented on 2015-06-01 18:18

I swear he reuploaded the release. Anyway, now it should work without any problems. Sorry for the delay ;-).

hecsa commented on 2015-05-27 04:09

Hi,

When trying to upgrade, I get this messages:

==> Validating source files with sha256sums...
v2.1.2.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build git-cola.

Is there a way to update the sha256sum with the good one, or any other workaround to update this package?

Thanks, and best regards,

HeCSa.

dracorp commented on 2015-05-21 20:33

Wrong sha256sums
sha256sums=('16fff73d2fd30bebdecce6f6179e87d6a03304e98819177de06055ead74d0f69')

nobody44 commented on 2015-05-17 10:03

It is now. Thanks for the reminder.

BunBum commented on 2015-05-16 06:06

When will it be updated to the latest version?

naraesk commented on 2015-03-26 16:09

cant install the latest version:

make -C share/doc/git-cola all
make[1]: Verzeichnis „/var/cache/pacman/pkg/git-cola8675/git-cola/src/git-cola-2.1.1/share/doc/git-cola“ wird betreten
sphinx-build -b html -d _build/doctrees . _build/html
Makefile:47: die Regel für Ziel „html“ scheiterte
make[1]: Verzeichnis „/var/cache/pacman/pkg/git-cola8675/git-cola/src/git-cola-2.1.1/share/doc/git-cola“ wird verlassen
Makefile:82: die Regel für Ziel „doc“ scheiterte

Azd325 commented on 2015-02-04 20:01

That was happen where I was installing the package with inside of a virtualenv

nobody44 commented on 2015-01-26 14:18

Did you remove the python-sip package? It is a dependency of python-pyqt4, basically you shouldn't be able to remove it...

Azd325 commented on 2015-01-26 12:45

Traceback (most recent call last):
File "/usr/bin/git-cola", line 55, in <module>
from cola.app import add_common_arguments
File "/usr/share/git-cola/lib/cola/app.py", line 20, in <module>
import sip
ImportError: No module named sip

That was happen where I was installing the package with inside of a virtualenv

Azd325 commented on 2015-01-26 12:15

Traceback (most recent call last):
File "/usr/bin/git-cola", line 55, in <module>
from cola.app import add_common_arguments
File "/usr/share/git-cola/lib/cola/app.py", line 20, in <module>
import sip
ImportError: No module named sip

andrewchen commented on 2014-12-13 01:09

Version 2.0.8 compiles, please update.

nobody44 commented on 2014-10-03 16:05

Right now there is a bug in the git-cola code that prevents the package from compiling. I fixed it and created a pull-request on github... I will release the new version as soon as this small bug fix has been merged.

liviucmg commented on 2014-08-23 21:20

Can confirm that the fix posted by @pablovilas works, but only after a reboot.

leledumbo commented on 2014-08-19 04:53

Got similar error as pablovilas, however his locale-gen workaround does't work for me. Logs:

# Sphinx version: 1.2.2
# Python version: 3.4.1
# Docutils version: 0.12 release
# Jinja2 version: 2.7.3
# Loaded extensions:
# sphinx.ext.doctest from /usr/lib/python3.4/site-packages/sphinx/ext/doctest.py
# sphinx.ext.autodoc from /usr/lib/python3.4/site-packages/sphinx/ext/autodoc.py
# sphinx.ext.oldcmarkup from /usr/lib/python3.4/site-packages/sphinx/ext/oldcmarkup.py
# sphinx.ext.coverage from /usr/lib/python3.4/site-packages/sphinx/ext/coverage.py
# sphinx.ext.todo from /usr/lib/python3.4/site-packages/sphinx/ext/todo.py
# sphinx.ext.intersphinx from /usr/lib/python3.4/site-packages/sphinx/ext/intersphinx.py
# sphinxtogithub from /tmp/yaourt-tmp-leledumbo/aur-git-cola/src/git-cola-2.0.5/extras/sphinxtogithub/__init__.py
Traceback (most recent call last):
File "/usr/lib/python3.4/site-packages/sphinx/cmdline.py", line 254, in main
app.build(force_all, filenames)
File "/usr/lib/python3.4/site-packages/sphinx/application.py", line 221, in build
self.emit('build-finished', None)
File "/usr/lib/python3.4/site-packages/sphinx/application.py", line 400, in emit
results.append(callback(self, *args))
File "/tmp/yaourt-tmp-leledumbo/aur-git-cola/src/git-cola-2.0.5/extras/sphinxtogithub/sphinxtogithub.py", line 315, in sphinx_extension
layout.process()
File "/tmp/yaourt-tmp-leledumbo/aur-git-cola/src/git-cola-2.0.5/extras/sphinxtogithub/sphinxtogithub.py", line 174, in process
handler.process()
File "/tmp/yaourt-tmp-leledumbo/aur-git-cola/src/git-cola-2.0.5/extras/sphinxtogithub/sphinxtogithub.py", line 52, in process
text = self.opener(self.name).read()
File "/usr/lib/python3.4/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 3671: ordinal not in range(128)

carstene1ns commented on 2014-08-18 08:40

@zottelef: 'qgis'[1] package is the offender, it bundles the python2 version of pygments and somehow gets in the way. There is already a discussion at the package page. Try removing it before building and it should work.

[1]: https://aur.archlinux.org/packages/qgis/

zottelef commented on 2014-08-18 07:41

While building git-cola I get the following error

sphinx-build -b html -d _build/doctrees . _build/html
Traceback (most recent call last):
File "/usr/bin/sphinx-build", line 9, in <module>
load_entry_point('Sphinx==1.2.2', 'console_scripts', 'sphinx-build')()
File "/usr/lib/python3.4/site-packages/sphinx/__init__.py", line 49, in main
from sphinx import cmdline
File "/usr/lib/python3.4/site-packages/sphinx/cmdline.py", line 22, in <module>
from sphinx.application import Sphinx
File "/usr/lib/python3.4/site-packages/sphinx/application.py", line 22, in <module>
from docutils.parsers.rst import convert_directive_function, \
File "/usr/lib/python3.4/site-packages/docutils/parsers/rst/__init__.py", line 75, in <module>
from docutils.parsers.rst import states
File "/usr/lib/python3.4/site-packages/docutils/parsers/rst/states.py", line 116, in <module>
from docutils.parsers.rst import directives, languages, tableparser, roles
File "/usr/lib/python3.4/site-packages/docutils/parsers/rst/roles.py", line 78, in <module>
from docutils.utils.code_analyzer import Lexer, LexerError
File "/usr/lib/python3.4/site-packages/docutils/utils/code_analyzer.py", line 12, in <module>
import pygments
File "/usr/share/qgis/python/pygments/__init__.py", line 46
except TypeError, err:
^
SyntaxError: invalid syntax
Makefile:44: recipe for target 'html' failed
make[1]: *** [html] Error 1

pablovilas commented on 2014-02-26 19:30

In order to fix the encoding problem I just uncomment my locale in: /etc/locale.gen, then I run locale-gen and then set it as default enconding using localectl set-locale LANG="<encoding>" where encoding is for example: en_US.UTF-8

pablovilas commented on 2014-02-25 18:37

When I try to upgrade to version 2.0.0-1 I've the same error than Nikus

# Sphinx version: 1.2.1
# Python version: 3.3.4
# Docutils version: 0.11 release
# Jinja2 version: 2.7.2
# Loaded extensions:
# sphinx.ext.intersphinx from /usr/lib/python3.3/site-packages/sphinx/ext/intersphinx.py
# sphinx.ext.coverage from /usr/lib/python3.3/site-packages/sphinx/ext/coverage.py
# sphinx.ext.oldcmarkup from /usr/lib/python3.3/site-packages/sphinx/ext/oldcmarkup.py
# sphinxtogithub from /tmp/yaourt-tmp-root/aur-git-cola/src/git-cola-2.0.0/extras/sphinxtogithub/__init__.py
# sphinx.ext.doctest from /usr/lib/python3.3/site-packages/sphinx/ext/doctest.py
# sphinx.ext.autodoc from /usr/lib/python3.3/site-packages/sphinx/ext/autodoc.py
# sphinx.ext.todo from /usr/lib/python3.3/site-packages/sphinx/ext/todo.py
Traceback (most recent call last):
File "/usr/lib/python3.3/site-packages/sphinx/cmdline.py", line 254, in main
app.build(force_all, filenames)
File "/usr/lib/python3.3/site-packages/sphinx/application.py", line 221, in build
self.emit('build-finished', None)
File "/usr/lib/python3.3/site-packages/sphinx/application.py", line 358, in emit
results.append(callback(self, *args))
File "/tmp/yaourt-tmp-root/aur-git-cola/src/git-cola-2.0.0/extras/sphinxtogithub/sphinxtogithub.py", line 315, in sphinx_extension
layout.process()
File "/tmp/yaourt-tmp-root/aur-git-cola/src/git-cola-2.0.0/extras/sphinxtogithub/sphinxtogithub.py", line 174, in process
handler.process()
File "/tmp/yaourt-tmp-root/aur-git-cola/src/git-cola-2.0.0/extras/sphinxtogithub/sphinxtogithub.py", line 52, in process
text = self.opener(self.name).read()
File "/usr/lib/python3.3/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 3222: ordinal not in range(128)

nobody44 commented on 2014-02-25 00:46

Updated to latest git-cola release:

Git-Cola run with Python3 now, so some dependencies changed: python-pyqt4 instead of python2-pyqt4, python-sphinx instead of python2-sphinx

Other than that, I hope it runs fine with Python3.

nobody44 commented on 2013-12-29 14:54

Updated, thanks for the info.

dujiulun2006 commented on 2013-12-28 15:21

I guess the dependency "python2-pyqt" should be "python2-pyqt4" which is what it's now called in [extra]. Tried myself and it works well.

nobody44 commented on 2012-12-20 12:14

Thanks for the error report, but I have to say, that I cannot fix this. This is python2-sphinx and/or python2 itself. There is nothing I can do about it.

Nikus commented on 2012-12-19 23:59

I have the following error when I try to compile the package :
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 15: ordinal not in range(128)

It's due to the path where I extracted the tarball which contains an « é ». Using an utf8 codec instead of an ascii one should be better.

# Sphinx version: 1.1.3
# Python version: 2.7.3
# Docutils version: 0.10 release
# Jinja2 version: 2.6
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/sphinx/cmdline.py", line 189, in main
app.build(force_all, filenames)
File "/usr/lib/python2.7/site-packages/sphinx/application.py", line 204, in build
self.builder.build_update()
File "/usr/lib/python2.7/site-packages/sphinx/builders/__init__.py", line 196, in build_update
'out of date' % len(to_build))
File "/usr/lib/python2.7/site-packages/sphinx/builders/__init__.py", line 216, in build
purple, length):
File "/usr/lib/python2.7/site-packages/sphinx/builders/__init__.py", line 120, in status_iterator
for item in iterable:
File "/usr/lib/python2.7/site-packages/sphinx/environment.py", line 613, in update_generator
self.read_doc(docname, app=app)
File "/usr/lib/python2.7/site-packages/sphinx/environment.py", line 758, in read_doc
pub.set_source(None, src_path.encode(fs_encoding))

nobody44 commented on 2012-08-31 12:30

those packages are in makedepends

Anonymous comment on 2012-08-31 04:32

in addition to python2-sphinx missing, add also asciidoc, xmlto, and rsync.

nobody44 commented on 2012-03-18 16:08

New Version: 1.7.6
Dependencies changed: sphinx2-build>=1.1.3
PKGBUILD slightly changed for sphinx-build2

nobody44 commented on 2012-02-06 15:20

makedepends changed: python2-sphinx instead of python-sphinx

amatriain commented on 2012-02-01 11:18

It refused to compile until I changed python-sphinx to python2-sphinx in the PKGBUILD. The root cause is probably this:

https://bugs.archlinux.org/task/27820

This PKGBUILD works for me:

http://pastebin.com/uhh18yfR

nobody44 commented on 2012-01-24 11:54

kgu, your updated PKGBUILD doesn't work for me:
###############
sphinx-build -b html -d _build/doctrees . _build/html
Traceback (most recent call last):
File "/usr/bin/sphinx-build", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.2/site-packages/pkg_resources.py", line 2708, in <module>
working_set.require(__requires__)
File "/usr/lib/python3.2/site-packages/pkg_resources.py", line 686, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.2/site-packages/pkg_resources.py", line 584, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: docutils>=0.7
################

The newest version is 1.7.4.1. Same problem there.
What exactly does python-sphinx do? I installed my own git-cola-package without the documentation...

Anonymous comment on 2011-12-29 22:57

Update for Version 1.7.3. Please update the pkg.
The following PKGBUILD works for me:

#########################################################

pkgname=git-cola
pkgver=1.7.3
pkgrel=1
pkgdesc="A powerful GUI for Git"
arch=('any')
url="http://git-cola.github.com/"
license=('GPL')
depends=('git' 'python2-pyqt>=4.3')
makedepends=('asciidoc' 'docbook-xsl' 'python-sphinx' 'rsync' 'xmlto')
optdepends=('pyinotify>=0.7.1: for inotify support'
'tk: to use the built-in ssh-askpass handler')
options=('!makeflags')
source=(https://github.com/git-cola/git-cola/downloads/git-cola-$pkgver.tar.gz)
md5sums=('5f7c3f1e596b25092b25e537e3814ad2')

build() {
cd "$srcdir/${pkgname}-$pkgver"
sed -i 's,= python,&2,' Makefile
sed -i '1s,python,&2,' bin/$pkgname
make all doc html
}

package() {
cd "$srcdir/${pkgname}-$pkgver"
make prefix=/usr DESTDIR="$pkgdir" install{,-doc,-html}
}

#############################################################


Anonymous comment on 2011-11-14 23:44

Version 1.7.0 is out and hosting has moved to github. The following PKGBUILD works for me.

######################################################################
pkgname=git-cola
pkgver=1.7.0
pkgrel=1
pkgdesc="A powerful GUI for Git"
arch=('any')
url="http://git-cola.github.com/"
license=('GPL')
depends=('git' 'python2-pyqt>=4.3')
makedepends=('asciidoc' 'docbook-xsl' 'python-sphinx' 'rsync' 'xmlto')
optdepends=('pyinotify>=0.7.1: for inotify support'
'tk: to use the built-in ssh-askpass handler')
options=('!makeflags')
source=(https://github.com/downloads/git-cola/git-cola/cola-$pkgver.tar.gz)
md5sums=('f7d6c67eb2c970bbd4343c4c6c2b51e6')

build() {
cd "$srcdir/${pkgname/*-}-$pkgver"
sed -i 's,= python,&2,' Makefile
sed -i '1s,python,&2,' bin/$pkgname
make all doc html
}

package() {
cd "$srcdir/${pkgname/*-}-$pkgver"
make prefix=/usr DESTDIR="$pkgdir" install{,-doc,-html}
}
######################################################################

chenxiaolong commented on 2011-08-20 21:04

Please update PKGBUILD with version: 1.4.3.4 with md5sum: 27d5ee669a4bd430a8dbf87123448146

tdy commented on 2011-05-07 02:18

it still won't work with the python3 python-qt, but i've fixed it to use the new name of python2-pyqt, thanks

Anonymous comment on 2011-05-07 01:49

python2-qt>=4.3 dependency is broken now, need a fix to python-qt>=4.8

tdy commented on 2011-02-07 23:42

tk is only needed if you decide to use cola's fallback ssh-askpass implementation. I've added it as an optdepend for now because any ssh-askpass handler will work, but I might change it to a hard dependency since it is the "default" ssh-askpass handler.

Anonymous comment on 2011-02-07 20:56

Pushing stopped working for me after a recent update, until I installed tk.
Maybe it should become a dependency?

msquared commented on 2011-01-19 19:20

Can you please adjust the dependencies to require python2-qt instead of pyqt?

Anonymous comment on 2010-10-20 14:03

Here is an updated PKGBUILD that will make this package work with the new python2 layout. http://paste.pocoo.org/show/277984/

This also pulls the latest version, 1.4.2.4.

tdy commented on 2010-07-02 13:59

1.4.2.1