Package Details: git-subrepo-git 0.4.3.r1.g2f68596-2

Git Clone URL: https://aur.archlinux.org/git-subrepo-git.git (read-only, click to copy)
Package Base: git-subrepo-git
Description: Git Submodule Alternative
Upstream URL: https://github.com/ingydotnet/git-subrepo
Licenses: GPL
Conflicts: git-subrepo
Provides: git-subrepo
Submitter: jamesan
Maintainer: arti
Last Packager: arti
Votes: 3
Popularity: 0.004847
First Submitted: 2016-07-10 20:52 (UTC)
Last Updated: 2022-01-17 05:57 (UTC)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

Lucki commented on 2022-01-24 15:32 (UTC)

Thanks! That worked!

arti commented on 2022-01-18 05:59 (UTC)

So, I did some more digging and it looks like stock zsh _git completion script for some reason does not want to register git-subrepo command. You can manually override this using this zstyle in .zshrc

zstyle ':completion:*:*:git:*' user-commands subrepo:'perform git-subrepo operations'

Lucki commented on 2022-01-18 01:40 (UTC)

Only thing is that i have to fully type out git subrepo before tab complete works for it […]

Oh, you're right then it works… seems a bit inconvenient.

arti commented on 2022-01-17 05:59 (UTC)

zsh completions should work, at least they work for me when i run zsh -f to not load my .zshrc and then manualy start comp system with autoload compinit; compinit. Only thing is that i have to fully type out git subrepo before tab complete works for it, this seems to be a problem with stock git completiton. Maintainer line is also now fixed.

Lucki commented on 2022-01-17 01:41 (UTC)

Hey there! Are zsh completions supposed to work? I don't get any when pressing TAB despite seeing a file in the site_functions. And the maintainer in the PKGBUILD is still the old one?

arti commented on 2021-02-18 10:58 (UTC)

Hi! Please apply patch down below to bring this package up to date with upstream project.

Those changes are also available via git here https://git.wut.ee/PKGBUILD/git-subrepo-git

From 2713c6b804e3a5e31ee2e8f18adf0c1bf9367e85 Mon Sep 17 00:00:00 2001
From: Arti Zirk <arti.zirk@gmail.com>
Date: Thu, 18 Feb 2021 12:42:56 +0200
Subject: [PATCH] Cleanup and add shell completions

---
 .SRCINFO           |  9 ++++-----
 PKGBUILD           | 21 +++++++++++++--------
 make-destdir.patch | 24 ------------------------
 3 files changed, 17 insertions(+), 37 deletions(-)
 delete mode 100644 make-destdir.patch

diff --git a/.SRCINFO b/.SRCINFO
index 65b9824..6be6f57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
 pkgbase = git-subrepo-git
-   pkgdesc = Git command is an improvement from git-submodule and git-subtree.
-   pkgver = 0.3.0.r72.g1e79595
+   pkgdesc = Git Submodule Alternative
+   pkgver = 0.4.3.r1.g2f68596
    pkgrel = 1
    url = https://github.com/ingydotnet/git-subrepo
    arch = any
    license = GPL
-   provides = git-subrepo=0.3.0.r72.g1e79595
+   depends = git
+   provides = git-subrepo=0.4.3.r1.g2f68596
    conflicts = git-subrepo
    source = git-subrepo::git+https://github.com/ingydotnet/git-subrepo.git
-   source = make-destdir.patch
    md5sums = SKIP
-   md5sums = ee9d7137bb4fe4b0cc7da8f669e26ddf

 pkgname = git-subrepo-git

diff --git a/PKGBUILD b/PKGBUILD
index e6a42dd..fe14e2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@

 pkgname=git-subrepo-git
 _pkgname=${pkgname%-git}
-pkgver=0.3.0.r72.g1e79595
+pkgver=0.4.3.r1.g2f68596
 pkgrel=1
-pkgdesc="Git command is an improvement from git-submodule and git-subtree."
+pkgdesc='Git Submodule Alternative'
 arch=('any')
 url="https://github.com/ingydotnet/$_pkgname"
 license=('GPL')
 provides=("$_pkgname=$pkgver")
 conflicts=("$_pkgname")
-source=("$_pkgname"::"git+$url.git"
-        make-destdir.patch)
-md5sums=('SKIP'
-         'ee9d7137bb4fe4b0cc7da8f669e26ddf')
+source=("$_pkgname"::"git+$url.git")
+md5sums=('SKIP')
+depends=(git)

 pkgver() {
   cd "$_pkgname"
@@ -24,10 +23,10 @@ pkgver() {
   )
 }

-prepare() {
+build() {
   cd "$_pkgname"

-  patch -p1 < ../make-destdir.patch
+  make compgen
 }

 check() {
@@ -40,4 +39,10 @@ package() {
   cd "$_pkgname"

   make DESTDIR="$pkgdir" PREFIX=/usr install
+
+  install -d -m 0755 "$pkgdir"/usr/share/bash-completion/completions
+  install -C -m 0644 share/completion.bash "$pkgdir"/usr/share/bash-completion/completions/git-subrepo
+
+  install -d -m 0755 "$pkgdir"/usr/share/zsh/site-functions
+  install -C -m 0644 share/zsh-completion/_git-subrepo "$pkgdir"/usr/share/zsh/site-functions/_git-subrepo
 }
diff --git a/make-destdir.patch b/make-destdir.patch
deleted file mode 100644
index 3109f86..0000000
--- a/make-destdir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 1239b9f..764bd65 100644
---- a/Makefile
-+++ b/Makefile
-@@ -15,9 +15,9 @@ SHARE = share
-
- # Install variables:
- PREFIX ?= /usr/local
--INSTALL_LIB  ?= $(shell git --exec-path)
-+INSTALL_LIB  ?= $(DESTDIR)$(shell git --exec-path)
- INSTALL_EXT  ?= $(INSTALL_LIB)/$(NAME).d
--INSTALL_MAN1 ?= $(PREFIX)/share/man/man1
-+INSTALL_MAN1 ?= $(DESTDIR)$(PREFIX)/share/man/man1
-
- # Basic targets:
- default: help
-@@ -36,6 +36,7 @@ test:
-
- # Install support:
- install:
-+  install -C -d -m 0755 $(INSTALL_LIB)/
-   install -C -m 0755 $(LIB) $(INSTALL_LIB)/
-   install -C -d -m 0755 $(INSTALL_EXT)/
-   install -C -m 0755 $(EXTS) $(INSTALL_EXT)/
--
2.30.1

boojum commented on 2017-12-01 14:06 (UTC)

at least one test is failing: test/status.t ............... cat: invalid option -- 'F' Try 'cat --help' for more information. test/status.t ............... No subtests run test/submodule.t ............ ok Test Summary Report ------------------- test/status.t (Wstat: 0 Tests: 0 Failed: 0) Parse errors: No plan found in TAP output Files=31, Tests=266, 108 wallclock secs ( 0.26 usr 0.09 sys + 69.41 cusr 45.42 csys = 115.18 CPU) Result: FAIL make: *** [Makefile:35: test] Error 1 ==> ERROR: A failure occurred in check(). Aborting...

lilydjwg commented on 2017-08-21 13:27 (UTC)

It doesn't build now. The make-destdir.patch is no longer needed.

lilydjwg commented on 2017-08-21 10:19 (UTC)

This package depends on git.

02m commented on 2017-08-21 09:08 (UTC)

Also got the same error as chopps. Needed to install it manually by running: pacaur -U .cache/pacaur/git-subrepo-git/git-subrepo-git-0.3.1.r19.ga7ee886-1-any.pkg.tar