Package Details: gitbook-editor 7.0.12-1

Git Clone URL: https://aur.archlinux.org/gitbook-editor.git (read-only)
Package Base: gitbook-editor
Description: Gitbook Editor - Write and publish books
Upstream URL: https://www.gitbook.com/editor/linux
Keywords: editors
Licenses: custom
Submitter: m4dz
Maintainer: m4dz
Last Packager: m4dz
Votes: 26
Popularity: 0.018969
First Submitted: 2015-11-03 17:24
Last Updated: 2017-08-28 08:14

Dependencies (1)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

m4dz commented on 2017-08-28 08:22

Hi all,

package is now updated to 7.0.12. Sorry for missing intermediate version due to a huge lack of time. I keep it up-to-date from now.

Thanks to all for the mentions ;)

ShalokShalom commented on 2017-08-26 17:29

7.0.12 is current

Triodes commented on 2017-06-12 10:04

Is this package still being maintained?

bachy commented on 2017-04-30 10:29

git book editor is not launching anymore
got an openssl error

[2017-04-30T10:25:09.248Z] [uhub] info: spawning uhub with port 44244
[2017-04-30T10:25:09.254Z] [uhub] info: stderr: /tmp/1493547909216-uhub: /usr/lib/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /tmp/1493547909216-uhub)
/tmp/1493547909216-uhub: /usr/lib/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /tmp/1493547909216-uhub)

see https://bbs.archlinux.org/viewtopic.php?id=225498

cchuang commented on 2017-03-31 23:19

#########################################
# it's 7.0.12.
#########################################
# Maintainer: m4dz <code(at)m4dz(dot)net>

pkgname=gitbook-editor
pkgver=7.0.12
pkgrel=1
pkgdesc="Gitbook Editor - Write and publish books"
arch=('i686' 'x86_64')
url="https://www.gitbook.com/editor/linux"
license=('custom')
depends=('gconf')

source_x86_64=("gitbook-editor-${pkgver}-linux-x64.deb::http://downloads.editor.gitbook.com/download/version/${pkgver}/linux-x64")
source_i686=("gitbook-editor-${pkgver}-linux-ia32.deb::http://downloads.editor.gitbook.com/download/version/${pkgver}/linux-ia32")

md5sums_i686=('7062f2853d7e36d8cb6b0d4937892588')
md5sums_x86_64=('e3943b8216ab262f4101b6be9b64ea26')

prepare() {
bsdtar -xJf data.tar.xz
}

package() {
cp --preserve=mode -r {opt,usr} "${pkgdir}"

find "${pkgdir}" -type d -exec chmod 755 {} +

install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
mv ${pkgdir}/opt/gitbook-editor/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
}

levinit commented on 2017-02-22 04:50

latest version is 7.0.3
http://downloads.editor.gitbook.com/

seifferth commented on 2017-02-16 11:38

I encountered a similar error:
gitbook-editor: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory

Manually installing gconf fixed it for me, so you might consider adding that as a dependency.

ctsidamurray commented on 2016-12-19 22:13

After installation, I get the following error message:

> error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

m4dz commented on 2016-07-12 06:45

Updated, thanks!

rcsilva83 commented on 2016-07-11 20:23

Version 6.0 is out.