Package Details: gitg-git 3.17.1.r115.g84eee97-1

Git Clone URL: https://aur.archlinux.org/gitg-git.git (read-only)
Package Base: gitg-git
Description: A GIT repository viewer based on GTK+ - git checkout
Upstream URL: https://git.gnome.org/browse/gitg/
Licenses: GPL
Conflicts: gitg
Provides: gitg
Submitter: mrspin
Maintainer: eworm
Last Packager: eworm
Votes: 21
Popularity: 0.577428
First Submitted: 2009-02-07 16:47
Last Updated: 2015-09-26 12:22

Latest Comments

donny commented on 2015-09-23 18:34

Probably git://git.gnome.org/libgd should be written in $source array.

amdj commented on 2015-05-26 07:38

Misses gobject-introspection and webkit2gtk as dependency.

eworm commented on 2015-03-04 09:06

autoconf belongs to base-devel group and is expected to be installed.

nebulon commented on 2015-03-04 08:49

Misses autoconf as dependency.

rafi commented on 2014-06-25 15:22

Missing dependency: `libpeas`
Also, had to install `libgit2-git` and `libgit2-glib-git` to satisfy dependency version requirements.

nyoxi commented on 2014-04-24 16:26

There's a missing build-dependency on gnome-common.

garyvdm commented on 2013-10-21 06:02

git versions of gtk3 and vala are no longer required.

garyvdm commented on 2013-07-10 13:44

Here is an updated PKGBUILD: http://fpaste.org/24245/13734634/
Whats diff:
* depends/makedepends on git versions of libgit2-glib, gtk3, and vala
* New depends gtkspell3

garyvdm commented on 2013-05-30 08:12

Where do you get libgit2-glib?

eworm commented on 2012-12-10 11:59

Finally it works... Builds just fine with webkitgtk3 1.10.2-1.

eworm commented on 2012-10-31 08:20

Ok, webkitgtk3 is not ready yet, it needs a patch to enable introspection for webkit2. The upstream bug about this: https://bugs.webkit.org/show_bug.cgi?id=94313

eworm commented on 2012-10-31 07:23

Ok, all dependencies are met, though it still does not build for me. Looks like webkitgkt3 does not install /usr/share/git-1.0/WebKit2-3.0.gir, which it should.

eworm commented on 2012-10-30 15:31

I am working on this, though I still have unmet dependencies. Stay tuned!

sender commented on 2012-07-12 06:17

Please orphan if you are not planning to update this package. Thanks.

cookiecaper commented on 2011-05-22 08:18

Please add --enable-maintainer-mode=no to the configure line. Compilation now fails without this.

cookiecaper commented on 2011-02-08 19:06

Also, one must cd into build/data and make install to avoid a runtime error about a missing schema settings file; this should be added to the PKGBUILD too. Mrspin, please orphan if you are not interested in maintaining this PKGBUILD anymore.

cookiecaper commented on 2011-02-08 18:49

Came here to say the same as the other two, gsettings-desktop-schemas is now required.

Here's a PKGBUILD that fixes it:
http://pastie.org/1541910

Gordin commented on 2011-02-05 14:10

what big_gie said... please fix this ^^

big_gie commented on 2011-01-12 15:02

Should makedepends on community/gsettings-desktop-schemas

Anonymous comment on 2010-05-22 15:11

Good job, thanks :)

Anonymous comment on 2010-05-04 21:36

'gtksourceview2' should be added as a makedep