Package Details: gitlab-ci 8.0.5-1

Git Clone URL: https://aur.archlinux.org/gitlab-ci.git (read-only)
Package Base: gitlab-ci
Description: Continuous integration server for gitlabhq | Coordinator
Upstream URL: http://www.gitlab.com/gitlab-ci
Licenses: MIT
Submitter: Lopo
Maintainer: Lopo
Last Packager: Lopo
Votes: 5
Popularity: 0.010482
First Submitted: 2014-06-05 11:00
Last Updated: 2015-12-08 12:06

Required by (0)

Sources (12)

  • apache-ssl.conf.example
  • apache.conf.example
  • apache2.2-ssl.conf.example
  • apache2.2.conf.example
  • gitlab-ci-8.0.5.tar.gz
  • gitlab-ci-sidekiq.service
  • gitlab-ci-unicorn.service
  • gitlab-ci.logrotate
  • gitlab-ci.target
  • gitlab-ci.tmpfiles.d
  • lighttpd.conf.example
  • nginx-ssl.conf.example

Latest Comments

chris commented on 2015-02-02 19:54

As already posted on the gitlab package, I have created a package for ruby 2.1 on the AUR for the use with gitlab**.
Note that you cannot use it alongside the extra/ruby package, as it is designed as a dropin replacement of extra/ruby.
If you have problems running gitlab under ruby 2.2, it might be worth considering.

https://aur.archlinux.org/pkgbase/ruby-2.1/

Lopo commented on 2015-02-02 14:54

yes, but there are problems:

....
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
....
linux_inet_diag.c: In function ‘rb_thread_blocking_region’:
linux_inet_diag.c:28:2: error: ‘TRAP_BEG’ undeclared (first use in this function)
TRAP_BEG;
^
linux_inet_diag.c:28:2: note: each undeclared identifier is reported only once for each function it appears in
linux_inet_diag.c:30:2: error: ‘TRAP_END’ undeclared (first use in this function)
TRAP_END;
^
Makefile:237: recipe for target 'linux_inet_diag.o' failed
make: *** [linux_inet_diag.o] Error 1

make failed, exit code 2
....
An error occurred while installing raindrops (0.12.0), and Bundler cannot continue.

Kernald commented on 2015-02-02 13:07

gitlab-ci 5.3 cannot run with Ruby 2.2. Do you have any plan to upgrade this package to 5.4?

twiggers commented on 2014-11-28 19:34

@Lopo it doesn't need to run on the same machine.

Lopo commented on 2014-11-23 17:25

@twiggers: https://gitlab.com/gitlab-org/gitlab-ci/blob/master/README.md : Additionally GitLab CI requires: GitLab 6.3+ (to host the repositories you test)

twiggers commented on 2014-11-01 13:09

Gitlab CI shouldn't require gitlab to be installed.

Garagoth commented on 2014-10-30 13:12

Got error during makepkg (line 146):

==> Starting package()...
mv: cannot stat ‘config/database.yml’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

Fixing this (there is an extra underscore (_) char in case, line 98)
allows build to continue.

Garagoth commented on 2014-10-30 12:47

Got error during makepkg:

==> Starting package()...
mv: cannot stat ‘config/database.yml’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...