Package Details: glade-perl 1.007-17

Git Clone URL: https://aur.archlinux.org/glade-perl.git (read-only, click to copy)
Package Base: glade-perl
Description: Gtk2-GladeXML perl bindings for glade 2.x
Upstream URL: https://metacpan.org/release/Gtk2-GladeXML
Licenses: LGPL, PerlArtistic
Submitter: figuepluto
Maintainer: None
Last Packager: figuepluto
Votes: 2
Popularity: 0.044017
First Submitted: 2019-06-11 17:18
Last Updated: 2019-06-11 17:18

Latest Comments

figuepluto commented on 2020-07-25 18:16

@Funkin-Stoopid probably you have old dependencies installed, like glib-perl. Try to rebuild it first then glade-perl

Funkin-Stoopid commented on 2020-07-23 08:57

Hello I have an error when I build the package with i686 arch.

Can't locate Glib/MakeHelper.pm in @INC (you may need to install the Glib::MakeHelper module) (@INC contains: /usr/lib/perl5/5.32/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.32/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.32/core_perl /usr/share/perl5/core_perl) at (eval 9) line 1. BEGIN failed--compilation aborted at (eval 9) line 1.

Checking if your kit is complete... Looks good MakeMaker FATAL: prerequisites not found. Glib not installed Gtk2 not installed

Please install these modules first and rerun 'perl Makefile.PL'. ==> ERROR: A failure occurred in build(). Aborting...

It works with x86_64 and pentium4 arch.

simona commented on 2020-06-23 17:50

thx

figue commented on 2020-06-23 17:13

Hi @simona. Uninstall glade-perl (don't worry if you have other dependencies, just do "pacman -Rdd glade-perl) and then upgrade your system. Then you can compile glade-perl again, with something like: "makepkg -sicf --asdeps"

Cheers

simona commented on 2020-06-23 16:26

l'installazione di perl (5.32.0-1) interrompe la dipendenza 'perl<5.31' richiesta da glade-perl

figue commented on 2019-06-11 17:20

Old package disappeared, so I uploaded it again.

There are several packages which depends on glade-perl.