Package Details: glc-lib 2.5.0-6

Git Clone URL: https://aur.archlinux.org/glc-lib.git (read-only, click to copy)
Package Base: glc-lib
Description: OpenGL Library Class
Upstream URL: http://www.glc-lib.net/
Licenses: LGPL
Submitter: net147
Maintainer: net147
Last Packager: net147
Votes: 20
Popularity: 0.000025
First Submitted: 2010-09-02 10:27 (UTC)
Last Updated: 2022-04-10 11:29 (UTC)

Latest Comments

1 2 Next › Last »

net147 commented on 2022-04-10 11:29 (UTC)

@Durag Updated

Durag commented on 2022-04-09 23:46 (UTC)

I get the following error when trying to build the package: fatal: remote error: The unauthenticated git protocol on port 9418 is no longer supported. Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.

This can be fixed by updating the source URL from git://github.com/laumaya/GLC_lib.git#tag=Version_2_5_0 to git+https://github.com/laumaya/GLC_lib.git#tag=Version_2_5_0

net147 commented on 2018-09-26 14:30 (UTC)

@cpuheater Updated

cpuheater commented on 2018-09-26 14:28 (UTC) (edited on 2018-09-26 14:28 (UTC) by cpuheater)

The PKGBUILD should contain

makedepends=('git')

This is especially important when building in a clean chroot environment.

helmut.fedder commented on 2016-08-02 09:44 (UTC)

makepkg ==> Making package: glc-lib 2.5.0-4 (Tue Aug 2 11:42:58 CEST 2016) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Cloning GLC_lib git repo... Cloning into bare repository '/home/helmut/aur/glc-lib/GLC_lib'... fatal: unable to connect to github.com: github.com[0: 192.30.253.112]: errno=Connection refused ==> ERROR: Failure while downloading GLC_lib git repo Aborting...

gian commented on 2016-06-14 20:18 (UTC)

You can now download the source in a zip file directly from github

haawda commented on 2015-09-01 18:18 (UTC)

md5sum changed to '2201ff537fb63ff9ff230659acf4c6d4'

net147 commented on 2014-04-25 05:08 (UTC)

Updated to use system zlib which fixes the following issue: libpng warning: iCCP: bad parameters to zlib

net147 commented on 2013-03-18 02:11 (UTC)

Fixed.

craig commented on 2013-03-17 22:31 (UTC)

Change qt to qt4 and qmake to qmake-qt4