Package Details: glfw2 2.7.9-3

Git Clone URL: https://aur.archlinux.org/glfw2.git (read-only)
Package Base: glfw2
Description: A free, open source, portable framework for OpenGL application development (LEGACY 2.x)
Upstream URL: http://www.glfw.org/
Licenses: zlib
Submitter: speps
Maintainer: WoefulDerelict
Last Packager: WoefulDerelict
Votes: 33
Popularity: 0.257707
First Submitted: 2013-08-03 01:08
Last Updated: 2017-02-02 06:04

Latest Comments

WoefulDerelict commented on 2016-12-12 19:21

Renfield: Builds locally in my test environments. Output snippits are rarely ever helpful. Please provide me with the entire output of makepkg, preferably in a clean chroot, via a URL pointing to the resource at your preferred text host. gist.github.com would be my suggestion.

Renfield commented on 2016-12-12 01:22

This doesn't build:

x11_window.c: In function ‘translateKey’:
x11_window.c:250:5: warning: ‘XKeycodeToKeysym’ is deprecated [-Wdeprecated-declarations]
key = XKeycodeToKeysym( _glfwLibrary.display, keycode, 1 );
^~~
In file included from ./platform.h:44:0,
from ../internal.h:92,
from x11_window.c:31:
/usr/include/X11/Xlib.h:1687:15: note: declared here
extern KeySym XKeycodeToKeysym(
^~~~~~~~~~~~~~~~
x11_window.c:272:5: warning: ‘XKeycodeToKeysym’ is deprecated [-Wdeprecated-declarations]
key = XKeycodeToKeysym( _glfwLibrary.display, keycode, 0 );
^~~
In file included from ./platform.h:44:0,
from ../internal.h:92,
from x11_window.c:31:
/usr/include/X11/Xlib.h:1687:15: note: declared here
extern KeySym XKeycodeToKeysym(
^~~~~~~~~~~~~~~~
ar -rcs libglfw.a enable.o fullscreen.o glext.o image.o init.o input.o joystick.o stream.o tga.o thread.o time.o window.o x11_enable.o x11_fullscreen.o x11_glext.o x11_init.o x11_joystick.o x11_keysym2unicode.o x11_thread.o x11_time.o x11_window.o
install -d /usr/local/lib
install -c -m 644 libglfw.a /usr/local/lib/libglfw.a
install: cannot create regular file '/usr/local/lib/libglfw.a': Permission denied
make[1]: *** [Makefile.x11:282: install] Error 1
make[1]: Leaving directory '/home/jlm/downloads/glfw2/src/glfw-2.7.9/lib/x11'
make: *** [Makefile:166: x11] Error 2
==> ERROR: A failure occurred in build().
Aborting...

SunRed commented on 2015-06-07 13:34

Please update the PKGBUILD:
source=("http://switch.dl.sourceforge.net/sourceforge/glfw/glfw-$pkgver.tar.bz2")
to
source=("http://heanet.dl.sourceforge.net/project/glfw/glfw/$pkgver/glfw-$pkgver.tar.bz2")

switch.dl.sourceforge.net isn't available anymore.

Ginkgo commented on 2013-09-10 22:36

I think this package should be part of an official repo. GLFW3 and GLFW2 don't interfere with each other and many games may still need the old version.

It's basically the same situation as with the sdl and sdl2 packages.