Package Details: glimpse-editor-git r44038.c39feb48d0-2

Git Clone URL: https://aur.archlinux.org/glimpse-editor-git.git (read-only, click to copy)
Package Base: glimpse-editor-git
Description: Fork of the GNU Image Manipulation Program
Upstream URL: https://glimpse-editor.org/
Keywords: editor image
Licenses: GPL3, LGPL
Conflicts: gimp, glimpse-editor
Provides: gimp, glimpse-editor
Submitter: FabioLolix
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 15
Popularity: 0.082271
First Submitted: 2019-08-30 17:31
Last Updated: 2021-01-23 13:19

Dependencies (32)

Required by (155)

Sources (1)

Latest Comments

1 2 Next › Last »

jmd commented on 2021-01-27 18:44

The latest build fails with the following error.

./configure: line 2790: 5: Bad file descriptor
checking whether --sysconfdir=/etc is declared... (cached) ./configure: line 2826: 5: Bad file descriptor
hB-libexecdir=/usr/bin
./configure: line 2830: syntax error near unexpected token `}'
./configure: line 2830: `} # ac_fn_c_check_decl'
==> ERROR: A failure occurred in build().
    Aborting...
error making: glimpse-editor-git

There are also a lot of other warnings before then, which mostly consist of these two:

warning: The macro `AC_TRY_COMPILE' is obsolete.
warning: The macro `GLIB_GNU_GETTEXT' is obsolete.

FabioLolix commented on 2021-01-23 13:21

I have corrected the build and now pygkt can be removed

FabioLolix commented on 2020-11-25 21:26

All users are pleased to download the new pkgbuild and rebuild the package

FabioLolix commented on 2020-11-19 11:51

I had forgot about that, I'll update this weekend

Trollwut commented on 2020-11-19 09:40

Is there currently work being done in fixing the mentioned "perpetual new update" thing?

squalou commented on 2020-09-18 06:32

@FabioLolix @programegg

this comes from pkgver() function in PKGBUILD

git describe --long --tags | sed 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'

returns things like 'continuous.r0.g4571a15ad7', which is usual for '-git' packages.

PKGBUILD itself includes a defaut value for pkgver=0.1.0.r1080.g6af7a42098, issue being aur helpers always think there is a more recent package,

PKGBUILD should be re-submitted with another default pgver= value I guess, to avoid perpetual update.

programegg commented on 2020-09-15 19:41

@FabioLolix, while the program builds correctly, the versioning needs some work still.

Running this PKGBUILD installs glimpse-editor-git with version number continuous.r0.g156205484f-1. However, when I run yay -Syu this package is marked as having an update to 0.1.0.r1080.g6af7a42098-1.

zoe1337 commented on 2020-08-14 13:28

yes it builds here!

programegg commented on 2020-08-13 15:38

@zoe1337, I'm not sure what's changed recently but I was just able to successfully build/install this package. No more libtool error but there were a ton of libtool warnings.

zoe1337 commented on 2020-07-22 09:21

@programegg my patch that fixes the extradir issue got upstreamed. Now the build fails on my Arch box with
libtool: error: cannot find the library '../../libglimpse-2.0.la' or unhandled argument '../../libglimpse-2.0.la'

and I have no idea how to debug libtool. It builds on Ubuntu.