Package Details: glmark2-git r971.af498f4-1

Git Clone URL: https://aur.archlinux.org/glmark2-git.git (read-only, click to copy)
Package Base: glmark2-git
Description: An OpenGL 2.0 and ES 2.0 benchmark (X11, Wayland, DRM)
Upstream URL: https://github.com/glmark2/glmark2
Licenses: GPL, custom
Conflicts: glmark2
Provides: glmark2
Submitter: devm33
Maintainer: devm33
Last Packager: devm33
Votes: 36
Popularity: 0.000006
First Submitted: 2014-09-17 15:09 (UTC)
Last Updated: 2022-04-16 14:57 (UTC)

Latest Comments

1 2 Next › Last »

devm33 commented on 2022-04-16 15:00 (UTC)

Fixed. Thanks for your info

Maybelline commented on 2022-04-01 18:56 (UTC)

This AUR package (and a couple of my other -git packages) no longer build, and I believe it's due to github changing their security. That page states "If you’re having trouble cloning a repository, make sure the URL starts with ssh://, https://, or git@github.com." and I see git://github.com/... in the PKGBUILD.

When I changed the PKGBUILD to source=("$pkgname"::'git+https://github.com/glmark2/glmark2.git') and run makepkg -si it builds successfully.

devm33 commented on 2021-08-14 07:38 (UTC)

Pushed r960.ca8de51-2 to fix it. Thanks. I accidentally deleted the previous makedepends entirely when rebasing onto glmark2.

ryshglene commented on 2021-08-14 06:51 (UTC)

This is a -git package, and should therefore include the git in makedepends=(). Please include it.

This should allow it to build under clean chroots.

ryshglene commented on 2020-09-19 08:46 (UTC) (edited on 2020-09-19 08:48 (UTC) by ryshglene)

This package already builds with libpng and python cleanly, please consider updating.

diff --git a/PKGBUILD b/PKGBUILD
index f235c66..7f8d52c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
 # Maintainer: Ryo Munakata <afpacket@gmail.com>
 pkgname=glmark2-git
-pkgver=r870.b949d5f
+pkgver=r914.8fdd8b4
 pkgrel=1
 pkgdesc="OpenGL (ES) 2.0 benchmark (X11, Wayland, DRM)"
 arch=('i686' 'x86_64')
 url="https://launchpad.net/glmark2"
 license=('GPL3')
-depends=('libjpeg-turbo' 'libpng12' 'libx11' 'libxcb' 'wayland' 'libgl' 'libgles')
-makedepends=('git' 'python2')
+depends=('libjpeg-turbo' 'libpng' 'libx11' 'libxcb' 'wayland' 'libgl' 'libgles' 'wayland-protocols')
+makedepends=('git' 'python')
 conflicts=('glmark2')
 provides=('glmark2')
 source=(
@@ -31,13 +31,13 @@ prepare() {

 build() {
     cd "${srcdir}/${pkgname}"
-    python2 ./waf configure \
+    python ./waf configure \
         --prefix=/usr \
         --with-flavors=${GM2_FLAVORS}
-    python2 ./waf -j4
+    python ./waf -j4
 }

 package() {
     cd "${srcdir}/${pkgname}"
-    DESTDIR="${pkgdir}" python2 ./waf install
+    DESTDIR="${pkgdir}" python ./waf install
 }

Score_Under commented on 2019-01-12 16:38 (UTC)

Seems to be missing a dependency on libpng

devm33 commented on 2018-10-29 01:42 (UTC)

@vedg fixed and push. Thanks.

vedg commented on 2018-10-24 16:32 (UTC)

glmark2 builds and runs without the patch. The issue has been fixed differently upstream (see https://github.com/glmark2/glmark2/pull/19). Please remove the obsolete patch.

drmargarido commented on 2018-01-06 05:19 (UTC) (edited on 2018-01-06 05:29 (UTC) by drmargarido)

During the package step I got a encoding error in the python script -> "UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 27: ordinal not in range(128)"

Fix: Changed all python2 to python and it worked

Edit: It worked well when I cloned directly from the git repo. Only happens in the current snapshot.

mgw commented on 2017-01-30 21:40 (UTC)

Could you add aarch64 to supported architectures? I can confirm that it works.