Package Details: globalprotect-openconnect-git 1.4.8+2snapshot.g0adeaf9-1

Git Clone URL: https://aur.archlinux.org/globalprotect-openconnect-git.git (read-only, click to copy)
Package Base: globalprotect-openconnect-git
Description: A GlobalProtect VPN client (GUI) for Linux based on Openconnect and built with Qt5, supports SAML auth mode. (development version)
Upstream URL: https://github.com/yuezk/GlobalProtect-openconnect
Keywords: globalprotect openconnect saml vpn
Licenses: GPL3
Conflicts: globalprotect-openconnect
Provides: globalprotect-openconnect, gpclient, gpservice
Submitter: yuezk
Maintainer: yuezk
Last Packager: yuezk
Votes: 2
Popularity: 0.008070
First Submitted: 2021-10-16 07:43 (UTC)
Last Updated: 2022-06-14 13:28 (UTC)

Latest Comments

yuezk commented on 2022-05-08 13:58 (UTC)

@kyechou Problem resolved.

kyechou commented on 2022-03-04 14:56 (UTC)

Hi @yuezk, yes, exactly! Thanks @zayatura for the explanation.

zayatura commented on 2022-03-04 08:52 (UTC)

@yuezk

What do you mean by providing 'globalprotect-openconnect'? Should I need to add 'globalprotect-openconnect' into the provides field?

The guidelines gives an example on this (https://wiki.archlinux.org/title/VCS_package_guidelines): "Include what the package conflicts with and provides (e.g. for fluxbox-git: conflicts=('fluxbox') and provides=('fluxbox'))."

This helps pacman or an AUR helper know that in case the user installs or a package requires "globalprotect-openconnect", there are multiple packages and can, for example, give a prompt.

yuezk commented on 2022-03-04 04:02 (UTC)

Hi @kyechou, I will migrate it to pull the code from the Git repo.

What do you mean by providing 'globalprotect-openconnect'? Should I need to add 'globalprotect-openconnect' into the provides field?

And this package is for the purpose of the snapshot version, so it's not that stable. It wasn't intended to be used by normal users widely. For most of the users, it is recommended to use the community version: https://archlinux.org/packages/community/x86_64/globalprotect-openconnect/

osimarr commented on 2022-03-02 18:47 (UTC) (edited on 2022-03-02 18:50 (UTC) by osimarr)

On top of what @togusa's patch, this extra diff also creates a better versioning for a git package:

 pkgver() {
-    cd $srcdir/$_pkgname-*/
-    cat VERSION VERSION_SUFFIX
+    cd $srcdir/$_pkgname/
+    printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
 }

kyechou commented on 2022-03-02 14:49 (UTC)

Hi @yuezk, the script still doesn't seem to be pulling from the Git repository. Perhaps you'd like to check out https://wiki.archlinux.org/title/VCS_package_guidelines? Also, the package should probably provide 'globalprotect-openconnect'.

yuezk commented on 2022-03-02 14:00 (UTC)

@kyechou Will do.

togusa commented on 2022-03-02 08:09 (UTC)

This patch works for me:

diff --git a/PKGBUILD b/PKGBUILD
index 7a7966d..a817ad5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,16 +13,16 @@ makedepends=(cmake)
 conflicts=('globalprotect-openconnect')
 provides=('gpclient' 'gpservice')

-source=("${_pkgname}.tar.gz")
+source=("${_pkgname}::git+https://github.com/yuezk/    GlobalProtect-openconnect.git")
 sha256sums=('SKIP')

 pkgver() {
-    cd $srcdir/$_pkgname-*/
+    cd $srcdir/$_pkgname/
     cat VERSION VERSION_SUFFIX
 }

 build() {
-    cd $srcdir/${_pkgname}-*/
+    cd $srcdir/${_pkgname}/
     cmake -B build \
         -DCMAKE_BUILD_TYPE=Release \
         -DCMAKE_CXX_FLAGS_RELEASE=-s
@@ -30,6 +30,6 @@ build() {
 }

 package() {
-    cd $srcdir/${_pkgname}-*/
+    cd $srcdir/${_pkgname}/
     make DESTDIR="$pkgdir/" install -C build
 }
diff --git a/globalprotect-openconnect.tar.gz b/globalprotect-openconnect.tar.gz
deleted file mode 100644
index e82150e..0000000
Binary files a/globalprotect-openconnect.tar.gz and /dev/null differ

kyechou commented on 2022-03-01 18:06 (UTC)

Hi @yuezk, would you mind removing the tarball and pulling the source from the repository instead?

tleydxdy commented on 2022-01-27 22:23 (UTC)

for some reason the version requirement openconnect>=8.0.0 is causing pacman to not recognize openconnect-git as a valid dependency and creates a conflict. can you remove the version from it?