Package Details: glslang-git 13.0.0.r15.g323836e4-1

Git Clone URL: https://aur.archlinux.org/glslang-git.git (read-only, click to copy)
Package Base: glslang-git
Description: OpenGL and OpenGL ES shader front end and validator, git version
Upstream URL: https://github.com/KhronosGroup/glslang
Keywords: graphics opengl rendering vulkan
Licenses: BSD
Conflicts: glslang
Provides: glslang
Submitter: jsjolund
Maintainer: bwrsandman
Last Packager: bwrsandman
Votes: 10
Popularity: 0.002237
First Submitted: 2016-01-27 00:35 (UTC)
Last Updated: 2023-09-14 02:56 (UTC)

Dependencies (5)

Required by (155)

Sources (1)

Latest Comments

1 2 Next › Last »

wilkins commented on 2023-12-23 11:05 (UTC)

@baby-void, i ended up installing spirv-tools-tkg-git from chaotic-aur repo.

baby-void commented on 2023-11-21 20:33 (UTC)

wilkins Have you solved the issue? I have the same and I'm lost at solving it.

wilkins commented on 2023-10-15 14:00 (UTC)

Missing dependencies: -> spirv-tools>=2023.2

However,

aur/spirv-tools-git 2:2023.4.r3803.a996591-1 (+6 0.00) (Installed: 2:2023.5.r3819.661f429-1)

bwrsandman commented on 2023-09-14 03:00 (UTC) (edited on 2023-09-14 03:05 (UTC) by bwrsandman)

Added ALLOW_EXTERNAL_SPIRV_TOOLS to the package. However, extra/spirv-tools is out of date but spirv-tools-git works.

bazza commented on 2023-09-13 13:14 (UTC)

CMake Error at CMakeLists.txt:280 (message):
  ENABLE_OPT set but SPIR-V tools not found.  Please run
  update_glslang_sources.py, set the ALLOW_EXTERNAL_SPIRV_TOOLS option to use
  a local install of SPIRV-Tools, or set ENABLE_OPT=0.

electric-tao commented on 2023-05-26 07:24 (UTC) (edited on 2023-05-26 07:26 (UTC) by electric-tao)

Please note that the default branch of the github repository is now 'main' and not 'master'. You need to fix in PKGBUILD git describe ... --excludemain-tot

DavTheRaveUK commented on 2023-03-12 19:46 (UTC)

Hello there, I need to install this version of glslang (glslang-git for the program video2x) and the other version of glslang (glslang for the program mpv) but there is conflict between the two versions of glslang. Is there a workaround?

Thanks, David.

damiandixon commented on 2022-03-17 16:04 (UTC)

github has disabled git://...

I have changed source to:

  source=("git+${url}.git")

Thanks

SamLukeYes commented on 2022-03-10 01:18 (UTC) (edited on 2022-03-10 02:10 (UTC) by SamLukeYes)

I'm getting a weird package version like this: sdk.1.3.204.0.r14.g538231d8-1

Paru thinks this version is lower than 8.13.3743.r232.g6a6e311d-1, so it keeps notifying of its update:(

UPDATE: It was fixed just now. Thanks!

bwrsandman commented on 2020-12-27 20:04 (UTC)

Can't repro. CMAKE_INSTALL_LIBDIR is set to 'lib' and CMAKE_INSTALL_PREFIX is '/usr'

$ ls pkg/glslang-git/usr/   
bin  include  lib  share

Do you have something special about your setup that would change this?