Package Details: gmdb2-git 0.7.r220.gd6f5745-1

Git Clone URL: https://aur.archlinux.org/mdbtools-git.git (read-only)
Package Base: mdbtools-git
Description: Graphical viewer for Microsoft Access database files
Upstream URL: https://github.com/brianb/mdbtools
Licenses: GPL
Conflicts: gmdb2
Provides: gmdb2
Submitter: cameel
Maintainer: bidulock
Last Packager: bidulock
Votes: 9
Popularity: 0.019646
First Submitted: 2014-01-07 16:24
Last Updated: 2017-04-06 10:49

Dependencies (13)

Required by (2)

Sources (1)

Latest Comments

1 2 Next › Last »

cameel commented on 2014-09-12 00:44

Strange. I just tried to reproduce this error but to no avail. It was failing for me in January and I added a patch back then. But when I was updating the package in March it built just fine (and still does) so I assumed the problem was solved and removed it.

The patch seems superfluous (the missing option is already declared elsewhere as I pointed out in their bugtracker: https://github.com/brianb/mdbtools/issues/37#issuecomment-31742729) and I guess it's not really a bug in mdbtools but something in autotools or gnome-doc-utils or elsewhere in the system that's broken on some systems (is your system up to date?).

But anyway, since I can't trace it (any hints?) I have restored the patch. I'll keep it in until they either merge it or find a better workaround.


I have also changed the way pkgver is constructed to include 'r' before revision number as the wiki currently suggests. Pacman thinks it's an older version and treats it as a downgrade. I suspect that this may cause some wrappers (like yaourt) not to report that the new version is availab.e

richardd commented on 2014-09-11 11:11

I get the same error as @natrio

See here for fix: https://github.com/brianb/mdbtools/issues/37#issuecomment-29264591

You need to put the patch into the pkgbuild before it runs autoconf (just patching the file will be overwritten).

richardd commented on 2014-09-11 11:10

I get the same error as @natrio,

to fix do put
```
--- configure.ac 2013-10-25 03:48:51.000000000 +0800
+++ configure.ac 2013-11-26 11:19:11.300378900 +0800
@@ -194,10 +194,12 @@
enable_gtk_doc=no
fi
fi

AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+AM_CONDITIONAL(HAVE_GNOME_DOC_UTILS, test x$enable_gtk_doc = xyes)
+AM_CONDITIONAL(ENABLE_SK, test x$enable_scrollkeeper = xyes)

##################################################
# Check for txt2man
##################################################
```
into sc_error_fix.patch and modify the pkgbuild to patch before configuring.

natrio commented on 2014-05-08 06:10

mdbtools-git 0.7.147.g95cf90d-1
> configure: error: conditional "ENABLE_SK" was never defined.
> Usually this means the macro was only invoked conditionally.

The options --disable-gmdb2 --disable-scrollkeeper ended with same error.

cameel commented on 2014-04-13 20:01

pkg-config is in base-devel group, which, according to the wiki (https://wiki.archlinux.org/index.php/makepkg#Usage) is assumed to be installed on your system if you're using makepkg. Even official packages do not list stuff from base and base-devel as explicit dependencies.

But thanks for letting us know. It might help others missing this package for whatever reason.

cameel commented on 2014-04-13 19:59

pkg-config is in base-devel group, which, according to the wiki (https://wiki.archlinux.org/index.php/makepkg#Usage) is assumed to be installed on your system if you're using makepkg. Official packages do not list stuff from base and base-devel as explicit dependencies.

But thanks for letting us know. It might help others missing this package for whatever reason.

eldog commented on 2014-04-13 09:30

I needed to install pkg-config to get it to work, as I had compilation due to the lack of the necessary macros like https://github.com/brianb/mdbtools/issues/48
and as explained in http://www.coffeecode.net/archives/208-PKG_CHECK_MODULES-syntax-error-near-unexpected-token-DEPS,.html

cameel commented on 2014-04-06 12:28

.desktop file added.

If anyone needs anything else, let me know in comments. This package is missing some stuff with respect to non-git one - like unixodbc support - because I didn't need it myself.

digifuzzy commented on 2014-03-27 14:23

gmdb2.desktop file is not installed
desktop file is available at src/gmdb2/gmdb.desktop in git repo

cameel commented on 2014-03-25 10:19

Package updated:
- Added the missing dependency on gnome-doc-utils
- Removed the patch that disables doc generation. The package now builds without it