Package Details: gmpc-lyricwiki 11.8.16-4

Git Clone URL: https://aur.archlinux.org/gmpc-lyricwiki.git (read-only)
Package Base: gmpc-lyricwiki
Description: A new plugin that uses the REST api of lyricwiki to fetch lyrics.
Upstream URL: http://gmpc.wikia.com/
Licenses: GPL
Submitter: None
Maintainer: Foucault
Last Packager: Foucault
Votes: 9
Popularity: 0.000010
First Submitted: 2008-11-12 00:03
Last Updated: 2015-06-13 10:43

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Foucault commented on 2014-04-14 15:50

Thanks! pkg-config is in base-devel group so it should not be listed in depends/makedepends. You should have already installed base-devel before building packages.

rudy.matela commented on 2014-04-14 13:51

pkgconfig is also missing:

configure: error: in `.../gmpc-lyricwiki/src/gmpc-lyricwiki-11.8.16':
configure: error: The pkg-config script could not be found or is too old. Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

depends=('libmpd>=0.20.0' 'libxml2' 'gmpc>=11.8.16' 'intltool>=0.21' 'pkg-config')

rudy.matela commented on 2014-04-14 13:49

Intltool >= 0.21 is needed for this package. Check the makepkg output:

$ makepkg
...
checking for intltool >= 0.21... ./configure: line 3902: intltool-update: command not found
found
configure: error: Your intltool is too old. You need intltool 0.21 or later.


Should be added to the depends line:

depends=('libmpd>=0.20.0' 'libxml2' 'gmpc>=11.8.16' 'intltool>=0.21')

Foucault commented on 2011-04-11 17:06

Strange, I tested the PKGBUILD yesterday and it was working. Oh well, thanks for that!

the_isz commented on 2011-04-11 16:20

The source link is wrong. It should be

http://download.sarine.nl/Programs/gmpc/0.20.0/gmpc-lyricwiki-0.20.0.tar.gz

Foucault commented on 2011-04-10 10:07

Updated to upstream.