Package Details: gmsh-docs 4.5.1-1

Git Clone URL: (read-only, click to copy)
Package Base: gmsh
Description: TXT, HMTL and PDF doc for Gmsh
Upstream URL:
Licenses: GPL2
Submitter: S1G1
Maintainer: gborzi
Last Packager: gborzi
Votes: 50
Popularity: 0.005121
First Submitted: 2006-04-04 23:31
Last Updated: 2019-12-28 14:45

Latest Comments

1 2 3 4 5 6 ... Next › Last »

PrinceMachiavell commented on 2019-11-19 21:21

Does this package specifically require python 3.7? If not there is probably a better solution than hardcoding directories in the PKGBUILD.

chilichiller commented on 2019-11-07 15:45

@gborzi Found it, gmsh runs fine again. Thank for answering my noob questions :)

gborzi commented on 2019-11-07 13:05

@chilichiller The package must be recompiled with the new opencascade library.

chilichiller commented on 2019-11-07 12:58

Upgrading the opencascade package to version 7.4.0 makes gmsh fail on startup with the message: "gmsh: symbol lookup error:gmsh:undefined symbol:_ZN28BRepAlgoAPI_BooleanOperation9IsDeletedERK12TopoDS_Shape"

Manual downgrade of opencascade to 7.3.0 helps. Apparently some methods in the opencascae library have changed.

gborzi commented on 2019-09-24 15:15

@xantares The compilation stopped with the same error. I've removed that line and now it works fine. Thanks for your message.

gborzi commented on 2019-09-24 15:03

@xantares I'm rebuilding the package to check the error, but it'll take some time. Did you use any AUR helper? If so, can you try to rebuild using "makepkg -s"?

xantares commented on 2019-09-24 14:55

hi, the build fails with:

-- Installing: /home/devel/.cache/aurman/gmsh/pkg/gmsh/usr/share/man/man1/gmsh.1

mv: cannot stat '/home/devel/.cache/aurman/gmsh/pkg/gmsh/usr/lib64': No such file or directory

==> ERROR: A failure occurred in package_gmsh().

I think the line:

mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"

is useless now, maybe a change in cmake ?

Maybe CMAKE_INSTALL_LIBDIR defaults to lib on arch now ?

chilichiller commented on 2019-08-05 19:31

@gborzi Thanks for your swift response and the instructions how to get the checksum for the downloaded files. The first checksum has been wrong, the other two identical, so the file gmsh-4.4.1-source.tgz has been affected. I deleted and downloaded the file again and the first checksum changed (still wrong). On the third attempt it was correct and I could install the update. Very strange, but all of that happened from a coorporate network, so possibly there was something fishy with the company's proxy server and the file got corrupted. Just checked at home on another machine and it updated witout any issue. So never mind and thank you guys for helping!

gborzi commented on 2019-08-05 18:56

@lahwaacz I don't expect that users run makepkg -g and fill the checksums. Following chilichiller message, I've checked that the checksum in the PKGBUILD for gmsh-4.4.1-source.tgz is correct. Then asked to see the output of the same command on chilichiller system, to see if he has downloaded a corrupted version of the source.

lahwaacz commented on 2019-08-05 17:39

@gborzi Users are not expected to run makepkg -g when building the package, you as the packager should ensure that the correct checksums for the current version are present in the PKGBUILD. If users blindly used makepkg -g to build all their packages, there would be no point to have the checksums at all, because there would be no verification in the first place.