Package Details: gnash-git 0.8.11.r22377.g2b3bded-1

Git Clone URL: https://aur.archlinux.org/gnash-git.git (read-only, click to copy)
Package Base: gnash-git
Description: The GNU SWF Player based on GameSWF - git development version
Upstream URL: http://www.gnu.org/software/gnash/
Licenses: GPL3
Conflicts: gnash, gnash-common, gnash-gtk
Provides: gnash, gnash-common, gnash-gtk
Replaces: gnash, gnash-common, gnash-gtk
Submitter: smoge
Maintainer: DaarkWel (iamtakingiteasy)
Last Packager: christoph.gysin
Votes: 66
Popularity: 0.000003
First Submitted: 2011-05-26 21:04
Last Updated: 2016-08-15 16:08

Dependencies (25)

Required by (1)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

daniel_shub commented on 2016-02-01 14:31

The problem with that is the last "release" v 8.10 is from Feb 2012 (https://www.gnu.org/software/gnash/download.html). As far as I can tell, everything since then is lumped into the "master" branch.

applebloom commented on 2016-01-31 18:09

Hmm, you're right. It should download a certain release (tag).

daniel_shub commented on 2016-01-28 22:00

Shouldn't this be merged with the gnash package (https://aur.archlinux.org/packages/gnash/) since they both are built off the same source in essentially the same way?

daniel_shub commented on 2016-01-28 21:57

I do not see how this package is different from gnash-git: https://aur.archlinux.org/packages/gnash-git/. They both pull the same git source and have nearly identical build and package functions. As this package seems to technically be a git package with a made up version number, shouldn't the maintenance efforts be combine with gnash-git?

applebloom commented on 2016-01-24 18:53

I guess I could.

GI_Jack commented on 2016-01-22 01:20

#applebloom, do you want to maintain this package?

EndlessEden commented on 2016-01-06 02:22

Gnash wont build with Git versions of FFMPEG.

ffmpeg/VideoConverterFfmpeg.cpp:60:1: error: ‘PixelFormat’ does not name a type PixelFormat

repeats.

GI_Jack commented on 2016-01-05 15:23

updated per applebloom's fix.

applebloom commented on 2015-12-28 03:04

You can add this line in the package function to fix the problem:

sed -i '36s/.*/ bool adjacent_tokens_only() const { return false; }/' libbase/accumulator.h

The issue was that this function adjacent_tokens_only was added in an AB class in boost as pure virtual, so it needed to be implemented in a derived class in Gnash.

GI_Jack commented on 2015-12-19 04:45

your guess is as good as mine. If you figure it out let me know. I get the same errror.